aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/folks/Makefile1
-rw-r--r--net-im/libtelepathy/Makefile19
-rw-r--r--net-im/libtelepathy/pkg-plist1
-rw-r--r--net-im/papyon/Makefile2
-rw-r--r--net-im/telepathy-farsight/Makefile12
-rw-r--r--net-im/telepathy-farsight/pkg-plist1
-rw-r--r--net-im/telepathy-gabble/Makefile15
-rw-r--r--net-im/telepathy-gabble/pkg-plist5
-rw-r--r--net-im/telepathy-glib/Makefile8
-rw-r--r--net-im/telepathy-glib/pkg-plist1
-rw-r--r--net-im/telepathy-haze/Makefile10
-rw-r--r--net-im/telepathy-haze/pkg-plist1
-rw-r--r--net-im/telepathy-idle/Makefile11
-rw-r--r--net-im/telepathy-idle/pkg-plist1
-rw-r--r--net-im/telepathy-mission-control/Makefile11
-rw-r--r--net-im/telepathy-mission-control/pkg-plist4
-rw-r--r--net-im/telepathy-python/Makefile17
-rw-r--r--net-im/telepathy-salut/Makefile11
-rw-r--r--net-im/telepathy-salut/pkg-plist3
19 files changed, 67 insertions, 67 deletions
diff --git a/net-im/folks/Makefile b/net-im/folks/Makefile
index a0c9c65045cc..9d10c6cbed32 100644
--- a/net-im/folks/Makefile
+++ b/net-im/folks/Makefile
@@ -39,7 +39,6 @@ PLIST_SUB= LIBVER=25 VERSION=33
CONFIGURE_ARGS+=--enable-libsocialweb-backend=no
#.endif
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|^build_old_libs=yes|build_old_libs=no|g' \
${WRKDIR}/gnome-libtool
diff --git a/net-im/libtelepathy/Makefile b/net-im/libtelepathy/Makefile
index 8427bb0a0df0..e66e84760d23 100644
--- a/net-im/libtelepathy/Makefile
+++ b/net-im/libtelepathy/Makefile
@@ -3,25 +3,22 @@
PORTNAME= libtelepathy
PORTVERSION= 0.3.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-im devel
MASTER_SITES= http://telepathy.freedesktop.org/releases/${PORTNAME}/
MAINTAINER= gnome@FreeBSD.org
COMMENT= Flexible Communications Framework
-LIB_PC_DEPENDS= dbus-glib-1.pc:${PORTSDIR}/devel/dbus-glib
-
-BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
-LIB_DEPENDS= telepathy-glib.0:${PORTSDIR}/net-im/telepathy-glib
-
-BUILD_DEPENDS+= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|g}
-RUN_DEPENDS+= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|g}
+LIB_DEPENDS= libtelepathy-glib.so:${PORTSDIR}/net-im/telepathy-glib \
+ libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
USE_PYTHON_BUILD= yes
-USES= gmake pkgconfig
+USES= gmake libtool:keepla pkgconfig
USE_LDCONFIG= yes
-USE_GNOME= gnomehack glib20 ltverhack
-USE_AUTOTOOLS= libtool
+USE_GNOME= gnomehack glib20 libxslt:build
+GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib `pkg-config --libs glib-2.0 telepathy-glib`
.include <bsd.port.mk>
diff --git a/net-im/libtelepathy/pkg-plist b/net-im/libtelepathy/pkg-plist
index 726f9acff55d..446dbcdd7588 100644
--- a/net-im/libtelepathy/pkg-plist
+++ b/net-im/libtelepathy/pkg-plist
@@ -48,6 +48,7 @@ lib/libtelepathy.a
lib/libtelepathy.la
lib/libtelepathy.so
lib/libtelepathy.so.2
+lib/libtelepathy.so.2.7.1
libdata/pkgconfig/libtelepathy.pc
@dirrm include/telepathy-1.0/libtelepathy
@dirrm include/telepathy-1.0
diff --git a/net-im/papyon/Makefile b/net-im/papyon/Makefile
index 2eedbab86d23..8d333c65b3e1 100644
--- a/net-im/papyon/Makefile
+++ b/net-im/papyon/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= http://www.freedesktop.org/software/${PORTNAME}/releases/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= gnome@FreeBSD.org
-COMMENT= A fork of pymsn to support the telepathy MSN connection manager
+COMMENT= Fork of pymsn to support the telepathy MSN connection manager
BUILD_DEPENDS= py*-openssl>0:${PORTSDIR}/security/py-openssl \
${PYTHON_SITELIBDIR}/Crypto/Hash/SHA.py:${PORTSDIR}/security/py-pycrypto \
diff --git a/net-im/telepathy-farsight/Makefile b/net-im/telepathy-farsight/Makefile
index 6c34f4936181..b7f2d2405af8 100644
--- a/net-im/telepathy-farsight/Makefile
+++ b/net-im/telepathy-farsight/Makefile
@@ -4,22 +4,22 @@
PORTNAME= telepathy-farsight
PORTVERSION= 0.0.19
+PORTREVISION= 1
CATEGORIES= net-im
MASTER_SITES= http://telepathy.freedesktop.org/releases/${PORTNAME}/
MAINTAINER= gnome@FreeBSD.org
COMMENT= Farsight Connection Manager for Telepathy Framework
-LIB_DEPENDS= dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
- telepathy-glib:${PORTSDIR}/net-im/telepathy-glib \
- gstfarsight-0.10:${PORTSDIR}/net-im/farsight2
+LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
+ libtelepathy-glib.so:${PORTSDIR}/net-im/telepathy-glib \
+ libgstfarsight-0.10.so:${PORTSDIR}/net-im/farsight2
GNU_CONFIGURE= yes
-USES= gmake pkgconfig
+USES= gmake libtool:keepla pkgconfig
USE_LDCONFIG= yes
USE_PYTHON= yes
-USE_AUTOTOOLS= libtool
-USE_GNOME= gnomehack glib20 ltverhack libxslt:build
+USE_GNOME= gnomehack glib20 libxslt:build
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
diff --git a/net-im/telepathy-farsight/pkg-plist b/net-im/telepathy-farsight/pkg-plist
index 0c5f246bd13f..1376a0b108ec 100644
--- a/net-im/telepathy-farsight/pkg-plist
+++ b/net-im/telepathy-farsight/pkg-plist
@@ -4,6 +4,7 @@ lib/libtelepathy-farsight.a
lib/libtelepathy-farsight.la
lib/libtelepathy-farsight.so
lib/libtelepathy-farsight.so.0
+lib/libtelepathy-farsight.so.0.1.6
%%PYTHON_SITELIBDIR%%/tpfarsight.a
%%PYTHON_SITELIBDIR%%/tpfarsight.la
%%PYTHON_SITELIBDIR%%/tpfarsight.so
diff --git a/net-im/telepathy-gabble/Makefile b/net-im/telepathy-gabble/Makefile
index 9f641baa7a4e..165da2194710 100644
--- a/net-im/telepathy-gabble/Makefile
+++ b/net-im/telepathy-gabble/Makefile
@@ -3,6 +3,7 @@
PORTNAME= telepathy-gabble
PORTVERSION= 0.16.6
+PORTREVISION= 1
CATEGORIES= net-im
MASTER_SITES= http://telepathy.freedesktop.org/releases/${PORTNAME}/
@@ -11,18 +12,18 @@ COMMENT= Jabber Connection Manager for Telepathy Framework
BUILD_DEPENDS= telepathy-glib>=0.18.0:${PORTSDIR}/net-im/telepathy-glib \
${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
-LIB_DEPENDS= soup-2.4:${PORTSDIR}/devel/libsoup \
- nice:${PORTSDIR}/net-im/libnice \
- telepathy-glib:${PORTSDIR}/net-im/telepathy-glib \
- dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
- uuid:${PORTSDIR}/misc/e2fsprogs-libuuid \
- loudmouth-1:${PORTSDIR}/net-im/loudmouth
+LIB_DEPENDS= libsoup-2.4.so:${PORTSDIR}/devel/libsoup \
+ libnice.so:${PORTSDIR}/net-im/libnice \
+ libtelepathy-glib.so:${PORTSDIR}/net-im/telepathy-glib \
+ libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
+ libuuid.so:${PORTSDIR}/misc/e2fsprogs-libuuid \
+ libloudmouth-1.so:${PORTSDIR}/net-im/loudmouth
RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
PORTSCOUT= limitw:1,even
GNU_CONFIGURE= yes
-USES= pathfix pkgconfig gmake
+USES= gmake libtool pathfix pkgconfig
USE_GNOME= glib20 libxslt:build
USE_SQLITE= yes
USE_OPENSSL= yes
diff --git a/net-im/telepathy-gabble/pkg-plist b/net-im/telepathy-gabble/pkg-plist
index 17ba573ea1ba..ed4562873959 100644
--- a/net-im/telepathy-gabble/pkg-plist
+++ b/net-im/telepathy-gabble/pkg-plist
@@ -2,17 +2,14 @@ bin/telepathy-gabble-xmpp-console
man/man8/telepathy-gabble.8.gz
lib/telepathy/gabble-0/lib/libgabble-plugins-%%PVERSION%%.so
lib/telepathy/gabble-0/lib/libgabble-plugins.a
-lib/telepathy/gabble-0/lib/libgabble-plugins.la
lib/telepathy/gabble-0/lib/libgabble-plugins.so
lib/telepathy/gabble-0/lib/libwocky-telepathy-gabble-%%PVERSION%%.so
lib/telepathy/gabble-0/lib/libwocky.a
-lib/telepathy/gabble-0/lib/libwocky.la
lib/telepathy/gabble-0/lib/libwocky.so
-lib/telepathy/gabble-0/plugins/libconsole.la
lib/telepathy/gabble-0/plugins/libconsole.so
-lib/telepathy/gabble-0/plugins/libgateways.la
lib/telepathy/gabble-0/plugins/libgateways.so
libexec/telepathy-gabble
+man/man8/telepathy-gabble.8.gz
share/dbus-1/services/org.freedesktop.Telepathy.ConnectionManager.gabble.service
%%DOCSDIR%%/muc-bytestream.html
%%DOCSDIR%%/olpc.html
diff --git a/net-im/telepathy-glib/Makefile b/net-im/telepathy-glib/Makefile
index 0d8b87999cc4..55e063ed150f 100644
--- a/net-im/telepathy-glib/Makefile
+++ b/net-im/telepathy-glib/Makefile
@@ -3,6 +3,7 @@
PORTNAME= telepathy-glib
PORTVERSION= 0.20.2
+PORTREVISION= 1
CATEGORIES= net-im
MASTER_SITES= http://telepathy.freedesktop.org/releases/${PORTNAME}/
@@ -10,15 +11,14 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= GLib utility library for the Telepathy framework
BUILD_DEPENDS= vala-vapigen>=0.20.0:${PORTSDIR}/lang/vala-vapigen
-LIB_DEPENDS= dbus-glib-1:${PORTSDIR}/devel/dbus-glib
+LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
RUN_DEPENDS= vapigen:${PORTSDIR}/lang/vala-vapigen
PORTSCOUT= limitw:1,even
-USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
-USES= gmake pathfix pkgconfig
-USE_GNOME= glib20 gnomehier introspection:build libxslt:build ltverhack
+USES= gmake libtool:keepla pathfix pkgconfig
+USE_GNOME= glib20 gnomehier introspection:build libxslt:build
USE_PYTHON_BUILD= yes
MAKE_JOBS_UNSAFE= yes
GNU_CONFIGURE= yes
diff --git a/net-im/telepathy-glib/pkg-plist b/net-im/telepathy-glib/pkg-plist
index 49bcde053010..b468d5884117 100644
--- a/net-im/telepathy-glib/pkg-plist
+++ b/net-im/telepathy-glib/pkg-plist
@@ -167,6 +167,7 @@ lib/libtelepathy-glib.a
lib/libtelepathy-glib.la
lib/libtelepathy-glib.so
lib/libtelepathy-glib.so.0
+lib/libtelepathy-glib.so.0.78.2
libdata/pkgconfig/telepathy-glib.pc
share/gir-1.0/TelepathyGLib-0.12.gir
share/gtk-doc/html/telepathy-glib/TpBaseCallChannel.html
diff --git a/net-im/telepathy-haze/Makefile b/net-im/telepathy-haze/Makefile
index a6333041ab9c..8e7dec7d8f64 100644
--- a/net-im/telepathy-haze/Makefile
+++ b/net-im/telepathy-haze/Makefile
@@ -11,13 +11,13 @@ MASTER_SITES= http://telepathy.freedesktop.org/releases/telepathy-haze/
MAINTAINER= gnome@FreeBSD.org
COMMENT= Libpurple connection manager for telepathy
-BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
-LIB_DEPENDS= purple:${PORTSDIR}/net-im/libpurple \
- idn:${PORTSDIR}/dns/libidn \
- telepathy-glib:${PORTSDIR}/net-im/telepathy-glib
+LIB_DEPENDS= libpurple.so:${PORTSDIR}/net-im/libpurple \
+ libidn.so:${PORTSDIR}/dns/libidn \
+ libtelepathy-glib.so:${PORTSDIR}/net-im/telepathy-glib
CPPFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
-USES= gmake pkgconfig
+USES= gmake libtool pkgconfig
+USE_GNOME= libxslt:build
.include <bsd.port.mk>
diff --git a/net-im/telepathy-haze/pkg-plist b/net-im/telepathy-haze/pkg-plist
index b3307948f55c..e99acae8bea2 100644
--- a/net-im/telepathy-haze/pkg-plist
+++ b/net-im/telepathy-haze/pkg-plist
@@ -1,3 +1,4 @@
libexec/telepathy-haze
+man/man8/telepathy-haze.8.gz
share/dbus-1/services/org.freedesktop.Telepathy.ConnectionManager.haze.service
man/man8/telepathy-haze.8.gz
diff --git a/net-im/telepathy-idle/Makefile b/net-im/telepathy-idle/Makefile
index 3071fc6e63a5..0cf929794a33 100644
--- a/net-im/telepathy-idle/Makefile
+++ b/net-im/telepathy-idle/Makefile
@@ -9,15 +9,14 @@ MASTER_SITES= http://telepathy.freedesktop.org/releases/${PORTNAME}/
MAINTAINER= gnome@FreeBSD.org
COMMENT= IRC Connection Manager for Telepathy Framework
-BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
-LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo \
- dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
- telepathy-glib:${PORTSDIR}/net-im/telepathy-glib
+LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
+ libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
+ libtelepathy-glib.so:${PORTSDIR}/net-im/telepathy-glib
GNU_CONFIGURE= yes
-USES= pkgconfig gmake
+USES= gmake libtool pathfix pkgconfig
USE_OPENSSL= yes
-USE_GNOME= gnomehack glib20
+USE_GNOME= glib20 libxslt:build
USE_PYTHON_BUILD=yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/net-im/telepathy-idle/pkg-plist b/net-im/telepathy-idle/pkg-plist
index 6f6676e9ed6a..a9c22672c369 100644
--- a/net-im/telepathy-idle/pkg-plist
+++ b/net-im/telepathy-idle/pkg-plist
@@ -1,4 +1,5 @@
libexec/telepathy-idle
+man/man8/telepathy-idle.8.gz
share/dbus-1/services/org.freedesktop.Telepathy.ConnectionManager.idle.service
share/telepathy/managers/idle.manager
man/man8/telepathy-idle.8.gz
diff --git a/net-im/telepathy-mission-control/Makefile b/net-im/telepathy-mission-control/Makefile
index 40990a9664d3..61c2d57420a8 100644
--- a/net-im/telepathy-mission-control/Makefile
+++ b/net-im/telepathy-mission-control/Makefile
@@ -4,18 +4,19 @@
PORTNAME= telepathy-mission-control
PORTVERSION= 5.12.0
+PORTREVISION= 1
CATEGORIES= net-im devel
MASTER_SITES= http://telepathy.freedesktop.org/releases/telepathy-mission-control/
MAINTAINER= gnome@FreeBSD.org
COMMENT= Telepathy component to apps to abstract details of connection managers
-LIB_DEPENDS= telepathy.2:${PORTSDIR}/net-im/libtelepathy \
- dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+LIB_DEPENDS= libtelepathy.so:${PORTSDIR}/net-im/libtelepathy \
+ libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
-USES= gmake pkgconfig
-USE_GNOME= gnomeprefix libxslt gnomehack ltverhack
-USE_AUTOTOOLS= libtool
+USES= gmake libtool:keepla pathfix pkgconfig
+USE_GNOME= gnomeprefix libxslt
+GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
diff --git a/net-im/telepathy-mission-control/pkg-plist b/net-im/telepathy-mission-control/pkg-plist
index 532d07f79b8d..0e84222be3b0 100644
--- a/net-im/telepathy-mission-control/pkg-plist
+++ b/net-im/telepathy-mission-control/pkg-plist
@@ -15,8 +15,12 @@ lib/libmission-control-plugins.a
lib/libmission-control-plugins.la
lib/libmission-control-plugins.so
lib/libmission-control-plugins.so.0
+lib/libmission-control-plugins.so.0.3.1
libdata/pkgconfig/mission-control-plugins.pc
libexec/mission-control-5
+man/man1/mc-tool.1.gz
+man/man1/mc-wait-for-name.1.gz
+man/man8/mission-control-5.8.gz
share/dbus-1/services/org.freedesktop.Telepathy.AccountManager.service
share/dbus-1/services/org.freedesktop.Telepathy.MissionControl5.service
share/doc/mission-control-plugins/McpAccountManager.html
diff --git a/net-im/telepathy-python/Makefile b/net-im/telepathy-python/Makefile
index 799474351af6..c78776da9547 100644
--- a/net-im/telepathy-python/Makefile
+++ b/net-im/telepathy-python/Makefile
@@ -11,18 +11,15 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= gnome@FreeBSD.org
COMMENT= Python bindings for the Telepathy framework
-LIB_PC_DEPENDS= dbus-python.pc:${PORTSDIR}/devel/py-dbus
+BUILD_DEPENDS= py2?-dbus>=0:${PORTSDIR}/devel/py-dbus
+RUN_DEPENDS= py2?-dbus>=0:${PORTSDIR}/devel/py-dbus
-BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
-
-BUILD_DEPENDS+= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|g}
-RUN_DEPENDS+= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|g}
-
-USE_PYTHON= yes
+USE_PYTHON= 2
USES= gmake
-GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+USE_GNOME= libxslt:build
+GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
MAKE_JOBS_UNSAFE= yes
.include <bsd.port.mk>
diff --git a/net-im/telepathy-salut/Makefile b/net-im/telepathy-salut/Makefile
index 240f43cd5ea5..509810d8fce6 100644
--- a/net-im/telepathy-salut/Makefile
+++ b/net-im/telepathy-salut/Makefile
@@ -3,19 +3,20 @@
PORTNAME= telepathy-salut
PORTVERSION= 0.8.0
+PORTREVISION= 1
CATEGORIES= net-im
MASTER_SITES= http://telepathy.freedesktop.org/releases/${PORTNAME}/
MAINTAINER= gnome@FreeBSD.org
COMMENT= Link-local Connection Manager for Telepathy Framework
-LIB_DEPENDS= avahi-glib.1:${PORTSDIR}/net/avahi-app \
- telepathy-glib.0:${PORTSDIR}/net-im/telepathy-glib \
- soup-2.4.1:${PORTSDIR}/devel/libsoup
+LIB_DEPENDS= libavahi-glib.so:${PORTSDIR}/net/avahi-app \
+ libtelepathy-glib.so:${PORTSDIR}/net-im/telepathy-glib \
+ libsoup-2.4.so:${PORTSDIR}/devel/libsoup
GNU_CONFIGURE= yes
-USES= pkgconfig gmake
-USE_GNOME= gnomehack glib20 libxslt:build
+USES= gmake libtool pathfix pkgconfig
+USE_GNOME= glib20 libxslt:build
USE_OPENSSL= yes
USE_PYTHON_BUILD= yes
USE_SQLITE= 3
diff --git a/net-im/telepathy-salut/pkg-plist b/net-im/telepathy-salut/pkg-plist
index dd8df5706e4c..8a2c36eaef28 100644
--- a/net-im/telepathy-salut/pkg-plist
+++ b/net-im/telepathy-salut/pkg-plist
@@ -1,12 +1,11 @@
man/man8/telepathy-salut.8.gz
lib/telepathy/salut-0/lib/libsalut-plugins-0.8.0.so
-lib/telepathy/salut-0/lib/libsalut-plugins.la
lib/telepathy/salut-0/lib/libsalut-plugins.so
lib/telepathy/salut-0/lib/libwocky-telepathy-salut-0.8.0.so
lib/telepathy/salut-0/lib/libwocky.a
-lib/telepathy/salut-0/lib/libwocky.la
lib/telepathy/salut-0/lib/libwocky.so
libexec/telepathy-salut
+man/man8/telepathy-salut.8.gz
share/dbus-1/services/org.freedesktop.Telepathy.ConnectionManager.salut.service
%%DOCSDIR%%/clique.html
share/telepathy/managers/salut.manager