aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/pbi-manager/Makefile7
-rw-r--r--sysutils/pcbsd-appweb/Makefile7
-rw-r--r--sysutils/pcbsd-libsh/Makefile7
-rw-r--r--sysutils/pcbsd-syscache/Makefile7
-rw-r--r--sysutils/pcbsd-utils/Makefile7
5 files changed, 5 insertions, 30 deletions
diff --git a/sysutils/pbi-manager/Makefile b/sysutils/pbi-manager/Makefile
index 51fc9c91470f..5cc75adf0f61 100644
--- a/sysutils/pbi-manager/Makefile
+++ b/sysutils/pbi-manager/Makefile
@@ -17,6 +17,7 @@ RUN_DEPENDS= ${LOCALBASE}/share/pcbsd/scripts/functions.sh:${PORTSDIR}/sysutils/
WRKSRC= ${WRKDIR}/pbi-manager
USES= pkgconfig tar:xz
NO_BUILD= yes
+MAKE_ARGS= PREFIX=${STAGEDIR}${PREFIX}
.include <bsd.port.pre.mk>
@@ -24,10 +25,4 @@ NO_BUILD= yes
IGNORE= requires FreeBSD 10 or later
.endif
-do-install:
- cd ${WRKSRC} && make install PREFIX=${STAGEDIR}${PREFIX}
-
-post-install:
- PKG_PREFIX=${STAGEDIR}${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-
.include <bsd.port.post.mk>
diff --git a/sysutils/pcbsd-appweb/Makefile b/sysutils/pcbsd-appweb/Makefile
index 70452fc46e97..b2790cd2cd32 100644
--- a/sysutils/pcbsd-appweb/Makefile
+++ b/sysutils/pcbsd-appweb/Makefile
@@ -23,6 +23,7 @@ USE_PHP= gd filter session
WRKSRC= ${WRKDIR}/src-webui
USES= pkgconfig tar:xz
NO_BUILD= yes
+MAKE_ARGS= PREFIX=${STAGEDIR}${PREFIX}
.include <bsd.port.pre.mk>
@@ -30,10 +31,4 @@ NO_BUILD= yes
IGNORE= requires FreeBSD 10 or later
.endif
-do-install:
- cd ${WRKSRC} && make install PREFIX=${STAGEDIR}${PREFIX}
-
-post-install:
- PKG_PREFIX=${STAGEDIR}${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-
.include <bsd.port.post.mk>
diff --git a/sysutils/pcbsd-libsh/Makefile b/sysutils/pcbsd-libsh/Makefile
index 67f2a03f6155..43926ed2ded4 100644
--- a/sysutils/pcbsd-libsh/Makefile
+++ b/sysutils/pcbsd-libsh/Makefile
@@ -15,6 +15,7 @@ LICENSE= BSD
WRKSRC= ${WRKDIR}/libsh
USES= pkgconfig tar:xz
NO_BUILD= yes
+MAKE_ARGS= PREFIX=${STAGEDIR}${PREFIX}
.include <bsd.port.pre.mk>
@@ -22,10 +23,4 @@ NO_BUILD= yes
IGNORE= requires FreeBSD 10 or later
.endif
-do-install:
- cd ${WRKSRC} && make install PREFIX=${STAGEDIR}${PREFIX}
-
-post-install:
- PKG_PREFIX=${STAGEDIR}${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-
.include <bsd.port.post.mk>
diff --git a/sysutils/pcbsd-syscache/Makefile b/sysutils/pcbsd-syscache/Makefile
index 0de3946f0b11..4b5febb28aea 100644
--- a/sysutils/pcbsd-syscache/Makefile
+++ b/sysutils/pcbsd-syscache/Makefile
@@ -16,6 +16,7 @@ WRKSRC= ${WRKDIR}/syscache
USE_QT5= core network buildtools qmake
USES= pkgconfig tar:xz
NO_BUILD= yes
+MAKE_ARGS= PREFIX=${STAGEDIR}${PREFIX}
.include <bsd.port.pre.mk>
@@ -23,10 +24,4 @@ NO_BUILD= yes
IGNORE= requires FreeBSD 10 or later
.endif
-do-install:
- cd ${WRKSRC} && make install PREFIX=${STAGEDIR}${PREFIX}
-
-post-install:
- PKG_PREFIX=${STAGEDIR}${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-
.include <bsd.port.post.mk>
diff --git a/sysutils/pcbsd-utils/Makefile b/sysutils/pcbsd-utils/Makefile
index c398a9a3cd0e..609a78548d6b 100644
--- a/sysutils/pcbsd-utils/Makefile
+++ b/sysutils/pcbsd-utils/Makefile
@@ -21,6 +21,7 @@ CONFLICTS?= pbi-manager-[0-9]*
USE_QT5= core network buildtools qmake
USES= pkgconfig tar:xz
NO_BUILD= yes
+MAKE_ARGS= PREFIX=${STAGEDIR}${PREFIX}
.include <bsd.port.pre.mk>
@@ -28,10 +29,4 @@ NO_BUILD= yes
IGNORE= requires FreeBSD 10 or later
.endif
-do-install:
- cd ${WRKSRC} && make install PREFIX=${STAGEDIR}${PREFIX}
-
-post-install:
- PKG_PREFIX=${STAGEDIR}${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-
.include <bsd.port.post.mk>