aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Unix-Groups-FFI/Makefile23
-rw-r--r--devel/p5-Unix-Groups-FFI/distinfo3
-rw-r--r--devel/p5-Unix-Groups-FFI/pkg-descr5
-rw-r--r--devel/p5-Unix-Groups-FFI/pkg-plist2
5 files changed, 34 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 88a1036b480a..c437b88064a3 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3679,6 +3679,7 @@
SUBDIR += p5-UUID-Tiny
SUBDIR += p5-Uniq
SUBDIR += p5-Unix-Groups
+ SUBDIR += p5-Unix-Groups-FFI
SUBDIR += p5-Unix-Statgrab
SUBDIR += p5-Unix-Uptime
SUBDIR += p5-User-Identity
diff --git a/devel/p5-Unix-Groups-FFI/Makefile b/devel/p5-Unix-Groups-FFI/Makefile
new file mode 100644
index 000000000000..952129876820
--- /dev/null
+++ b/devel/p5-Unix-Groups-FFI/Makefile
@@ -0,0 +1,23 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Unix-Groups-FFI
+PORTVERSION= 0.002
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Interface to Unix group syscalls
+
+LICENSE= ART20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= p5-FFI-Platypus>=0.20:devel/p5-FFI-Platypus
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+NO_ARCH= yes
+USE_PERL5= configure
+USES= perl5
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Unix-Groups-FFI/distinfo b/devel/p5-Unix-Groups-FFI/distinfo
new file mode 100644
index 000000000000..e352fb3ea839
--- /dev/null
+++ b/devel/p5-Unix-Groups-FFI/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1519141847
+SHA256 (Unix-Groups-FFI-0.002.tar.gz) = 81fef789dca2c9a5675fb4d3a8ed0008ecb533941a01c6e2bae3709a79c44560
+SIZE (Unix-Groups-FFI-0.002.tar.gz) = 17090
diff --git a/devel/p5-Unix-Groups-FFI/pkg-descr b/devel/p5-Unix-Groups-FFI/pkg-descr
new file mode 100644
index 000000000000..05c81be3e8c4
--- /dev/null
+++ b/devel/p5-Unix-Groups-FFI/pkg-descr
@@ -0,0 +1,5 @@
+Unix::Groups::FFI provides a FFI interface to several syscalls related to Unix
+groups, including getgroups(2), setgroups(2), getgrouplist(3), and
+initgroups(3). As such it will only work on Unix-like operating systems.
+
+WWW: http://search.cpan.org/dist/Unix-Groups-FFI/
diff --git a/devel/p5-Unix-Groups-FFI/pkg-plist b/devel/p5-Unix-Groups-FFI/pkg-plist
new file mode 100644
index 000000000000..a52eccb9bcf5
--- /dev/null
+++ b/devel/p5-Unix-Groups-FFI/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Unix/Groups/FFI.pm
+%%PERL5_MAN3%%/Unix::Groups::FFI.3.gz