aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/tidyp/Makefile45
-rw-r--r--textproc/tidyp/distinfo3
-rw-r--r--textproc/tidyp/pkg-descr7
-rw-r--r--textproc/tidyp/pkg-plist12
5 files changed, 68 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index e040a0a77707..28ab7096e6c2 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1203,6 +1203,7 @@
SUBDIR += texi2db
SUBDIR += texi2html
SUBDIR += textogif
+ SUBDIR += tidyp
SUBDIR += tinyxml
SUBDIR += tk-aspell
SUBDIR += tkdiff
diff --git a/textproc/tidyp/Makefile b/textproc/tidyp/Makefile
new file mode 100644
index 000000000000..68f1158fc84d
--- /dev/null
+++ b/textproc/tidyp/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: tidyp
+# Date created: 2010-05-14
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@sunpoet.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tidyp
+PORTVERSION= 1.02
+CATEGORIES= textproc www
+MASTER_SITES= http://cloud.github.com/downloads/petdance/tidyp/ \
+ http://sunpoet.net/distfiles/
+
+MAINTAINER= sunpoet@sunpoet.net
+COMMENT= A library and program to validate and fix HTML
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+OPTIONS= ACCESS "Support Accessibility checks" off \
+ ASIAN "Support Asian encoding" off \
+ DEBUG "Enable debugging" off \
+ UTF16 "Support UTF-16 encoding" off
+
+PLIST_SUB+= TIDYP_VER="${PORTVERSION}"
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_ACCESS)
+CONFIGURE_ARGS+= --enable-debug
+.endif
+
+.if defined(WITH_ASIAN)
+CONFIGURE_ARGS+= --enable-asian
+.endif
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug
+.endif
+
+.if defined(WITH_UTF16)
+CONFIGURE_ARGS+= --enable-utf16
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/tidyp/distinfo b/textproc/tidyp/distinfo
new file mode 100644
index 000000000000..c6e2e02ca3e9
--- /dev/null
+++ b/textproc/tidyp/distinfo
@@ -0,0 +1,3 @@
+MD5 (tidyp-1.02.tar.gz) = 4fc6f0ba8fb1e2ffafbf8f5963f58969
+SHA256 (tidyp-1.02.tar.gz) = 6ff0eb94a1ac548339a1ea3d377e72bb1261491ffa7df29851aaa1c25e168004
+SIZE (tidyp-1.02.tar.gz) = 674947
diff --git a/textproc/tidyp/pkg-descr b/textproc/tidyp/pkg-descr
new file mode 100644
index 000000000000..82b0b2f727d0
--- /dev/null
+++ b/textproc/tidyp/pkg-descr
@@ -0,0 +1,7 @@
+tidyp is a fork of tidy on SourceForge at http://tidy.sf.net. The
+library name is "tidyp", and the command-line tool is also "tidyp"
+but all internal API stays the same.
+
+tidyp will validate your HTML, and output cleaned-up HTML.
+
+WWW: http://tidyp.com/
diff --git a/textproc/tidyp/pkg-plist b/textproc/tidyp/pkg-plist
new file mode 100644
index 000000000000..120ede53cb7c
--- /dev/null
+++ b/textproc/tidyp/pkg-plist
@@ -0,0 +1,12 @@
+@comment $FreeBSD$
+bin/tidyp
+include/tidyp/buffio.h
+include/tidyp/platform.h
+include/tidyp/tidyp.h
+include/tidyp/tidypenum.h
+lib/libtidyp-%%TIDYP_VER%%.so
+lib/libtidyp-%%TIDYP_VER%%.so.0
+lib/libtidyp.a
+lib/libtidyp.la
+lib/libtidyp.so
+@dirrm include/tidyp