aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Markapl/Makefile32
-rw-r--r--textproc/p5-Markapl/distinfo3
-rw-r--r--textproc/p5-Markapl/pkg-descr6
-rw-r--r--textproc/p5-Markapl/pkg-plist7
5 files changed, 49 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 715ed42248f3..c92fb4199e46 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -508,6 +508,7 @@
SUBDIR += p5-MKDoc-XML
SUBDIR += p5-Makefile-DOM
SUBDIR += p5-Makefile-Parser
+ SUBDIR += p5-Markapl
SUBDIR += p5-MathML-Entities
SUBDIR += p5-Net-YASA
SUBDIR += p5-NetAddr-IP-Find
diff --git a/textproc/p5-Markapl/Makefile b/textproc/p5-Markapl/Makefile
new file mode 100644
index 000000000000..6a591f2121da
--- /dev/null
+++ b/textproc/p5-Markapl/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: textproc/p5-Markapl
+# Date created: 15 February 2010
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Markapl
+PORTVERSION= 0.10
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN/../../authors/id/G/GU/GUGOD
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Markup as Perl
+
+BUILD_DEPENDS= p5-Exporter-Lite>=0:${PORTSDIR}/devel/p5-Exporter-Lite \
+ p5-HTML-Lint>=0:${PORTSDIR}/www/p5-HTML-Lint \
+ p5-B-Hooks-EndOfScope>=0.05:${PORTSDIR}/devel/p5-B-Hooks-EndOfScope \
+ p5-Sub-Install>=0:${PORTSDIR}/devel/p5-Sub-Install \
+ p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
+ p5-String-BufferStack>=1.15:${PORTSDIR}/textproc/p5-String-BufferStack \
+ p5-Devel-Declare>=0:${PORTSDIR}/devel/p5-Devel-Declare
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Markapl.3 \
+ Markapl::Helpers.3 \
+ Markapl::Tags.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Markapl/distinfo b/textproc/p5-Markapl/distinfo
new file mode 100644
index 000000000000..9193f6dc2a1d
--- /dev/null
+++ b/textproc/p5-Markapl/distinfo
@@ -0,0 +1,3 @@
+MD5 (Markapl-0.10.tar.gz) = d759274ea979fd746766a058e9760a2a
+SHA256 (Markapl-0.10.tar.gz) = 1c14db6043b910a881397b6b5e05a96731d2ee6b6f85b0248a02e14e0c868d94
+SIZE (Markapl-0.10.tar.gz) = 25449
diff --git a/textproc/p5-Markapl/pkg-descr b/textproc/p5-Markapl/pkg-descr
new file mode 100644
index 000000000000..7c2ef9e90949
--- /dev/null
+++ b/textproc/p5-Markapl/pkg-descr
@@ -0,0 +1,6 @@
+This is a new try to use Devel::Declare to change the Perl5
+language. It learns pretty much everything from Template::Declare,
+and has similar interface. With only one difference: how element
+attributes are defined.
+
+WWW: http://search.cpan.org/dist/Markapl/
diff --git a/textproc/p5-Markapl/pkg-plist b/textproc/p5-Markapl/pkg-plist
new file mode 100644
index 000000000000..2a617a24ce98
--- /dev/null
+++ b/textproc/p5-Markapl/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Markapl.pm
+%%SITE_PERL%%/Markapl/Helpers.pm
+%%SITE_PERL%%/Markapl/TagHandlers.pm
+%%SITE_PERL%%/Markapl/Tags.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Markapl/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Markapl
+@dirrmtry %%SITE_PERL%%/Markapl