aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--biology/bedtools/Makefile5
-rw-r--r--comms/gnuradio/Makefile2
-rw-r--r--editors/libreoffice/Makefile3
-rw-r--r--emulators/stella/Makefile5
-rw-r--r--games/armagetron/Makefile4
-rw-r--r--graphics/gsculpt/Makefile1
-rw-r--r--net/linknx/Makefile1
-rw-r--r--net/rsplib/Makefile4
-rw-r--r--science/afni/Makefile5
-rw-r--r--security/botan2/Makefile2
-rw-r--r--security/highwayhash/Makefile3
-rw-r--r--security/sha1collisiondetection/Makefile1
-rw-r--r--www/chromium/Makefile5
-rw-r--r--www/ctemplate/Makefile1
-rw-r--r--x11-toolkits/mygui/Makefile1
15 files changed, 37 insertions, 6 deletions
diff --git a/biology/bedtools/Makefile b/biology/bedtools/Makefile
index 2e587e209cf0..6d4928122d65 100644
--- a/biology/bedtools/Makefile
+++ b/biology/bedtools/Makefile
@@ -13,8 +13,9 @@ COMMENT= Toolset for genome arithmetic
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_armv6= fails to compile: implicit instantiation of undefined template __static_assert_test<false>
-BROKEN_armv7= fails to compile: implicit instantiation of undefined template __static_assert_test<false>
+BROKEN_FreeBSD_12_aarch64= fails to compile: /usr/include/c++/v1/queue:401:5: error: static_assert failed
+BROKEN_armv6= fails to compile: implicit instantiation of undefined template __static_assert_test<false>
+BROKEN_armv7= fails to compile: implicit instantiation of undefined template __static_assert_test<false>
USE_GITHUB= yes
GH_ACCOUNT= arq5x
diff --git a/comms/gnuradio/Makefile b/comms/gnuradio/Makefile
index 71338a9a8b41..e72287beabfa 100644
--- a/comms/gnuradio/Makefile
+++ b/comms/gnuradio/Makefile
@@ -37,6 +37,8 @@ LIB_DEPENDS= libcppunit.so:devel/cppunit \
liborc-0.4.so:devel/orc
RUN_DEPENDS:= ${BUILD_DEPENDS}
+BROKEN_aarch64= fails to compile: /usr/lib/clang/5.0.0/include/mmintrin.h:47:5: use of undeclared identifier '__builtin_ia32_emms'; did you mean '__builtin_isless'?
+
# USES=compiler:c11 is necessary because base GCC fails:
# volk/lib/volk_cpu.c: In function 'i_can_has_3dnow':
# volk/lib/volk_cpu.c:62: error: can't find a register in class 'BREG' while reloading 'asm'
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index b65974fe41aa..9897447731b7 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -86,6 +86,9 @@ DISTFILES+= 4b87018f7fff1d054939d19920b751a0-collada2gltf-master-cb1d97788a.tar.
86b1daaa438f5a7bea9a52d7b9799ac0-xmlsec1-1.2.23.tar.gz:src \
cppunit-1.13.2.tar.gz:src
+NOT_FOR_ARCHS= aarch64 armv6 armv7
+NOT_FOR_ARCHS_REASON= Unsupported host_cpu
+
.if defined(PRERELEASE)
MASTER_SITES+= http://dev-builds.libreoffice.org/pre-releases/src/
.endif
diff --git a/emulators/stella/Makefile b/emulators/stella/Makefile
index 8216ec7ad9f3..ee833e529e10 100644
--- a/emulators/stella/Makefile
+++ b/emulators/stella/Makefile
@@ -16,6 +16,11 @@ LICENSE_FILE= ${WRKSRC}/License.txt
LIB_DEPENDS= libpng.so:graphics/png
+BROKEN_aarch64= fails to compile: Checking for compiler version... 5.0.0, bad; Please ensure you are using GCC 4.7 / Clang 3.4 or above
+BROKEN_armv6= fails to compile: Checking for compiler version... 5.0.0, bad; Please ensure you are using GCC 4.7 / Clang 3.4 or above
+BROKEN_armv7= fails to compile: Checking for compiler version... 5.0.0, bad; Please ensure you are using GCC 4.7 / Clang 3.4 or above
+BROKEN_powerpc64= fails to compile: CartDebug.cxx: 'snprintf' is not a member of 'std'
+
CONFLICTS_INSTALL= rubygem-stella
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/games/armagetron/Makefile b/games/armagetron/Makefile
index 2495deef9f2b..24d42c79fe6c 100644
--- a/games/armagetron/Makefile
+++ b/games/armagetron/Makefile
@@ -15,6 +15,10 @@ COMMENT= Multiplayer networked Tron clone in 3D
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_FreeBSD_12_aarch64= network/nNetObject.cpp:1533:46: error: ordered comparison between pointer and zero ('const nSocket *' and 'int')
+BROKEN_FreeBSD_12_armv6= network/nNetObject.cpp:1533:46: error: ordered comparison between pointer and zero ('const nSocket *' and 'int')
+BROKEN_FreeBSD_12_armv7= network/nNetObject.cpp:1533:46: error: ordered comparison between pointer and zero ('const nSocket *' and 'int')
+
USES= gmake jpeg
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-etc --disable-initscripts
diff --git a/graphics/gsculpt/Makefile b/graphics/gsculpt/Makefile
index 28569894c2e9..1977cde6e429 100644
--- a/graphics/gsculpt/Makefile
+++ b/graphics/gsculpt/Makefile
@@ -18,6 +18,7 @@ LIB_DEPENDS= libboost_python.so:devel/boost-python-libs
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}PyOpenGL>0:graphics/py-PyOpenGL@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}gtkglext>0:x11-toolkits/py-gtkglext@${PY_FLAVOR}
+BROKEN_aarch64= fails to compile: cpp/extlibs/greenlet/greenlet.c:254:2: greenlet needs to be ported to this platform
BROKEN_powerpc= fails to compile
BROKEN_sparc64= fails to compile
diff --git a/net/linknx/Makefile b/net/linknx/Makefile
index a2a5b7507ae3..ffc6625e2798 100644
--- a/net/linknx/Makefile
+++ b/net/linknx/Makefile
@@ -14,6 +14,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libpthsem.so:devel/pthsem
BUILD_DEPENDS= ${LOCALBASE}/lib/libargp.a:devel/argp-standalone
+BROKEN_aarch64= fails to compile: /usr/include/c++/v1/math.h:733:39: no member named 'fabsf' in the global namespace; did you mean simply 'fabsf'?
BROKEN_armv6= fails to configure: checking for GNU Pth... Segmentation fault
BROKEN_armv7= fails to configure: checking for GNU Pth... Segmentation fault
BROKEN_mips= fails to configure: checking for GNU Pth... Segmentation fault
diff --git a/net/rsplib/Makefile b/net/rsplib/Makefile
index 93cf4837aa70..7a171b8684ab 100644
--- a/net/rsplib/Makefile
+++ b/net/rsplib/Makefile
@@ -12,6 +12,10 @@ COMMENT= RSerPool Framework and Example Applications
LICENSE= GPLv3
+BROKEN_aarch64= fails to compile: fractalgeneratorservice.cc:353:12: expected unqualified-id
+BROKEN_armv6= fails to compile: fractalgeneratorservice.cc:353:12: expected unqualified-id
+BROKEN_armv7= fails to compile: fractalgeneratorservice.cc:353:12: expected unqualified-id
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-maintainer-mode \
--enable-qt --with-qt-lib=${QT_LIBDIR} \
diff --git a/science/afni/Makefile b/science/afni/Makefile
index c6c681843bae..296114462daa 100644
--- a/science/afni/Makefile
+++ b/science/afni/Makefile
@@ -33,6 +33,9 @@ RUN_DEPENDS= endian:sysutils/endian \
ppmtogif:graphics/netpbm \
qhull:math/qhull5
+BROKEN_aarch64= fails to compile: suma_utils.c:3043:10: statement requires expression of scalar type
+BROKEN_sparc64= fails to compile: undefined reference to '_mcount'
+
CONFLICTS= im-[0-9]* \
nifticlib-[0-9]* \
open-usp-tukubai-[0-9]*
@@ -48,8 +51,6 @@ USE_GNOME= glib20
.include <bsd.port.options.mk>
-BROKEN_sparc64= Does not compile: "undefined reference to '_mcount'"
-
USE_GL= gl glu glw
USE_XORG= x11 xext xi xmu xp xt
MAKE_ENV= CC="${CC}" R_SHARE_DIR=${LOCALBASE}/lib/R/share
diff --git a/security/botan2/Makefile b/security/botan2/Makefile
index 19e672a014fe..f871f059a57d 100644
--- a/security/botan2/Makefile
+++ b/security/botan2/Makefile
@@ -15,6 +15,8 @@ LICENSE_FILE= ${WRKSRC}/license.txt
LIB_DEPENDS= libboost_filesystem.so:devel/boost-libs
+BROKEN_aarch64= fails to compile: ./src/lib/block/aes/aes_armv8/aes_armv8.cpp:40:25: use of undeclared identifier 'vaeseq_u8'
+
OPTIONS_DEFINE= SQLITE3 SSL DOCS
OPTIONS_DEFAULT= SSL
OPTIONS_SUB= yes
diff --git a/security/highwayhash/Makefile b/security/highwayhash/Makefile
index 4871fe2360ea..9c99ececbb7f 100644
--- a/security/highwayhash/Makefile
+++ b/security/highwayhash/Makefile
@@ -11,7 +11,8 @@ COMMENT= Fast strong hash functions: SipHash/HighwayHash
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-ONLY_FOR_ARCHS= aarch64 amd64 powerpc powerpc64
+BROKEN_aarch64= fails to compile: /usr/lib/clang/5.0.0/include/mmintrin.h:47:5: use of undeclared identifier '__builtin_ia32_emms'
+ONLY_FOR_ARCHS= aarch64 amd64 powerpc powerpc64
ONLY_FOR_ARCHS_REASON= Assembly is implemented only for specific architectures in highwayhash/tsc_timer.h
USES= gmake
diff --git a/security/sha1collisiondetection/Makefile b/security/sha1collisiondetection/Makefile
index f49f84954031..f7574a47793f 100644
--- a/security/sha1collisiondetection/Makefile
+++ b/security/sha1collisiondetection/Makefile
@@ -11,6 +11,7 @@ COMMENT= Library and command line tool to detect SHA-1 collisions
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+BROKEN_aarch64= fails to compile: generic selections are a C11-specific feature [-Werror,-Wc11-extensions]
BROKEN_armv6= fails to compile: generic selections are a C11-specific feature [-Werror,-Wc11-extensions]
BROKEN_armv7= fails to compile: generic selections are a C11-specific feature [-Werror,-Wc11-extensions]
BROKEN_powerpc64= fails to compile: cc1: unrecognized command line option -std=c90
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index 84ac2c2c1895..c4dcf1326b15 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -62,7 +62,10 @@ LIB_DEPENDS= libspeechd.so:accessibility/speech-dispatcher \
RUN_DEPENDS= xdg-open:devel/xdg-utils \
droid-fonts-ttf>0:x11-fonts/droid-fonts-ttf
-ONLY_FOR_ARCHS= aarch64 amd64 i386
+BROKEN_FreeBSD_11_aarch64= components/safe_browsing_db/v4_rice.cc:120:18: use of overloaded operator '&' is ambiguous
+BROKEN_FreeBSD_12_aarch64= third_party/skia/src/core/SkCpu.cpp:84:27: use of undeclared identifier 'getauxval'
+ONLY_FOR_ARCHS= aarch64 amd64 i386
+
.endif
.if defined(GN_ONLY)
diff --git a/www/ctemplate/Makefile b/www/ctemplate/Makefile
index 33fd5768f3ef..e77ac1d66729 100644
--- a/www/ctemplate/Makefile
+++ b/www/ctemplate/Makefile
@@ -9,6 +9,7 @@ MASTER_SITES= SF
MAINTAINER= ap@page2rss.com
COMMENT= Template system for C
+BROKEN_aarch64= fails to compile: assigning to char * from incompatible type const char *
BROKEN_armv6= fails to compile: assigning to char * from incompatible type const char *
BROKEN_armv7= fails to compile: assigning to char * from incompatible type const char *
diff --git a/x11-toolkits/mygui/Makefile b/x11-toolkits/mygui/Makefile
index 40b94884fd93..1544b694f028 100644
--- a/x11-toolkits/mygui/Makefile
+++ b/x11-toolkits/mygui/Makefile
@@ -23,6 +23,7 @@ BUILD_WRKSRC= ${WRKSRC}/${MYGUI_SUBDIR}
INSTALL_WRKSRC= ${WRKSRC}/${MYGUI_SUBDIR}
.endif
+BROKEN_aarch64= fails to compile: memory:2050:9: error: cannot initialize a member subobject of type 'std::__1::basic_string<char> *' with an rvalue of type 'int'
BROKEN_armv6= fails to compile: memory:2050:9: error: cannot initialize a member subobject of type 'std::__1::basic_string<char> *' with an rvalue of type 'int'
BROKEN_armv7= fails to compile: memory:2050:9: error: cannot initialize a member subobject of type 'std::__1::basic_string<char> *' with an rvalue of type 'int'
BROKEN_powerpc64= fails to build