aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/p5-MogileFS-Client/Makefile25
-rw-r--r--sysutils/p5-MogileFS-Client/distinfo3
-rw-r--r--sysutils/p5-MogileFS-Client/pkg-descr6
-rw-r--r--sysutils/p5-MogileFS-Client/pkg-plist9
5 files changed, 44 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 7495cdfcb629..ca7f61b11308 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -441,6 +441,7 @@
SUBDIR += p5-Fuse-Simple
SUBDIR += p5-LJ-Cache
SUBDIR += p5-LJ-TextMessage
+ SUBDIR += p5-MogileFS-Client
SUBDIR += p5-Proc-PidUtil
SUBDIR += p5-Quota
SUBDIR += p5-Schedule-At
diff --git a/sysutils/p5-MogileFS-Client/Makefile b/sysutils/p5-MogileFS-Client/Makefile
new file mode 100644
index 000000000000..9c050472ccfd
--- /dev/null
+++ b/sysutils/p5-MogileFS-Client/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-MogileFS-Client
+# Date created: 2007-04-22
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= MogileFS-Client
+PORTVERSION= 1.06
+CATEGORIES= sysutils net perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/B/BR/BRADFITZ
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Client library for the MogileFS distributed file system
+
+RUN_DEPENDS= ${SITE_PERL}/IO/WrapTie.pm:${PORTSDIR}/devel/p5-IO-stringy \
+ ${SITE_PERL}/LWP/Simple.pm:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+
+MAN3= MogileFS::Client.3
+
+.include <bsd.port.mk>
diff --git a/sysutils/p5-MogileFS-Client/distinfo b/sysutils/p5-MogileFS-Client/distinfo
new file mode 100644
index 000000000000..58b31792dec5
--- /dev/null
+++ b/sysutils/p5-MogileFS-Client/distinfo
@@ -0,0 +1,3 @@
+MD5 (MogileFS-Client-1.06.tar.gz) = bba37011319a433d470299ffb2cf7ac3
+SHA256 (MogileFS-Client-1.06.tar.gz) = 15a090e91f912dc625049578eccbfe001461864268d5c8ec4d974f009e7a0d4e
+SIZE (MogileFS-Client-1.06.tar.gz) = 18144
diff --git a/sysutils/p5-MogileFS-Client/pkg-descr b/sysutils/p5-MogileFS-Client/pkg-descr
new file mode 100644
index 000000000000..b660787f1f12
--- /dev/null
+++ b/sysutils/p5-MogileFS-Client/pkg-descr
@@ -0,0 +1,6 @@
+This module is a client library for the MogileFS distributed file
+system. The class method 'new' creates a client object against a
+particular mogilefs tracker and domain. This object may then be used
+to store and retrieve content easily from MogileFS.
+
+WWW: http://search.cpan.org/dist/MogileFS-Client/
diff --git a/sysutils/p5-MogileFS-Client/pkg-plist b/sysutils/p5-MogileFS-Client/pkg-plist
new file mode 100644
index 000000000000..c25256f00a4c
--- /dev/null
+++ b/sysutils/p5-MogileFS-Client/pkg-plist
@@ -0,0 +1,9 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/MogileFS/Client/.packlist
+%%SITE_PERL%%/MogileFS/Admin.pm
+%%SITE_PERL%%/MogileFS/Backend.pm
+%%SITE_PERL%%/MogileFS/Client.pm
+%%SITE_PERL%%/MogileFS/NewHTTPFile.pm
+@dirrmtry %%SITE_PERL%%/MogileFS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MogileFS/Client
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MogileFS