aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/gnome-games/Makefile7
-rw-r--r--games/gnome-games/distinfo6
-rw-r--r--games/gnome-games/pkg-install2
-rw-r--r--games/gnome-games/pkg-plist14
4 files changed, 11 insertions, 18 deletions
diff --git a/games/gnome-games/Makefile b/games/gnome-games/Makefile
index 47abb95f1718..edb8acd66246 100644
--- a/games/gnome-games/Makefile
+++ b/games/gnome-games/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= gnome-games
-PORTVERSION= 2.16.2
+PORTVERSION= 2.16.3
CATEGORIES= games gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -26,7 +26,7 @@ INSTALLS_ICONS= yes
USE_XLIB= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui \
- librsvg2 desktopfileutils
+ librsvg2
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -50,7 +50,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|bin/python|bin/env python|g' \
${WRKSRC}/libgames-support/games-server.py
-post-install:
- @-update-desktop-database
-
.include <bsd.port.post.mk>
diff --git a/games/gnome-games/distinfo b/games/gnome-games/distinfo
index b240b9749be6..4e46e3101642 100644
--- a/games/gnome-games/distinfo
+++ b/games/gnome-games/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gnome-games-2.16.2.tar.bz2) = e69465370ce5d8aad617f341bc35a58e
-SHA256 (gnome2/gnome-games-2.16.2.tar.bz2) = a6b20aa2684f223a41521d28c6b6e8a10ef9c9ad0540e5389564404ddd591a25
-SIZE (gnome2/gnome-games-2.16.2.tar.bz2) = 5257581
+MD5 (gnome2/gnome-games-2.16.3.tar.bz2) = 88baa9ab64b84bfcac2a1ba05f84d2f9
+SHA256 (gnome2/gnome-games-2.16.3.tar.bz2) = 7c32dc59819cbf22787d5ac1fde221a4cd38a20de33831246e12811520294d05
+SIZE (gnome2/gnome-games-2.16.3.tar.bz2) = 5276299
diff --git a/games/gnome-games/pkg-install b/games/gnome-games/pkg-install
index cbbb71f5595f..41261dc21da0 100644
--- a/games/gnome-games/pkg-install
+++ b/games/gnome-games/pkg-install
@@ -5,7 +5,7 @@ PATH=/bin:/usr/bin:/usr/sbin
case $2 in
POST-INSTALL)
mkdir -p ${PKG_PREFIX}/share/gnome/games
- SCORES="glines.scores glines.Large.scores glines.Medium.scores glines.Small.scores gnibbles.1.0.scores gnibbles.1.1.scores gnibbles.2.0.scores gnibbles.2.1.scores gnibbles.3.0.scores gnibbles.3.1.scores gnibbles.4.0.scores gnibbles.4.1.scores gnobots2.classic_robots-safe.scores gnobots2.classic_robots-super-safe.scores gnobots2.classic_robots.scores gnobots2.nightmare-safe.scores gnobots2.nightmare-super-safe.scores gnobots2.nightmare.scores gnobots2.robots2-safe.scores gnobots2.robots2-super-safe.scores gnobots2.robots2.scores gnobots2.robots2_easy-safe.scores gnobots2.robots2_easy-super-safe.scores gnobots2.robots2_easy.scores gnobots2.robots_with_safe_teleport-safe.scores gnobots2.robots_with_safe_teleport-super-safe.scores gnobots2.robots_with_safe_teleport.scores gnometris.scores gnomine.Custom.scores gnomine.Large.scores gnomine.Medium.scores gnomine.Small.scores gnotravex.2x2.scores gnotravex.3x3.scores gnotravex.4x4.scores gnotravex.5x5.scores gnotravex.6x6.scores gnotski.1.scores gnotski.10.scores gnotski.11.scores gnotski.12.scores gnotski.13.scores gnotski.14.scores gnotski.15.scores gnotski.16.scores gnotski.17.scores gnotski.18.scores gnotski.2.scores gnotski.20.scores gnotski.21.scores gnotski.22.scores gnotski.23.scores gnotski.24.scores gnotski.25.scores gnotski.26.scores gnotski.27.scores gnotski.28.scores gnotski.29.scores gnotski.3.scores gnotski.30.scores gnotski.31.scores gnotski.32.scores gnotski.33.scores gnotski.34.scores gnotski.35.scores gnotski.36.scores gnotski.37.scores gnotski.4.scores gnotski.5.scores gnotski.6.scores gnotski.7.scores gnotski.8.scores gnotski.9.scores gtali.scores mahjongg.bridges.scores mahjongg.cloud.scores mahjongg.confounding.scores mahjongg.difficult.scores mahjongg.dragon.scores mahjongg.easy.scores mahjongg.pyramid.scores mahjongg.tictactoe.scores mahjongg.ziggurat.scores same-gnome.Small.scores same-gnome.Medium.scores same-gnome.Large.scores"
+ SCORES="glines.Large.scores glines.Medium.scores glines.Small.scores gnibbles.1.0.scores gnibbles.1.1.scores gnibbles.2.0.scores gnibbles.2.1.scores gnibbles.3.0.scores gnibbles.3.1.scores gnibbles.4.0.scores gnibbles.4.1.scores gnobots2.classic_robots-safe.scores gnobots2.classic_robots-super-safe.scores gnobots2.classic_robots.scores gnobots2.nightmare-safe.scores gnobots2.nightmare-super-safe.scores gnobots2.nightmare.scores gnobots2.robots2-safe.scores gnobots2.robots2-super-safe.scores gnobots2.robots2.scores gnobots2.robots2_easy-safe.scores gnobots2.robots2_easy-super-safe.scores gnobots2.robots2_easy.scores gnobots2.robots_with_safe_teleport-safe.scores gnobots2.robots_with_safe_teleport-super-safe.scores gnobots2.robots_with_safe_teleport.scores gnometris.scores gnomine.Custom.scores gnomine.Large.scores gnomine.Medium.scores gnomine.Small.scores gnotravex.2x2.scores gnotravex.3x3.scores gnotravex.4x4.scores gnotravex.5x5.scores gnotravex.6x6.scores gnotski.1.scores gnotski.10.scores gnotski.11.scores gnotski.12.scores gnotski.13.scores gnotski.14.scores gnotski.15.scores gnotski.16.scores gnotski.17.scores gnotski.18.scores gnotski.19.scores gnotski.2.scores gnotski.20.scores gnotski.21.scores gnotski.22.scores gnotski.23.scores gnotski.24.scores gnotski.25.scores gnotski.26.scores gnotski.27.scores gnotski.28.scores gnotski.29.scores gnotski.3.scores gnotski.30.scores gnotski.31.scores gnotski.32.scores gnotski.33.scores gnotski.34.scores gnotski.35.scores gnotski.36.scores gnotski.37.scores gnotski.4.scores gnotski.5.scores gnotski.6.scores gnotski.7.scores gnotski.8.scores gnotski.9.scores gtali.scores mahjongg.bridges.scores mahjongg.cloud.scores mahjongg.confounding.scores mahjongg.difficult.scores mahjongg.dragon.scores mahjongg.easy.scores mahjongg.pyramid.scores mahjongg.tictactoe.scores mahjongg.ziggurat.scores same-gnome.Large.scores same-gnome.Medium.scores same-gnome.Small.scores"
for i in ${SCORES}; do
if [ ! -f ${PKG_PREFIX}/share/gnome/games/${i} ]; then
touch -f ${PKG_PREFIX}/share/gnome/games/${i}
diff --git a/games/gnome-games/pkg-plist b/games/gnome-games/pkg-plist
index 8141ddc3f30c..e28319574b79 100644
--- a/games/gnome-games/pkg-plist
+++ b/games/gnome-games/pkg-plist
@@ -37,7 +37,6 @@ share/gnome/blackjack/Ameristar.rules
share/gnome/blackjack/Atlantic_City.rules
share/gnome/blackjack/Vegas_Downtown.rules
share/gnome/blackjack/Vegas_Strip.rules
-@unexec [ -s %D/share/gnome/games/glines.scores ] || rm -f %D/share/gnome/games/glines.scores
@unexec [ -s %D/share/gnome/games/glines.Large.scores ] || rm -f %D/share/gnome/games/glines.Large.scores
@unexec [ -s %D/share/gnome/games/glines.Medium.scores ] || rm -f %D/share/gnome/games/glines.Medium.scores
@unexec [ -s %D/share/gnome/games/glines.Small.scores ] || rm -f %D/share/gnome/games/glines.Small.scores
@@ -124,7 +123,6 @@ share/gnome/blackjack/Vegas_Strip.rules
@unexec [ -s %D/share/gnome/games/same-gnome.Large.scores ] || rm -f %D/share/gnome/games/same-gnome.Large.scores
@unexec [ -s %D/share/gnome/games/same-gnome.Medium.scores ] || rm -f %D/share/gnome/games/same-gnome.Medium.scores
@unexec [ -s %D/share/gnome/games/same-gnome.Small.scores ] || rm -f %D/share/gnome/games/same-gnome.Small.scores
-@unexec [ -L %D/share/gnome/games/same-gnome.scores ] || rm -f %D/share/gnome/games/same-gnome.scores
share/gnome/gnect/white_ob.cn4.gz
share/gnome/gnibbles/level001.gnl
share/gnome/gnibbles/level002.gnl
@@ -205,8 +203,8 @@ share/gnome/help/aisleriot/C/isabel.xml
share/gnome/help/aisleriot/C/jamestown.xml
share/gnome/help/aisleriot/C/jumbo.xml
share/gnome/help/aisleriot/C/kansas.xml
-share/gnome/help/aisleriot/C/kings_audience.xml
share/gnome/help/aisleriot/C/king_albert.xml
+share/gnome/help/aisleriot/C/kings_audience.xml
share/gnome/help/aisleriot/C/klondike.xml
share/gnome/help/aisleriot/C/labyrinth.xml
share/gnome/help/aisleriot/C/lady_jane.xml
@@ -248,8 +246,8 @@ share/gnome/help/aisleriot/C/yield.xml
share/gnome/help/aisleriot/C/yukon.xml
share/gnome/help/aisleriot/C/zebra.xml
share/gnome/help/aisleriot/fr/agnes.xml
-share/gnome/help/aisleriot/fr/athena.xml
share/gnome/help/aisleriot/fr/aisleriot.xml
+share/gnome/help/aisleriot/fr/athena.xml
share/gnome/help/aisleriot/fr/auld_lang_syne.xml
share/gnome/help/aisleriot/fr/aunt_mary.xml
share/gnome/help/aisleriot/fr/backbone.xml
@@ -291,8 +289,8 @@ share/gnome/help/aisleriot/fr/isabel.xml
share/gnome/help/aisleriot/fr/jamestown.xml
share/gnome/help/aisleriot/fr/jumbo.xml
share/gnome/help/aisleriot/fr/kansas.xml
-share/gnome/help/aisleriot/fr/kings_audience.xml
share/gnome/help/aisleriot/fr/king_albert.xml
+share/gnome/help/aisleriot/fr/kings_audience.xml
share/gnome/help/aisleriot/fr/klondike.xml
share/gnome/help/aisleriot/fr/labyrinth.xml
share/gnome/help/aisleriot/fr/lady_jane.xml
@@ -518,9 +516,9 @@ share/gnome/pixmaps/iagno/woodtrim.png
share/gnome/pixmaps/mahjongg/postmodern.svg
share/gnome/pixmaps/mahjongg/smooth.png
share/gnome/sol-games/agnes.scm
-share/gnome/sol-games/aunt_mary.scm
share/gnome/sol-games/athena.scm
share/gnome/sol-games/auld_lang_syne.scm
+share/gnome/sol-games/aunt_mary.scm
share/gnome/sol-games/backbone.scm
share/gnome/sol-games/bakers_dozen.scm
share/gnome/sol-games/bakers_game.scm
@@ -558,8 +556,8 @@ share/gnome/sol-games/isabel.scm
share/gnome/sol-games/jamestown.scm
share/gnome/sol-games/jumbo.scm
share/gnome/sol-games/kansas.scm
-share/gnome/sol-games/kings_audience.scm
share/gnome/sol-games/king_albert.scm
+share/gnome/sol-games/kings_audience.scm
share/gnome/sol-games/klondike.scm
share/gnome/sol-games/labyrinth.scm
share/gnome/sol-games/lady_jane.scm
@@ -818,8 +816,6 @@ share/locale/zh_TW/LC_MESSAGES/gnome-games.mo
@dirrm share/gnome/gnibbles
@dirrm share/gnome/gnect
@dirrm share/gnome/blackjack
-@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
-@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
@dirrmtry share/locale/zh_TW/LC_MESSAGES
@dirrmtry share/locale/zh_TW
@dirrmtry share/locale/zh_HK/LC_MESSAGES