aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--print/pdfcube/Makefile2
-rw-r--r--science/cdo/Makefile4
-rw-r--r--science/pcmsolver/Makefile2
-rw-r--r--security/clamfs/Makefile1
-rw-r--r--security/highwayhash/Makefile1
-rw-r--r--security/iaikpkcs11wrapper/Makefile2
-rw-r--r--security/libtomcrypt/Makefile2
-rw-r--r--security/py-python-nss/Makefile2
-rw-r--r--security/spass/Makefile5
-rw-r--r--sysutils/cbsd/Makefile2
-rw-r--r--sysutils/condor/Makefile2
-rw-r--r--sysutils/fusefs-libs3/Makefile2
-rw-r--r--sysutils/incron/Makefile2
-rw-r--r--sysutils/smart/Makefile1
-rw-r--r--textproc/ffe/Makefile2
-rw-r--r--textproc/heirloom-doctools/Makefile2
-rw-r--r--textproc/libmwaw03/Makefile2
-rw-r--r--textproc/multimarkdown/Makefile2
-rw-r--r--textproc/source-highlight/Makefile3
-rw-r--r--textproc/xmlwrapp/Makefile4
-rw-r--r--www/domoticz/Makefile2
-rw-r--r--www/h2o/Makefile1
-rw-r--r--www/mod_md-devel/Makefile2
-rw-r--r--x11-toolkits/gnustep-gui/Makefile1
-rw-r--r--x11-toolkits/gtksourceview3/Makefile2
-rw-r--r--x11-toolkits/py-fltk/Makefile4
-rw-r--r--x11-wm/gcompmgr/Makefile2
27 files changed, 52 insertions, 7 deletions
diff --git a/print/pdfcube/Makefile b/print/pdfcube/Makefile
index 377c7ea37f28..dc9b9fa11b00 100644
--- a/print/pdfcube/Makefile
+++ b/print/pdfcube/Makefile
@@ -10,6 +10,8 @@ MASTER_SITES= http://code.100allora.it/releases/pdfcube/
MAINTAINER= lwhsu@FreeBSD.org
COMMENT= OpenGL presentation viewer on a spinning cube
+BROKEN_powerpc64= fails to configure: checking for exit in -lboost_program_options... no
+
LIB_DEPENDS= libgtkglext-x11-1.0.so:x11-toolkits/gtkglext \
libpoppler-glib.so:graphics/poppler-glib \
libboost_program_options.so:devel/boost-libs
diff --git a/science/cdo/Makefile b/science/cdo/Makefile
index 08dfe97f8d1d..c57d235c57a8 100644
--- a/science/cdo/Makefile
+++ b/science/cdo/Makefile
@@ -13,6 +13,8 @@ COMMENT= Climate Data Operators
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_powerpc64= fails to compile: remaplib.cc:1504:6: internal compiler error: in gsi_insert_seq_nodes_after, at gimple-iterator.c:283
+
OPTIONS_DEFINE= CGRIBEX HDF5 JASPER NETCDF PROJ SZIP UDUNITS UUID
OPTIONS_DEFAULT=CGRIBEX HDF5 JASPER NETCDF PROJ SZIP UDUNITS UUID
OPTIONS_SUB= yes
@@ -36,9 +38,9 @@ GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
MAKE_JOBS_UNSAFE= yes
TEST_TARGET= check
+USES= compiler:c++11-lib gmake libtool localbase pathfix
USE_CXXSTD= c++11
USE_LDCONFIG= yes
-USES= compiler:c++11-lib gmake libtool localbase pathfix
CGRIBEX_CONFIGURE_WITH= cgribex
CGRIBEX_LIB_DEPENDS= libcgribex.so:science/cgribex
diff --git a/science/pcmsolver/Makefile b/science/pcmsolver/Makefile
index a4a7ebf776c0..cf3d6f6218cd 100644
--- a/science/pcmsolver/Makefile
+++ b/science/pcmsolver/Makefile
@@ -11,6 +11,8 @@ COMMENT= API for the Polarizable Continuum Model
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_powerpc64= fails to compile: SphericalDiffuse.cpp:182: invalid initialization of non-const reference
+
LIB_DEPENDS= libflang.so:devel/flang # USES=fortran:clang breaks in configure: can't find libs directory
USES= cmake:outsource,noninja python
diff --git a/security/clamfs/Makefile b/security/clamfs/Makefile
index 73f436ece959..3a9ffad574c6 100644
--- a/security/clamfs/Makefile
+++ b/security/clamfs/Makefile
@@ -14,6 +14,7 @@ LICENSE= GPLv2
BROKEN_armv6= fails to compile: ./config.hxx:52:17: expected namespace name
BROKEN_armv7= fails to compile: ./config.hxx:52:17: expected namespace name
+BROKEN_powerpc64= fails to compile: g++6: unrecognized command line option '-mavx2'
LIB_DEPENDS= libccgnu2.so:devel/commoncpp \
libPocoNet.so:devel/poco-ssl \
diff --git a/security/highwayhash/Makefile b/security/highwayhash/Makefile
index bf74e59dd90a..63f4ce7f096c 100644
--- a/security/highwayhash/Makefile
+++ b/security/highwayhash/Makefile
@@ -12,6 +12,7 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_aarch64= fails to compile: /usr/lib/clang/5.0.0/include/mmintrin.h:47:5: use of undeclared identifier '__builtin_ia32_emms'
+BROKEN_powerpc64= fails to link: main.cpp.o: undefined reference to `boost::program_options::options_description::options_description
ONLY_FOR_ARCHS= aarch64 amd64 powerpc powerpc64
ONLY_FOR_ARCHS_REASON= Assembly is implemented only for specific architectures in highwayhash/tsc_timer.h
diff --git a/security/iaikpkcs11wrapper/Makefile b/security/iaikpkcs11wrapper/Makefile
index 806046a51668..dcf463550d7a 100644
--- a/security/iaikpkcs11wrapper/Makefile
+++ b/security/iaikpkcs11wrapper/Makefile
@@ -10,6 +10,8 @@ DISTNAME= ${PORTNAME}_${PORTVERSION:S/./_/g}
MAINTAINER= ale@FreeBSD.org
COMMENT= PKCS\#11 Java wrapper
+BROKEN_powerpc64= fails to link: cannot find -lgcc
+
OPTIONS_DEFINE= DOCS EXAMPLES
USES= dos2unix gmake zip
diff --git a/security/libtomcrypt/Makefile b/security/libtomcrypt/Makefile
index 3a5ca13c8384..7da50afc19b6 100644
--- a/security/libtomcrypt/Makefile
+++ b/security/libtomcrypt/Makefile
@@ -14,6 +14,8 @@ COMMENT= Comprehensive, modular, and portable cryptographic toolkit
LICENSE= PD
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_powerpc64= fails to compile: unrecognized command line option "-Wno-type-limits"
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
CFLAGS+= -I${LOCALBASE}/include
diff --git a/security/py-python-nss/Makefile b/security/py-python-nss/Makefile
index 2e9adfe5bb24..54adb87c98ff 100644
--- a/security/py-python-nss/Makefile
+++ b/security/py-python-nss/Makefile
@@ -15,6 +15,8 @@ LICENSE_FILE_LGPL21+ = ${WRKSRC}/LICENSE.lgpl
LICENSE_FILE_GPLv2+ = ${WRKSRC}/LICENSE.gpl
LICENSE_FILE_MPL20= ${WRKSRC}/LICENSE.mpl
+BROKEN_powerpc64= fails to compile: py_nss.c:20285: #pragma GCC diagnostic not allowed inside functions
+
LIB_DEPENDS= libnspr4.so:devel/nspr \
libnss3.so:security/nss
diff --git a/security/spass/Makefile b/security/spass/Makefile
index c4d94ed3837e..555ebd5d7f61 100644
--- a/security/spass/Makefile
+++ b/security/spass/Makefile
@@ -11,11 +11,12 @@ COMMENT= Secure password generator with a true random number generator
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_sparc64= cannot link with boost
+BROKEN_powerpc64= fails to link: main.cpp.o: undefined reference to boost::program_options::options_description::options_description
+
BUILD_DEPENDS= ${LOCALBASE}/include/boost/format.hpp:devel/boost-libs
LIB_DEPENDS= libboost_program_options.so:devel/boost-libs
-BROKEN_sparc64= cannot link with boost
-
USE_GITHUB= yes
GH_ACCOUNT= guyru
GH_TAGNAME= cb0de64
diff --git a/sysutils/cbsd/Makefile b/sysutils/cbsd/Makefile
index c710618ff586..c241dc27a09e 100644
--- a/sysutils/cbsd/Makefile
+++ b/sysutils/cbsd/Makefile
@@ -10,6 +10,8 @@ COMMENT= Yet another FreeBSD Jail and Bhyve Management Utility
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_powerpc64= fails to link: cannot find -lc++
+
RUN_DEPENDS= rsync:net/rsync \
sudo:security/sudo \
sqlite3:databases/sqlite3 \
diff --git a/sysutils/condor/Makefile b/sysutils/condor/Makefile
index 892b8c2d4f9f..67b69656e51d 100644
--- a/sysutils/condor/Makefile
+++ b/sysutils/condor/Makefile
@@ -17,7 +17,7 @@ COMMENT= High-throughput computing on distributively owned resources
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE-2.0.txt
-BROKEN_powerpc64= fails to build
+BROKEN_powerpc64= fails to link: test_unit.hpp:249: undefined reference to boost::unit_test::ut_detail::normalize_test_case_name
LIB_DEPENDS= libkrb5support.so:security/krb5 \
libpcre.so:devel/pcre \
diff --git a/sysutils/fusefs-libs3/Makefile b/sysutils/fusefs-libs3/Makefile
index f237a538eeff..6618a4f3b3dd 100644
--- a/sysutils/fusefs-libs3/Makefile
+++ b/sysutils/fusefs-libs3/Makefile
@@ -12,6 +12,8 @@ COMMENT= FUSE library version 3 for filesystems implemented in userspace
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING.LIB
+BROKEN_powerpc64= fails to compile: unrecognized command line option "-Wno-unused-result"
+
USES= meson
USE_LDCONFIG= yes
diff --git a/sysutils/incron/Makefile b/sysutils/incron/Makefile
index 9f26aa63736d..ce0984f5e852 100644
--- a/sysutils/incron/Makefile
+++ b/sysutils/incron/Makefile
@@ -15,6 +15,8 @@ LICENSE_FILE_GPLv2= ${WRKSRC}/LICENSE-GPL
LICENSE_FILE_LGPL21= ${WRKSRC}/LICENSE-LGPL
LICENSE_FILE_MIT= ${WRKSRC}/LICENSE-X11
+BROKEN_powerpc64= fails to compile: usertable.cpp:440: #pragma GCC diagnostic not allowed inside functions
+
LIB_DEPENDS= libinotify.so:devel/libinotify
USE_GITHUB= indeed
diff --git a/sysutils/smart/Makefile b/sysutils/smart/Makefile
index db41b7e0e008..06fb61f18f35 100644
--- a/sysutils/smart/Makefile
+++ b/sysutils/smart/Makefile
@@ -9,6 +9,7 @@ COMMENT= Output disk SMART values
LICENSE= ISCL
+BROKEN_powerpc64= fails to compile: libsmart.c:241: storage size of 's' isn't constant
IGNORE_FreeBSD_10= Requires FreeBSD 11 or later
USE_GITHUB= yes
diff --git a/textproc/ffe/Makefile b/textproc/ffe/Makefile
index 047985c07b8a..ea77573fecfc 100644
--- a/textproc/ffe/Makefile
+++ b/textproc/ffe/Makefile
@@ -12,6 +12,8 @@ COMMENT= Flat file extractor
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_powerpc64= fails to compile: unrecognized command line option "-Wmaybe-uninitialized"
+
LIB_DEPENDS= libgcrypt.so:security/libgcrypt \
libgpg-error.so:security/libgpg-error
diff --git a/textproc/heirloom-doctools/Makefile b/textproc/heirloom-doctools/Makefile
index ca7100ad1d5c..90525d362992 100644
--- a/textproc/heirloom-doctools/Makefile
+++ b/textproc/heirloom-doctools/Makefile
@@ -10,6 +10,8 @@ COMMENT= Portable and enhanced troff, nroff, and related utilities
LICENSE= CDDL
+BROKEN_powerpc64= fails to package: Unable to access file pub/utf-8: No such file or directory
+
USES= gmake
USE_GITHUB= yes
GH_ACCOUNT= n-t-roff
diff --git a/textproc/libmwaw03/Makefile b/textproc/libmwaw03/Makefile
index 903b7c4852f7..167e588f2378 100644
--- a/textproc/libmwaw03/Makefile
+++ b/textproc/libmwaw03/Makefile
@@ -12,6 +12,8 @@ COMMENT= Import library for some old mac text documents
LICENSE= LGPL21+ MPL20
LICENSE_COMB= dual
+BROKEN_powerpc64= fails to compile: MWAWCell.cxx:644: #pragma GCC diagnostic not allowed inside functions
+
LIB_DEPENDS= librevenge-0.0.so:textproc/librevenge
CONFIGURE_ARGS= --disable-werror --without-docs
diff --git a/textproc/multimarkdown/Makefile b/textproc/multimarkdown/Makefile
index 86a134542c56..cce9a87732a8 100644
--- a/textproc/multimarkdown/Makefile
+++ b/textproc/multimarkdown/Makefile
@@ -13,6 +13,8 @@ LICENSE= BSD3CLAUSE MIT GPLv2+ ZLIB
LICENSE_COMB= multi
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+BROKEN_powerpc64= fails to compile: Sources/libMultiMarkdown/file.h:116: redefinition of typedef 'DString'
+
LIB_DEPENDS= libcurl.so:ftp/curl
USES= cmake
diff --git a/textproc/source-highlight/Makefile b/textproc/source-highlight/Makefile
index b5d46f9bc323..6f5cbd72b374 100644
--- a/textproc/source-highlight/Makefile
+++ b/textproc/source-highlight/Makefile
@@ -13,7 +13,8 @@ COMMENT= C/C++ and Java sources to HTML converter
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_sparc64= Does not compile with GCC 4.2
+BROKEN_powerpc64= fails to configure: checking for exit in -lboost_regex... (cached) no
+BROKEN_sparc64= fails to compile with GCC 4.2
BUILD_DEPENDS= exctags:devel/ctags
LIB_DEPENDS= libboost_regex.so:devel/boost-libs
diff --git a/textproc/xmlwrapp/Makefile b/textproc/xmlwrapp/Makefile
index cca4cf01bc65..9e03eb3e5803 100644
--- a/textproc/xmlwrapp/Makefile
+++ b/textproc/xmlwrapp/Makefile
@@ -13,6 +13,8 @@ COMMENT= Modern style C++ library for working with XML data
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_powerpc64= fails to configure: invalid value: boost_major_version=
+
LIB_DEPENDS= libboost_iostreams.so:devel/boost-libs
OPTIONS_DEFINE= XSLT DOCS
@@ -22,7 +24,7 @@ OPTIONS_SUB= yes
XSLT_USE= gnome=libxslt
XSLT_CONFIGURE_ENABLE= xslt
-USES= pathfix pkgconfig libtool
+USES= compiler:c++11-lang libtool pathfix pkgconfig
USE_GNOME= libxml2
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/www/domoticz/Makefile b/www/domoticz/Makefile
index 77d72d7b1d6f..4bf118a25303 100644
--- a/www/domoticz/Makefile
+++ b/www/domoticz/Makefile
@@ -11,6 +11,8 @@ COMMENT= Home Automation System
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/License.txt
+BROKEN_powerpc64= fails to compile: libboost_thread.so: undefined reference to std::__cxx11::basic_string
+
LIB_DEPENDS= libcurl.so:ftp/curl \
libexpat.so:textproc/expat2
diff --git a/www/h2o/Makefile b/www/h2o/Makefile
index b087f018b847..73fbe42c0383 100644
--- a/www/h2o/Makefile
+++ b/www/h2o/Makefile
@@ -15,6 +15,7 @@ LICENSE_COMB= multi
BROKEN_armv6= fails to compile: asm_arm.inc:139:36: '.syntax divided' arm assembly not supported
BROKEN_armv7= fails to compile: asm_arm.inc:139:36: '.syntax divided' arm assembly not supported
+BROKEN_powerpc64= fails to link: unrecognized option '-Wl,-rpath=/usr/local/lib/gcc6'
LIB_DEPENDS= libuv.so:devel/libuv
diff --git a/www/mod_md-devel/Makefile b/www/mod_md-devel/Makefile
index 0263bbdb6a63..330e8738dafd 100644
--- a/www/mod_md-devel/Makefile
+++ b/www/mod_md-devel/Makefile
@@ -14,6 +14,8 @@ COMMENT= Early experience LetsEncrypt module for Apache httpd
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_powerpc64= fails to compile: md_json.c:29: expected [error|warning|ignored] after '#pragma GCC diagnostic'
+
LIB_DEPENDS= libaprutil-1.so:devel/apr1 \
libcurl.so:ftp/curl \
libjansson.so:devel/jansson
diff --git a/x11-toolkits/gnustep-gui/Makefile b/x11-toolkits/gnustep-gui/Makefile
index 33422fe2ac1b..e8891dc1761d 100644
--- a/x11-toolkits/gnustep-gui/Makefile
+++ b/x11-toolkits/gnustep-gui/Makefile
@@ -23,6 +23,7 @@ LIB_DEPENDS+= libflite.so:audio/flite
BROKEN_armv6= fails to package: chmod: GSSpeechServer.desktop: No such file or directory
BROKEN_armv7= fails to package: chmod: GSSpeechServer.desktop: No such file or directory
+BROKEN_powerpc64= fails to build: Illegal instruction (core dumped)
OPTIONS_DEFINE= DOCS CUPS ASPELL
OPTIONS_DEFAULT= CUPS
diff --git a/x11-toolkits/gtksourceview3/Makefile b/x11-toolkits/gtksourceview3/Makefile
index ae8aa1de22f2..30e4306c9cce 100644
--- a/x11-toolkits/gtksourceview3/Makefile
+++ b/x11-toolkits/gtksourceview3/Makefile
@@ -11,6 +11,8 @@ DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= Text widget that adds syntax highlighting to the GtkTextView widget
+BROKEN_powerpc64= fails to compile: gtksourcetag.h:43: redefinition of typedef 'GtkSourceTag'
+
USES= tar:xz
PORTSCOUT= limitw:1,even
diff --git a/x11-toolkits/py-fltk/Makefile b/x11-toolkits/py-fltk/Makefile
index bdd505f64642..99f551c9558c 100644
--- a/x11-toolkits/py-fltk/Makefile
+++ b/x11-toolkits/py-fltk/Makefile
@@ -14,13 +14,15 @@ COMMENT= Python interface to FLTK window toolkit
LICENSE= LGPL20
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_powerpc64= fails to compile: fltk_wrap.cpp:5355: #pragma GCC diagnostic not allowed inside functions
+
LIB_DEPENDS= libfltk.so:x11-toolkits/fltk
CFLAGS+= -DFL_LIBRARY
MAKE_ENV= FLTK_HOME=${LOCALBASE}/bin
+USES= python
USE_PYTHON= autoplist distutils
USE_XORG= x11
-USES= python
DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
diff --git a/x11-wm/gcompmgr/Makefile b/x11-wm/gcompmgr/Makefile
index 4779394284f8..d33295d0ee43 100644
--- a/x11-wm/gcompmgr/Makefile
+++ b/x11-wm/gcompmgr/Makefile
@@ -10,6 +10,8 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= GNOME interface to xcompmgr
+BROKEN_powerpc64= fails to compile: params.cc:135:37: 'memset' was not declared in this scope
+
RUN_DEPENDS= xcompmgr:x11-wm/xcompmgr
GNU_CONFIGURE= yes