aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Class-Generate/Makefile23
-rw-r--r--devel/p5-Class-Generate/distinfo1
-rw-r--r--devel/p5-Class-Generate/pkg-comment1
-rw-r--r--devel/p5-Class-Generate/pkg-descr10
-rw-r--r--devel/p5-Class-Generate/pkg-plist6
6 files changed, 42 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 88d42f82a690..896924a87b87 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -414,6 +414,7 @@
SUBDIR += p5-Class-Factory
SUBDIR += p5-Class-Factory-Util
SUBDIR += p5-Class-Fields
+ SUBDIR += p5-Class-Generate
SUBDIR += p5-Class-ISA
SUBDIR += p5-Class-Inner
SUBDIR += p5-Class-Loader
diff --git a/devel/p5-Class-Generate/Makefile b/devel/p5-Class-Generate/Makefile
new file mode 100644
index 000000000000..d7defc826dcf
--- /dev/null
+++ b/devel/p5-Class-Generate/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: Class:Generate
+# Date created: 24 October 2002
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-Generate
+PORTVERSION= 1.06
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Class
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+PERL_CONFIGURE= yes
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+MAN3= Class::Generate.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Class-Generate/distinfo b/devel/p5-Class-Generate/distinfo
new file mode 100644
index 000000000000..f2881d306992
--- /dev/null
+++ b/devel/p5-Class-Generate/distinfo
@@ -0,0 +1 @@
+MD5 (Class-Generate-1.06.tar.gz) = 8db5448af78c4741eaa5c3aaadfc49ca
diff --git a/devel/p5-Class-Generate/pkg-comment b/devel/p5-Class-Generate/pkg-comment
new file mode 100644
index 000000000000..0faaaee7bee3
--- /dev/null
+++ b/devel/p5-Class-Generate/pkg-comment
@@ -0,0 +1 @@
+A Perl5 module to simplify creating class hierarchies
diff --git a/devel/p5-Class-Generate/pkg-descr b/devel/p5-Class-Generate/pkg-descr
new file mode 100644
index 000000000000..e1de38037efb
--- /dev/null
+++ b/devel/p5-Class-Generate/pkg-descr
@@ -0,0 +1,10 @@
+Class::Generate is a Perl5 module to simplify creating class
+hierarchies. It offers typed or untyped scalar, array, and hash
+members, required members, private members, methods (both
+instance and class), and other common features of object-
+oriented software development. Of course, you can implement all
+these things without a special module, but doing it via
+Class::Generate is much, much more concise. And futhermore,
+it's much less error prone: if you are using Perl's -w flag,
+Class::Generate will catch many class specification and usage
+errors.
diff --git a/devel/p5-Class-Generate/pkg-plist b/devel/p5-Class-Generate/pkg-plist
new file mode 100644
index 000000000000..5871c5d5b56d
--- /dev/null
+++ b/devel/p5-Class-Generate/pkg-plist
@@ -0,0 +1,6 @@
+lib/perl5/site_perl/%%PERL_VER%%/Class/Generate.pm
+lib/perl5/site_perl/%%PERL_VER%%/Class/Generate.pod
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Class/Generate/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Class
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Class/Generate
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Class