aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/penguin-command/Makefile5
-rw-r--r--graphics/icontact/Makefile6
-rw-r--r--graphics/vp/Makefile3
-rw-r--r--security/stegdetect/Makefile5
4 files changed, 12 insertions, 7 deletions
diff --git a/games/penguin-command/Makefile b/games/penguin-command/Makefile
index a345eb3c8569..f512966e5872 100644
--- a/games/penguin-command/Makefile
+++ b/games/penguin-command/Makefile
@@ -19,14 +19,15 @@ LIB_DEPENDS= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
MAN6= penguin-command.6
post-patch:
- ${PERL} -pi -e 's|"SDL/SDL|"SDL|g ; s|<SDL/SDL|<SDL|g' \
+ ${REINPLACE_CMD} 's|"SDL/SDL|"SDL|g ; s|<SDL/SDL|<SDL|g' \
${WRKSRC}/configure ${WRKSRC}/src/*.[ch]
- ${PERL} -pi -e "s/ -lz -lSDL -lm/ -lz -lm/g" ${WRKSRC}/configure
+ ${REINPLACE_CMD} 's/ -lz -lSDL -lm/ -lz -lm/g' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/graphics/icontact/Makefile b/graphics/icontact/Makefile
index 282ddec34eb0..469a06e8d552 100644
--- a/graphics/icontact/Makefile
+++ b/graphics/icontact/Makefile
@@ -15,10 +15,12 @@ MAINTAINER= markp@FreeBSD.org
RUN_DEPENDS= ${LOCALBASE}/bin/ppmmake:${PORTSDIR}/graphics/netpbm \
${LOCALBASE}/bin/cjpeg:${PORTSDIR}/graphics/jpeg
+USE_REINPLACE= yes
MAN1= icontact.1 xvtoppm.1
-pre-build:
- ${PERL} -pi -e "s@CC=cc@CC=${CC}@g;s@CFLAGS=-O@CFLAGS=${CFLAGS}@g" ${WRKSRC}/Makefile
+post-patch:
+ ${REINPLACE_CMD} "s/CC=cc/CC=${CC}/g; s/CFLAGS=-O/CFLAGS=${CFLAGS}/g" \
+ ${WRKSRC}/Makefile
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/icontact ${PREFIX}/bin
diff --git a/graphics/vp/Makefile b/graphics/vp/Makefile
index 4fd53ff1ecdd..3351afab16fa 100644
--- a/graphics/vp/Makefile
+++ b/graphics/vp/Makefile
@@ -21,9 +21,10 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -lgnugetopt" \
ac_cv_func_getopt_long=yes
+USE_REINPLACE= yes
MAN1= vp.1
post-patch:
- @${PERL} -pi -e 's@ getopt_long/Makefile@@g' ${WRKSRC}/configure
+ ${REINPLACE_CMD} 's@ getopt_long/Makefile@@g' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/security/stegdetect/Makefile b/security/stegdetect/Makefile
index 1c5f3e552ec6..ebdf27c1e71d 100644
--- a/security/stegdetect/Makefile
+++ b/security/stegdetect/Makefile
@@ -20,6 +20,7 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libevent.a:${PORTSDIR}/devel/libevent
# Note: stegdetect includes a modified version of jpeg-6b linked statically
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_REINPLACE= yes
MAN1= stegdetect.1 stegbreak.1
.if defined(WITHOUT_X11)
@@ -32,10 +33,10 @@ PLIST_SUB+= X11=""
.endif
post-patch:
- @${PERL} -pi -e 's@\$$\(JPEGLIB\)@\$$\(JPEGLIB\) \-lcrypto@' \
+ ${REINPLACE_CMD} 's/$$(JPEGLIB)/$$(JPEGLIB) -lcrypto/' \
${WRKSRC}/Makefile.in
.if defined(WITHOUT_X11)
- @${PERL} -pi -e 's/gtk-config//g' ${WRKSRC}/configure
+ ${REINPLACE_CMD} 's/gtk-config//g' ${WRKSRC}/configure
.endif
.include <bsd.port.mk>