aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/Makefile1
-rw-r--r--mail/greyfix/Makefile35
-rw-r--r--mail/greyfix/distinfo2
-rw-r--r--mail/greyfix/files/pkg-message.in21
-rw-r--r--mail/greyfix/pkg-descr5
-rw-r--r--mail/greyfix/pkg-plist4
6 files changed, 68 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 10e977ea8278..6d08a597687d 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -182,6 +182,7 @@
SUBDIR += gnumail
SUBDIR += gotmail
SUBDIR += grepmail
+ SUBDIR += greyfix
SUBDIR += greylite
SUBDIR += gtray
SUBDIR += gubby
diff --git a/mail/greyfix/Makefile b/mail/greyfix/Makefile
new file mode 100644
index 000000000000..bc0c126fc947
--- /dev/null
+++ b/mail/greyfix/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: greyfix
+# Date created: 2011-05-14
+# Whom: Keith Gaughan <k@stereochro.me>
+#
+# $FreeBSD$
+#
+
+PORTNAME= greyfix
+PORTVERSION= 0.3.9
+CATEGORIES= mail
+MASTER_SITES= http://www.kim-minh.com/pub/greyfix/
+
+MAINTAINER= k@stereochro.me
+COMMENT= A greylisting policy daemon for Postfix
+
+SUB_FILES= pkg-message
+
+USE_BDB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-berkeleydb-libdir=${BDB_LIB_DIR} \
+ --with-berkeleydb-includedir=${BDB_INCLUDE_DIR} \
+ --localstatedir=/var
+
+post-patch:
+ @${REINPLACE_CMD} 's|-ldb|-l${BDB_LIB_NAME}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} 's|$$(localstatedir)/lib|$$(localstatedir)/db|' ${WRKSRC}/Makefile.in
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/greyfix ${PREFIX}/sbin
+ @${INSTALL} -o nobody -m 700 -d /var/db/greyfix
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/mail/greyfix/distinfo b/mail/greyfix/distinfo
new file mode 100644
index 000000000000..d1f50d79f149
--- /dev/null
+++ b/mail/greyfix/distinfo
@@ -0,0 +1,2 @@
+SHA256 (greyfix-0.3.9.tar.gz) = dee4428aef9b248b68799a640a85b44ffee0e9a3b2d2f16eed1bb41edad5f204
+SIZE (greyfix-0.3.9.tar.gz) = 79883
diff --git a/mail/greyfix/files/pkg-message.in b/mail/greyfix/files/pkg-message.in
new file mode 100644
index 000000000000..32b70d8320ad
--- /dev/null
+++ b/mail/greyfix/files/pkg-message.in
@@ -0,0 +1,21 @@
+Edit Postfix's master configuration file, master.cf, and add the following:
+
+ greyfix unix - n n - - spawn
+ user=nobody argv=%%PREFIX%%/sbin/greyfix -/ 24
+
+(The -/ argument specifies how much of the IP address to consider significant,
+in this case the first 24 bits.)
+
+Edit Postfix's main configuration file, main.cf and add the following:
+
+ smtpd_recipient_restrictions = permit_mynetworks,
+ reject_unauth_destination,
+ check_policy_service unix:private/greyfix
+
+If there is already a smtpd_recipient_restrictions configuration line you
+should edit it rather than add a new one. The important part for Greyfix is
+that you should add check_policy_service unix:private/greyfix to it.
+
+Finally have postfix reload its configuration with:
+
+ %%PREFIX%%/etc/rc.d/postfix reload
diff --git a/mail/greyfix/pkg-descr b/mail/greyfix/pkg-descr
new file mode 100644
index 000000000000..a9a0fa5f18bd
--- /dev/null
+++ b/mail/greyfix/pkg-descr
@@ -0,0 +1,5 @@
+Greyfix is the greylisting policy daemon for Postfix written by Kim Minh
+Kaplan. Greyfix uses Postfix policy mechanism to enable greylisting with
+Postfix.
+
+WWW: http://www.kim-minh.com/pub/greyfix/
diff --git a/mail/greyfix/pkg-plist b/mail/greyfix/pkg-plist
new file mode 100644
index 000000000000..61a7ac4870de
--- /dev/null
+++ b/mail/greyfix/pkg-plist
@@ -0,0 +1,4 @@
+@exec mkdir -m 700 -p /var/db/greyfix && chown nobody /var/db/greyfix
+sbin/greyfix
+@cwd /
+@dirrmtry /var/db/greyfix