aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/gnome-vfs/Makefile8
-rw-r--r--devel/gnomevfs2/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/devel/gnome-vfs/Makefile b/devel/gnome-vfs/Makefile
index e5b4258219bf..1bdefdfd22c3 100644
--- a/devel/gnome-vfs/Makefile
+++ b/devel/gnome-vfs/Makefile
@@ -34,9 +34,12 @@ CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/lib/libcdda_paranoia.so.0)
+.if exists(${LOCALBASE}/lib/libcdda_paranoia.a)
WITH_CDPARANOIA= yes
.endif
+.if exists(${LOCALBASE}/lib/libfam.a)
+WITH_FAM= yes
+.endif
.if defined(WITH_CDPARANOIA)
LIB_DEPENDS+= cdda_paranoia.0:${PORTSDIR}/audio/cdparanoia
@@ -44,6 +47,9 @@ PLIST_SUB+= CDPARANOIA=""
.else
PLIST_SUB+= CDPARANOIA="@comment "
.endif
+.if defined(WITH_FAM)
+LIB_DEPENDS+= fam.0:${PORTSDIR}/devel/fam
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
diff --git a/devel/gnomevfs2/Makefile b/devel/gnomevfs2/Makefile
index e5b4258219bf..1bdefdfd22c3 100644
--- a/devel/gnomevfs2/Makefile
+++ b/devel/gnomevfs2/Makefile
@@ -34,9 +34,12 @@ CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/lib/libcdda_paranoia.so.0)
+.if exists(${LOCALBASE}/lib/libcdda_paranoia.a)
WITH_CDPARANOIA= yes
.endif
+.if exists(${LOCALBASE}/lib/libfam.a)
+WITH_FAM= yes
+.endif
.if defined(WITH_CDPARANOIA)
LIB_DEPENDS+= cdda_paranoia.0:${PORTSDIR}/audio/cdparanoia
@@ -44,6 +47,9 @@ PLIST_SUB+= CDPARANOIA=""
.else
PLIST_SUB+= CDPARANOIA="@comment "
.endif
+.if defined(WITH_FAM)
+LIB_DEPENDS+= fam.0:${PORTSDIR}/devel/fam
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure