aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Search-VectorSpace/Makefile31
-rw-r--r--textproc/p5-Search-VectorSpace/distinfo2
-rw-r--r--textproc/p5-Search-VectorSpace/pkg-descr12
-rw-r--r--textproc/p5-Search-VectorSpace/pkg-plist6
5 files changed, 52 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 3d7a0fce734d..6ab79d009c6a 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -355,6 +355,7 @@
SUBDIR += p5-Regexp-Log-Common
SUBDIR += p5-SVG
SUBDIR += p5-Search-Saryer
+ SUBDIR += p5-Search-VectorSpace
SUBDIR += p5-Sort-ArbBiLex
SUBDIR += p5-Sort-Fields
SUBDIR += p5-Sort-Naturally
diff --git a/textproc/p5-Search-VectorSpace/Makefile b/textproc/p5-Search-VectorSpace/Makefile
new file mode 100644
index 000000000000..edf853b57612
--- /dev/null
+++ b/textproc/p5-Search-VectorSpace/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Search-VectorSpace
+# Date created: 2004-10-26
+# Whom: clsung
+#
+# $FreeBSD$
+#
+
+PORTNAME= Search-VectorSpace
+PORTVERSION= 0.02
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Search
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= A very basic vector-space search engine perl module
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/PDL.pm:${PORTSDIR}/math/PDL \
+ ${SITE_PERL}/Lingua/Stem.pm:${PORTSDIR}/textproc/p5-Lingua-Stem
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+MAN3= Search::VectorSpace.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= This port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Search-VectorSpace/distinfo b/textproc/p5-Search-VectorSpace/distinfo
new file mode 100644
index 000000000000..9e340c330e56
--- /dev/null
+++ b/textproc/p5-Search-VectorSpace/distinfo
@@ -0,0 +1,2 @@
+MD5 (Search-VectorSpace-0.02.tar.gz) = adce4a8bded096c925226c5788888900
+SIZE (Search-VectorSpace-0.02.tar.gz) = 4251
diff --git a/textproc/p5-Search-VectorSpace/pkg-descr b/textproc/p5-Search-VectorSpace/pkg-descr
new file mode 100644
index 000000000000..0d30dae3d834
--- /dev/null
+++ b/textproc/p5-Search-VectorSpace/pkg-descr
@@ -0,0 +1,12 @@
+This module takes a list of documents (in English) and
+builds a simple in-memory search engine using a vector
+space model. Documents are stored as PDL objects, and
+after the initial indexing phase, the search should be
+very fast. This implementation applies a rudimentary
+stop list to filter out very common words, and uses a
+cosine measure to calculate document similarity.
+All documents above a user-configurable similarity
+threshold are returned.
+
+Author: Maciej Ceglowski <maciej AT ceglowski.com>
+WWW: http://search.cpan.org/dist/Search-VectorSpace/
diff --git a/textproc/p5-Search-VectorSpace/pkg-plist b/textproc/p5-Search-VectorSpace/pkg-plist
new file mode 100644
index 000000000000..a3d733f7344a
--- /dev/null
+++ b/textproc/p5-Search-VectorSpace/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/Search/VectorSpace.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/VectorSpace/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/VectorSpace
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Search 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Search 2>/dev/null || true