aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/linux-c6-alsa-lib/Makefile8
-rw-r--r--audio/linux-c6-alsa-plugins-oss/Makefile8
-rw-r--r--audio/linux-c6-alsa-plugins-oss/files/patch-pcm-oss.conf21
-rw-r--r--audio/linux-c6-alsa-plugins-oss/pkg-deinstall16
-rw-r--r--audio/linux-c6-alsa-plugins-oss/pkg-install18
-rw-r--r--audio/linux-c6-alsa-plugins-oss/pkg-plist2
-rw-r--r--audio/linux-c6-alsa-plugins-pulseaudio/Makefile4
-rw-r--r--audio/linux-c6-alsa-plugins-pulseaudio/pkg-plist1
-rw-r--r--audio/linux-f10-alsa-lib/Makefile9
-rw-r--r--audio/linux-f10-alsa-plugins-oss/Makefile11
-rw-r--r--audio/linux-f10-alsa-plugins-oss/files/patch-pcm-oss.conf14
-rw-r--r--audio/linux-f10-alsa-plugins-oss/pkg-deinstall16
-rw-r--r--audio/linux-f10-alsa-plugins-oss/pkg-install18
-rw-r--r--audio/linux-f10-alsa-plugins-oss/pkg-plist2
14 files changed, 26 insertions, 122 deletions
diff --git a/audio/linux-c6-alsa-lib/Makefile b/audio/linux-c6-alsa-lib/Makefile
index 2f36cf0ae67f..a67980270b80 100644
--- a/audio/linux-c6-alsa-lib/Makefile
+++ b/audio/linux-c6-alsa-lib/Makefile
@@ -12,6 +12,8 @@ COMMENT= Advanced Linux Sound Architecture libraries (Linux CentOS ${LINUX_DIST_
LICENSE= GPLv3
+RUN_DEPENDS= ${LOCALBASE}/etc/asound.conf:${PORTSDIR}/audio/alsa-lib
+
CONFLICTS= linux-alsa-lib-[0-9]* linux-f8-alsa-lib-[0-9]* linux-f10-alsa-lib-[0-9]*
BRANDELF_FILES= usr/bin/aserver
@@ -22,7 +24,13 @@ USE_LINUX_RPM= yes
RPMVERSION= 3.el6
USE_LDCONFIG= yes
+# We will use native configuration file, so delete a linux one
+post-extract:
+ @${RM} -r ${WRKSRC}/etc
+
post-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/etc
+ ${LN} -fs ${LOCALBASE}/etc/asound.conf ${STAGEDIR}${PREFIX}/etc
${RM} ${STAGEDIR}${PREFIX}/usr/lib/alsa-lib/smixer/smixer-ac97.la
${RM} ${STAGEDIR}${PREFIX}/usr/lib/alsa-lib/smixer/smixer-hda.la
${RM} ${STAGEDIR}${PREFIX}/usr/lib/alsa-lib/smixer/smixer-sbase.la
diff --git a/audio/linux-c6-alsa-plugins-oss/Makefile b/audio/linux-c6-alsa-plugins-oss/Makefile
index 410ed1a8e6ff..7f4830af864f 100644
--- a/audio/linux-c6-alsa-plugins-oss/Makefile
+++ b/audio/linux-c6-alsa-plugins-oss/Makefile
@@ -26,10 +26,8 @@ RPMVERSION= 3.el6
USE_LDCONFIG= yes
-CONF_FILE= etc/alsa/pcm/pcm-oss.conf
-
-post-patch:
- @${RM} ${WRKSRC}/${CONF_FILE}.orig
- @${MV} ${WRKSRC}/${CONF_FILE} ${WRKSRC}/${CONF_FILE}.sample
+# We will use native configuration file, so delete a linux one
+post-extract:
+ @${RM} -r ${WRKSRC}/etc
.include <bsd.port.mk>
diff --git a/audio/linux-c6-alsa-plugins-oss/files/patch-pcm-oss.conf b/audio/linux-c6-alsa-plugins-oss/files/patch-pcm-oss.conf
deleted file mode 100644
index bfb6e4e44ec8..000000000000
--- a/audio/linux-c6-alsa-plugins-oss/files/patch-pcm-oss.conf
+++ /dev/null
@@ -1,21 +0,0 @@
---- ./etc/alsa/pcm/pcm-oss.conf.orig 2010-11-11 02:07:08.000000000 +0200
-+++ ./etc/alsa/pcm/pcm-oss.conf 2014-03-16 17:33:37.794567295 +0200
-@@ -1,9 +1,17 @@
- # pcm-oss plugin configuration
-
--pcm.oss {
-+pcm.!default {
- type oss
- device /dev/dsp
- hint {
- description "Open Sound System"
- }
- }
-+
-+ctl.!default {
-+ type oss
-+ device /dev/mixer
-+ hint {
-+ description "Open Sound System"
-+ }
-+}
diff --git a/audio/linux-c6-alsa-plugins-oss/pkg-deinstall b/audio/linux-c6-alsa-plugins-oss/pkg-deinstall
deleted file mode 100644
index 22b3172b23f6..000000000000
--- a/audio/linux-c6-alsa-plugins-oss/pkg-deinstall
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/bin/sh
-
-case "$2" in
- POST-DEINSTALL)
- conf=${PKG_PREFIX}/etc/asound.conf
- if [ ! -f "$conf" ]; then
- exit 1
- fi
- grep -v '/etc/alsa/pcm/pcm-oss\.conf' <$conf >/tmp/asound.conf.new
- ;;
- *)
- exit 0
- ;;
-esac
-
-exit 0
diff --git a/audio/linux-c6-alsa-plugins-oss/pkg-install b/audio/linux-c6-alsa-plugins-oss/pkg-install
deleted file mode 100644
index b77ca3d001c3..000000000000
--- a/audio/linux-c6-alsa-plugins-oss/pkg-install
+++ /dev/null
@@ -1,18 +0,0 @@
-#!/bin/sh
-
-case "$2" in
- POST-INSTALL)
- conf=${PKG_PREFIX}/etc/asound.conf
- if [ ! -f "$conf" ]; then
- exit 1
- fi
- awk '{print $0}; /files/ { print "\t\t\t\"/etc/alsa/pcm/pcm-oss.conf\""}' <$conf >/tmp/asound.conf.new
- mv /tmp/asound.conf.new $conf
- exit 0
- ;;
- *)
- exit 0
- ;;
-esac
-
-exit 0
diff --git a/audio/linux-c6-alsa-plugins-oss/pkg-plist b/audio/linux-c6-alsa-plugins-oss/pkg-plist
index 9591870fca5b..0cc8ce6ecf39 100644
--- a/audio/linux-c6-alsa-plugins-oss/pkg-plist
+++ b/audio/linux-c6-alsa-plugins-oss/pkg-plist
@@ -1,7 +1,5 @@
-@sample etc/alsa/pcm/pcm-oss.conf.sample
usr/lib/alsa-lib/libasound_module_ctl_oss.so
usr/lib/alsa-lib/libasound_module_pcm_oss.so
usr/share/doc/alsa-plugins-oss-1.0.21/COPYING
usr/share/doc/alsa-plugins-oss-1.0.21/COPYING.GPL
usr/share/doc/alsa-plugins-oss-1.0.21/README-pcm-oss
-@unexec if [ -f %D/etc/asound.conf ]; then fgrep -v '/etc/alsa/pcm/pcm-oss.conf' <%D/etc/asound.conf >/tmp/asound.conf.new; mv /tmp/asound.conf.new %D/etc/asound.conf; fi
diff --git a/audio/linux-c6-alsa-plugins-pulseaudio/Makefile b/audio/linux-c6-alsa-plugins-pulseaudio/Makefile
index 43ab8e8942e3..895084024693 100644
--- a/audio/linux-c6-alsa-plugins-pulseaudio/Makefile
+++ b/audio/linux-c6-alsa-plugins-pulseaudio/Makefile
@@ -26,4 +26,8 @@ RPMVERSION= 3.el6
USE_LDCONFIG= yes
+# We will use native configuration file, so delete a linux one
+post-extract:
+ @${RM} -r ${WRKSRC}/etc
+
.include <bsd.port.mk>
diff --git a/audio/linux-c6-alsa-plugins-pulseaudio/pkg-plist b/audio/linux-c6-alsa-plugins-pulseaudio/pkg-plist
index a3cd0daa52dd..f41dda259cfd 100644
--- a/audio/linux-c6-alsa-plugins-pulseaudio/pkg-plist
+++ b/audio/linux-c6-alsa-plugins-pulseaudio/pkg-plist
@@ -1,4 +1,3 @@
-etc/alsa/pulse-default.conf
usr/lib/alsa-lib/libasound_module_conf_pulse.so
usr/lib/alsa-lib/libasound_module_ctl_pulse.so
usr/lib/alsa-lib/libasound_module_pcm_pulse.so
diff --git a/audio/linux-f10-alsa-lib/Makefile b/audio/linux-f10-alsa-lib/Makefile
index 856d7a0e3d39..c0bcdea33573 100644
--- a/audio/linux-f10-alsa-lib/Makefile
+++ b/audio/linux-f10-alsa-lib/Makefile
@@ -10,6 +10,8 @@ MASTER_SITES= CRITICAL/rpm/${LINUX_RPM_ARCH}/fedora/${LINUX_DIST_VER}
MAINTAINER= emulation@FreeBSD.org
COMMENT= Advanced Linux Sound Architecture libraries (Linux Fedora 10)
+RUN_DEPENDS= ${LOCALBASE}/etc/asound.conf:${PORTSDIR}/audio/alsa-lib
+
CONFLICTS= linux-alsa-lib-[0-9]* linux-f8-alsa-lib-[0-9]*
ONLY_FOR_ARCHS= i386 amd64
@@ -20,10 +22,15 @@ RPMVERSION= 2.fc10
BRANDELF_FILES= usr/bin/aserver
USE_LDCONFIG= yes
+# We will use native configuration file, so delete a linux one
+post-extract:
+ @${RM} -r ${WRKSRC}/etc
+
post-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/etc
+ ${LN} -fs ${LOCALBASE}/etc/asound.conf ${STAGEDIR}${PREFIX}/etc
${RM} ${STAGEDIR}${PREFIX}/usr/lib/alsa-lib/smixer/smixer-ac97.la
${RM} ${STAGEDIR}${PREFIX}/usr/lib/alsa-lib/smixer/smixer-hda.la
${RM} ${STAGEDIR}${PREFIX}/usr/lib/alsa-lib/smixer/smixer-sbase.la
-
.include <bsd.port.mk>
diff --git a/audio/linux-f10-alsa-plugins-oss/Makefile b/audio/linux-f10-alsa-plugins-oss/Makefile
index 2b01183807b0..3d337df612f5 100644
--- a/audio/linux-f10-alsa-plugins-oss/Makefile
+++ b/audio/linux-f10-alsa-plugins-oss/Makefile
@@ -18,13 +18,8 @@ RPMVERSION= 3.fc10
SRC_DISTFILES= ${PORTNAME:S/-oss//}-${PORTVERSION}-${RPMVERSION}${SRC_SUFX}
USE_LDCONFIG= yes
-CONF_FILE= etc/alsa/pcm/pcm-oss.conf
-
-post-patch:
- @${RM} ${WRKSRC}/${CONF_FILE}.orig
- @${MV} ${WRKSRC}/${CONF_FILE} ${WRKSRC}/${CONF_FILE}-dist
-
-post-install:
- ${MV} ${STAGEDIR}${PREFIX}/${CONF_FILE}-dist ${STAGEDIR}${PREFIX}/${CONF_FILE}.sample
+# We will use native configuration file, so delete a linux one
+post-extract:
+ @${RM} -r ${WRKSRC}/etc
.include <bsd.port.mk>
diff --git a/audio/linux-f10-alsa-plugins-oss/files/patch-pcm-oss.conf b/audio/linux-f10-alsa-plugins-oss/files/patch-pcm-oss.conf
deleted file mode 100644
index ca58f1b46e34..000000000000
--- a/audio/linux-f10-alsa-plugins-oss/files/patch-pcm-oss.conf
+++ /dev/null
@@ -1,14 +0,0 @@
---- etc/alsa/pcm/pcm-oss.conf.orig 2010-03-23 10:56:41.000000000 +0900
-+++ etc/alsa/pcm/pcm-oss.conf 2010-03-23 10:57:30.000000000 +0900
-@@ -7,3 +7,11 @@
- description "Open Sound System"
- }
- }
-+
-+ctl.oss {
-+ type oss
-+ device /dev/mixer
-+ hint {
-+ description "Open Sound System"
-+ }
-+}
diff --git a/audio/linux-f10-alsa-plugins-oss/pkg-deinstall b/audio/linux-f10-alsa-plugins-oss/pkg-deinstall
deleted file mode 100644
index 22b3172b23f6..000000000000
--- a/audio/linux-f10-alsa-plugins-oss/pkg-deinstall
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/bin/sh
-
-case "$2" in
- POST-DEINSTALL)
- conf=${PKG_PREFIX}/etc/asound.conf
- if [ ! -f "$conf" ]; then
- exit 1
- fi
- grep -v '/etc/alsa/pcm/pcm-oss\.conf' <$conf >/tmp/asound.conf.new
- ;;
- *)
- exit 0
- ;;
-esac
-
-exit 0
diff --git a/audio/linux-f10-alsa-plugins-oss/pkg-install b/audio/linux-f10-alsa-plugins-oss/pkg-install
deleted file mode 100644
index b77ca3d001c3..000000000000
--- a/audio/linux-f10-alsa-plugins-oss/pkg-install
+++ /dev/null
@@ -1,18 +0,0 @@
-#!/bin/sh
-
-case "$2" in
- POST-INSTALL)
- conf=${PKG_PREFIX}/etc/asound.conf
- if [ ! -f "$conf" ]; then
- exit 1
- fi
- awk '{print $0}; /files/ { print "\t\t\t\"/etc/alsa/pcm/pcm-oss.conf\""}' <$conf >/tmp/asound.conf.new
- mv /tmp/asound.conf.new $conf
- exit 0
- ;;
- *)
- exit 0
- ;;
-esac
-
-exit 0
diff --git a/audio/linux-f10-alsa-plugins-oss/pkg-plist b/audio/linux-f10-alsa-plugins-oss/pkg-plist
index 9591870fca5b..0cc8ce6ecf39 100644
--- a/audio/linux-f10-alsa-plugins-oss/pkg-plist
+++ b/audio/linux-f10-alsa-plugins-oss/pkg-plist
@@ -1,7 +1,5 @@
-@sample etc/alsa/pcm/pcm-oss.conf.sample
usr/lib/alsa-lib/libasound_module_ctl_oss.so
usr/lib/alsa-lib/libasound_module_pcm_oss.so
usr/share/doc/alsa-plugins-oss-1.0.21/COPYING
usr/share/doc/alsa-plugins-oss-1.0.21/COPYING.GPL
usr/share/doc/alsa-plugins-oss-1.0.21/README-pcm-oss
-@unexec if [ -f %D/etc/asound.conf ]; then fgrep -v '/etc/alsa/pcm/pcm-oss.conf' <%D/etc/asound.conf >/tmp/asound.conf.new; mv /tmp/asound.conf.new %D/etc/asound.conf; fi