aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dns/unbound/Makefile19
-rw-r--r--dns/unbound/distinfo6
-rw-r--r--dns/unbound/pkg-plist2
3 files changed, 16 insertions, 11 deletions
diff --git a/dns/unbound/Makefile b/dns/unbound/Makefile
index 06b1ea56ebd6..356a9d4780c2 100644
--- a/dns/unbound/Makefile
+++ b/dns/unbound/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= unbound
-PORTVERSION= 1.11.0
+PORTVERSION= 1.13.0
CATEGORIES= dns
MASTER_SITES= https://www.nlnetlabs.nl/downloads/unbound/ \
https://distfiles.crux.guru/
@@ -28,15 +28,17 @@ GROUPS= ${PORTNAME}
USE_RC_SUBR= unbound
-PORTDOCS= CREDITS Changelog FEATURES LICENSE README README.svn \
- README.tests TODO control_proto_spec.txt ietf67-design-02.odp \
+PORTDOCS= CNAME-basedRedirectionDesignNotes.pdf CREDITS Changelog \
+ FEATURES IP-BasedActions.pdf LICENSE README README.DNS64 \
+ README.ipset.md README.svn README.tests TODO \
+ control_proto_spec.txt example.conf ietf67-design-02.odp \
ietf67-design-02.pdf requirements.txt
OPTIONS_SUB= yes
-OPTIONS_DEFINE= THREADS PYTHON GOST ECDSA MUNIN_PLUGIN DOCS LIBEVENT \
- FILTER_AAAA DNSTAP DNSCRYPT SUBNET EVAPI TFOCL TFOSE \
- HIREDIS
-OPTIONS_DEFAULT=THREADS ECDSA LIBEVENT GOST
+OPTIONS_DEFINE= DNSCRYPT DNSTAP DOCS DOH ECDSA EVAPI FILTER_AAAA GOST \
+ HIREDIS LIBEVENT MUNIN_PLUGIN PYTHON SUBNET TFOCL TFOSE \
+ THREADS
+OPTIONS_DEFAULT=ECDSA GOST LIBEVENT THREADS
LIBEVENT_DESC= Build against libevent
GOST_DESC= Enable GOST support (requires OpenSSL >= 1.0)
@@ -50,6 +52,7 @@ EVAPI_DESC= (Experimental) pluggable event based libunbound API support
TFOCL_DESC= Enable TCP Fast Open for client mode
TFOSE_DESC= Enable TCP Fast Open for server mode
HIREDIS_DESC= Enable hiredis support for the cachedb module
+DOH_DESC= Enable DNS-over-HTTPS supports
STRIP_FILES= .libs/libunbound.so unbound-checkconf unbound \
unbound-control .libs/unbound-host .libs/unbound-anchor
@@ -81,6 +84,8 @@ PYTHON_VARS= STRIP_FILES+=.libs/_unbound.so
THREADS_CONFIGURE_WITH= pthreads
HIREDIS_CONFIGURE_ON= --enable-cachedb --with-libhiredis
HIREDIS_LIB_DEPENDS= libhiredis.so:databases/hiredis
+DOH_CONFIGURE_ON= --with-libnghttp2
+DOH_LIB_DEPENDS= libnghttp2.so:www/libnghttp2
post-patch:
@${RM} ${WRKSRC}/util/configlexer.c
diff --git a/dns/unbound/distinfo b/dns/unbound/distinfo
index c56228cce0b4..0e551d104a32 100644
--- a/dns/unbound/distinfo
+++ b/dns/unbound/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1595844570
-SHA256 (unbound-1.11.0.tar.gz) = 9f2f0798f76eb8f30feaeda7e442ceed479bc54db0e3ac19c052d68685e51ef7
-SIZE (unbound-1.11.0.tar.gz) = 5900967
+TIMESTAMP = 1607786765
+SHA256 (unbound-1.13.0.tar.gz) = a954043a95b0326ca4037e50dace1f3a207a0a19e9a4a22f4c6718fc623db2a1
+SIZE (unbound-1.13.0.tar.gz) = 5950063
diff --git a/dns/unbound/pkg-plist b/dns/unbound/pkg-plist
index 2fc74fce677e..70585f43dc08 100644
--- a/dns/unbound/pkg-plist
+++ b/dns/unbound/pkg-plist
@@ -5,7 +5,7 @@ libdata/pkgconfig/libunbound.pc
lib/libunbound.a
lib/libunbound.so
lib/libunbound.so.8
-lib/libunbound.so.8.1.9
+lib/libunbound.so.8.1.11
%%PYTHON%%%%PYTHON_SITELIBDIR%%/_unbound.so
%%PYTHON%%%%PYTHON_SITELIBDIR%%/unbound.py
%%PYTHON%%%%PYTHON_SITELIBDIR%%/unboundmodule.py