aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/bitcoin/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/net-p2p/bitcoin/Makefile b/net-p2p/bitcoin/Makefile
index cad4367d9c8d..65085e4842da 100644
--- a/net-p2p/bitcoin/Makefile
+++ b/net-p2p/bitcoin/Makefile
@@ -26,7 +26,7 @@ GH_PROJECT= bitcoin
GH_COMMIT= 15e2837
GH_TAGNAME= v${PORTVERSION}
-USE_GMAKE= yes
+USES= gmake
USE_OPENSSL= yes
USE_BDB= yes
WANT_BDB_VER= 48
@@ -77,7 +77,7 @@ post-patch:
do-configure:
.if ${PORT_OPTIONS:MGUI} && !defined(WITHOUT_X11)
- cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
+ cd ${WRKSRC} && ${SETENV} ${QMAKE_ENV} \
${QMAKE} ${QMAKE_ARGS} USE_UPNP=${QMAKE_USE_UPNP} USE_QRCODE=${QMAKE_USE_QRCODE} \
QMAKE_LRELEASE=${LRELEASE} INCLUDEPATH=${BDB_INCLUDE_DIR} \
QMAKE_LIBDIR+=${BDB_LIB_DIR} bitcoin-qt.pro