aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/xpi-adblock/Makefile2
-rw-r--r--www/xpi-adblock/Makefile.xpi7
2 files changed, 5 insertions, 4 deletions
diff --git a/www/xpi-adblock/Makefile b/www/xpi-adblock/Makefile
index 878157f77e74..6d04028af292 100644
--- a/www/xpi-adblock/Makefile
+++ b/www/xpi-adblock/Makefile
@@ -18,5 +18,5 @@ XPI_FILES= chrome/adblock.jar chrome.manifest components/.autoreg components/nsA
defaults/preferences/adblock.js install.js install.rdf license.txt
XPI_DIRS= chrome/adblock chrome components defaults/preferences defaults
-.include "../xpi-adblock/Makefile.xpi"
+.include "${.CURDIR}/../xpi-adblock/Makefile.xpi"
.include <bsd.port.mk>
diff --git a/www/xpi-adblock/Makefile.xpi b/www/xpi-adblock/Makefile.xpi
index 514f8e427173..234ce3dc00f3 100644
--- a/www/xpi-adblock/Makefile.xpi
+++ b/www/xpi-adblock/Makefile.xpi
@@ -44,7 +44,7 @@
# as a USE_XPI list. If several tuples match, the last non-regexp
# one takes precedence, then the last regexp one.
#
-# This Makefile is an alpha-version of the new xpi infrastructure. It currently
+# This Makefile is a beta-version of the new xpi infrastructure. It currently
# supports Gecko 1.8+ (Firefox 1.5+). Support for Gecko 1.7x (and Seamonkey 1.0)
# may be merged later from Thierry Thomas works.
#
@@ -123,11 +123,12 @@ WITH_XPI_APPS?= ${WITH_XPI_NTUPLES}
USE_XPI= ${WITH_XPI_APPS}
.endif
-.if !defined(USE_XPI) || (defined(USE_XPI) && ( ${USE_XPI:U} == "YES" || ${USE_XPI} == "*" ))
+.if !defined(USE_XPI) || ${USE_XPI:U} == "YES" || ${USE_XPI} == "*"
USE_XPI= ${XPI_APPS_ALL_WC}
.endif
-XPI_APPS?= ${USE_XPI:S.^.${X11BASE}/lib/.:S.$./extensions.}
+XPI_APPS?= ${USE_XPI:S.^.${LOCALBASE}/lib/.:S.$./extensions.} \
+ ${USE_XPI:S.^.${X11BASE}/lib/.:S.$./extensions.}
XPI_SLDIRS_ALL= ${XPI_APPS_ALL:S.^.${XPI_SLDIR}/.}
XPI_SLDIRS= ${USE_XPI:S.^.${XPI_SLDIR}/.}
XPI_LINKFARMS= ${XPI_APPS} ${XPI_SLDIRS}