aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-String-Escape/Makefile21
-rw-r--r--textproc/p5-String-Escape/distinfo3
-rw-r--r--textproc/p5-String-Escape/pkg-descr3
-rw-r--r--textproc/p5-String-Escape/pkg-plist5
5 files changed, 33 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 3d849963d2b7..6ba824221c81 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -567,6 +567,7 @@
SUBDIR += p5-String-BufferStack
SUBDIR += p5-String-CamelCase
SUBDIR += p5-String-Divert
+ SUBDIR += p5-String-Escape
SUBDIR += p5-String-Format
SUBDIR += p5-String-Fraction
SUBDIR += p5-String-Koremutake
diff --git a/textproc/p5-String-Escape/Makefile b/textproc/p5-String-Escape/Makefile
new file mode 100644
index 000000000000..1dda40ec4a0b
--- /dev/null
+++ b/textproc/p5-String-Escape/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-String-Escape
+# Date Created: 15 May 2009
+# Whom: Denis Pokataev <catone@cpan.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= String-Escape
+PORTVERSION= 2002.001
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= catone@cpan.org
+COMMENT= Registry of string functions, including backslash escapes
+
+PERL_CONFIGURE= yes
+
+MAN3= String::Escape.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-String-Escape/distinfo b/textproc/p5-String-Escape/distinfo
new file mode 100644
index 000000000000..f0c6e21007dd
--- /dev/null
+++ b/textproc/p5-String-Escape/distinfo
@@ -0,0 +1,3 @@
+MD5 (String-Escape-2002.001.tar.gz) = 764ff01a8f96632af1742e9637defaf6
+SHA256 (String-Escape-2002.001.tar.gz) = 845e13c6c5315abf0652729cd649ac5b3b6a995551bc0945cf8e824e41032c66
+SIZE (String-Escape-2002.001.tar.gz) = 7183
diff --git a/textproc/p5-String-Escape/pkg-descr b/textproc/p5-String-Escape/pkg-descr
new file mode 100644
index 000000000000..b8aed227dffa
--- /dev/null
+++ b/textproc/p5-String-Escape/pkg-descr
@@ -0,0 +1,3 @@
+String::Escape - Registry of string functions, including backslash escapes
+
+WWW: http://search.cpan.org/dist/String-Escape/
diff --git a/textproc/p5-String-Escape/pkg-plist b/textproc/p5-String-Escape/pkg-plist
new file mode 100644
index 000000000000..964f4418c4e7
--- /dev/null
+++ b/textproc/p5-String-Escape/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/String/Escape/.packlist
+%%SITE_PERL%%/String/Escape.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/String/Escape
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/String
+@dirrmtry %%SITE_PERL%%/String