aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--hungarian/hunspell/Makefile1
-rw-r--r--hungarian/hunspell/files/patch-src_parsers_latexparser.cxx11
-rw-r--r--textproc/hunspell/Makefile1
-rw-r--r--textproc/hunspell/files/patch-src_parsers_latexparser.cxx11
4 files changed, 24 insertions, 0 deletions
diff --git a/hungarian/hunspell/Makefile b/hungarian/hunspell/Makefile
index bf86e0b28563..1aebb4b18ae0 100644
--- a/hungarian/hunspell/Makefile
+++ b/hungarian/hunspell/Makefile
@@ -7,6 +7,7 @@
PORTNAME= hunspell
PORTVERSION= 1.2.2b
+PORTREVISION= 1
CATEGORIES= hungarian textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:S@$@:code@:S@%SUBDIR%@${PORTNAME}@} \
${MASTER_SITE_SOURCEFORGE:S@$@:data@:S@%SUBDIR%@magyarispell@}
diff --git a/hungarian/hunspell/files/patch-src_parsers_latexparser.cxx b/hungarian/hunspell/files/patch-src_parsers_latexparser.cxx
new file mode 100644
index 000000000000..89c6b60bed1b
--- /dev/null
+++ b/hungarian/hunspell/files/patch-src_parsers_latexparser.cxx
@@ -0,0 +1,11 @@
+--- src/parsers/latexparser.cxx.orig 2008-04-23 17:56:27.000000000 +0200
++++ src/parsers/latexparser.cxx 2008-04-23 17:57:00.000000000 +0200
+@@ -82,7 +82,7 @@
+ { { "\\url", NULL } , 1 }
+ };
+
+-#define PATTERN_LEN (sizeof(PATTERN) / ((sizeof(char *) * 2) + sizeof(int)))
++#define PATTERN_LEN (sizeof(PATTERN) / sizeof(PATTERN[0]))
+
+ LaTeXParser::LaTeXParser(const char * wordchars)
+ {
diff --git a/textproc/hunspell/Makefile b/textproc/hunspell/Makefile
index bf86e0b28563..1aebb4b18ae0 100644
--- a/textproc/hunspell/Makefile
+++ b/textproc/hunspell/Makefile
@@ -7,6 +7,7 @@
PORTNAME= hunspell
PORTVERSION= 1.2.2b
+PORTREVISION= 1
CATEGORIES= hungarian textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:S@$@:code@:S@%SUBDIR%@${PORTNAME}@} \
${MASTER_SITE_SOURCEFORGE:S@$@:data@:S@%SUBDIR%@magyarispell@}
diff --git a/textproc/hunspell/files/patch-src_parsers_latexparser.cxx b/textproc/hunspell/files/patch-src_parsers_latexparser.cxx
new file mode 100644
index 000000000000..89c6b60bed1b
--- /dev/null
+++ b/textproc/hunspell/files/patch-src_parsers_latexparser.cxx
@@ -0,0 +1,11 @@
+--- src/parsers/latexparser.cxx.orig 2008-04-23 17:56:27.000000000 +0200
++++ src/parsers/latexparser.cxx 2008-04-23 17:57:00.000000000 +0200
+@@ -82,7 +82,7 @@
+ { { "\\url", NULL } , 1 }
+ };
+
+-#define PATTERN_LEN (sizeof(PATTERN) / ((sizeof(char *) * 2) + sizeof(int)))
++#define PATTERN_LEN (sizeof(PATTERN) / sizeof(PATTERN[0]))
+
+ LaTeXParser::LaTeXParser(const char * wordchars)
+ {