aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-Relations-Query/Makefile25
-rw-r--r--databases/p5-Relations-Query/distinfo3
-rw-r--r--databases/p5-Relations-Query/pkg-descr9
-rw-r--r--databases/p5-Relations-Query/pkg-plist5
5 files changed, 43 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 4952d19fbdf4..608a5357c836 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -268,6 +268,7 @@
SUBDIR += p5-POE-Component-LaDBI
SUBDIR += p5-Pg
SUBDIR += p5-Relations
+ SUBDIR += p5-Relations-Query
SUBDIR += p5-ResourcePool-Resource-DBI
SUBDIR += p5-Rose-DB
SUBDIR += p5-Rose-DB-Object
diff --git a/databases/p5-Relations-Query/Makefile b/databases/p5-Relations-Query/Makefile
new file mode 100644
index 000000000000..0a114f1ee525
--- /dev/null
+++ b/databases/p5-Relations-Query/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: databases/p5-Relations-Query
+# Date created: 1 Aug 2006
+# Whom: Timur I. Bakeyev <bat@cpan.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Relations-Query
+PORTVERSION= 0.93
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Relations
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= bat@cpan.org
+COMMENT= Object for building queries with DBI/DBD::mysql
+
+BUILD_DEPENDS= ${SITE_PERL}/Relations.pm:${PORTSDIR}/databases/p5-Relations
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Relations::Query.3
+
+.include <bsd.port.mk>
diff --git a/databases/p5-Relations-Query/distinfo b/databases/p5-Relations-Query/distinfo
new file mode 100644
index 000000000000..126111884da6
--- /dev/null
+++ b/databases/p5-Relations-Query/distinfo
@@ -0,0 +1,3 @@
+MD5 (Relations-Query-0.93.tar.gz) = c9188d6cd7e0fdd2236e95fb30207062
+SHA256 (Relations-Query-0.93.tar.gz) = d7c218846def4cea37c0e33918cc11b9bf0e60866df3acd473e28c531e7c87f3
+SIZE (Relations-Query-0.93.tar.gz) = 10518
diff --git a/databases/p5-Relations-Query/pkg-descr b/databases/p5-Relations-Query/pkg-descr
new file mode 100644
index 000000000000..14b63c46b6ac
--- /dev/null
+++ b/databases/p5-Relations-Query/pkg-descr
@@ -0,0 +1,9 @@
+With Relations::Query you can create a 'select' query by creating a new
+query object, and passing hashes, arrays, or strings of info to the
+constructor, such as what's within the variables clause, what to order
+by, etc. You can also add and override clause info in the query as
+well, on both a permanent and temporary basis. With the to_string()
+function, you can create a query string from a hash, query object or
+string.
+
+WWW: http://www.gaf3.com/
diff --git a/databases/p5-Relations-Query/pkg-plist b/databases/p5-Relations-Query/pkg-plist
new file mode 100644
index 000000000000..ba87b14957b3
--- /dev/null
+++ b/databases/p5-Relations-Query/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Relations/Query.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Relations/Query/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Relations/Query
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Relations
+@dirrmtry %%SITE_PERL%%/Relations