aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/cfengine3-legacy/Makefile4
-rw-r--r--sysutils/cfengine3/Makefile4
2 files changed, 8 insertions, 0 deletions
diff --git a/sysutils/cfengine3-legacy/Makefile b/sysutils/cfengine3-legacy/Makefile
index 7af0239439a8..f14e892a59fc 100644
--- a/sysutils/cfengine3-legacy/Makefile
+++ b/sysutils/cfengine3-legacy/Makefile
@@ -42,6 +42,10 @@ OPTIONS= PCRE "Enable Perl-compatible regular expressions" on \
BROKEN= TOKYOCABINET and QDBM are mutuallly exclusive
.endif
+.if !defined(WITH_TOKYOCABINET) && !defined(WITH_QDBM)
+BROKEN= TOKYOCABINET or QDBM must be defined
+.endif
+
.if defined(WITH_PCRE)
LIB_DEPENDS+= pcre.1:${PORTSDIR}/devel/pcre
CONFIGURE_ARGS+= --with-pcre=${LOCALBASE}
diff --git a/sysutils/cfengine3/Makefile b/sysutils/cfengine3/Makefile
index 7af0239439a8..f14e892a59fc 100644
--- a/sysutils/cfengine3/Makefile
+++ b/sysutils/cfengine3/Makefile
@@ -42,6 +42,10 @@ OPTIONS= PCRE "Enable Perl-compatible regular expressions" on \
BROKEN= TOKYOCABINET and QDBM are mutuallly exclusive
.endif
+.if !defined(WITH_TOKYOCABINET) && !defined(WITH_QDBM)
+BROKEN= TOKYOCABINET or QDBM must be defined
+.endif
+
.if defined(WITH_PCRE)
LIB_DEPENDS+= pcre.1:${PORTSDIR}/devel/pcre
CONFIGURE_ARGS+= --with-pcre=${LOCALBASE}