aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/Makefile1
-rw-r--r--math/octave-forge-gsl/Makefile22
-rw-r--r--math/octave-forge-gsl/distinfo3
-rw-r--r--math/octave-forge-gsl/pkg-descr10
-rw-r--r--math/octave-forge-gsl/pkg-plist1
5 files changed, 37 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 6c15e1f54f6b..77f7c40ad43b 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -187,6 +187,7 @@
SUBDIR += octave-forge-base
SUBDIR += octave-forge-engine
SUBDIR += octave-forge-fpl
+ SUBDIR += octave-forge-gsl
SUBDIR += oleo
SUBDIR += orpie
SUBDIR += p5-AI-DecisionTree
diff --git a/math/octave-forge-gsl/Makefile b/math/octave-forge-gsl/Makefile
new file mode 100644
index 000000000000..478592c9e2b9
--- /dev/null
+++ b/math/octave-forge-gsl/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: octave-forge
+# Date created: 5 May 2004
+# Whom: Stephen Montgomery-Smith <stephen@math.missouri.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= octave-forge-gsl
+PORTVERSION= 1.0.7
+CATEGORIES= math
+
+MAINTAINER= stephen@math.missouri.edu
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+
+LIB_DEPENDS= gsl.12:${PORTSDIR}/math/gsl
+
+post-patch:
+ @${REINPLACE_CMD} s+/bin/bash+/usr/local/bin/bash+g ${WRKSRC}/src/config*
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.octave.mk"
+.include <bsd.port.post.mk>
diff --git a/math/octave-forge-gsl/distinfo b/math/octave-forge-gsl/distinfo
new file mode 100644
index 000000000000..6b7de9aeef8c
--- /dev/null
+++ b/math/octave-forge-gsl/distinfo
@@ -0,0 +1,3 @@
+MD5 (octave-forge/gsl-1.0.7.tar.gz) = 77a3058592f938f6384146d3630cc845
+SHA256 (octave-forge/gsl-1.0.7.tar.gz) = ff1539def908dbcb63d714b2f1ef3076dc5276719c2af5dac0274b45a6e2c81b
+SIZE (octave-forge/gsl-1.0.7.tar.gz) = 1200207
diff --git a/math/octave-forge-gsl/pkg-descr b/math/octave-forge-gsl/pkg-descr
new file mode 100644
index 000000000000..9ca54b47b0ae
--- /dev/null
+++ b/math/octave-forge-gsl/pkg-descr
@@ -0,0 +1,10 @@
+The octave-forge package is the result of The GNU Octave Repositry project,
+which is intended to be a central location for custom scripts, functions and
+extensions for GNU Octave. contains the source for all the functions plus
+build and install scripts.
+
+This is gsl.
+
+ Octave bindings to the GNU Scientific Library
+
+WWW: http://octave.sourceforge.net/
diff --git a/math/octave-forge-gsl/pkg-plist b/math/octave-forge-gsl/pkg-plist
new file mode 100644
index 000000000000..a999ec86c07e
--- /dev/null
+++ b/math/octave-forge-gsl/pkg-plist
@@ -0,0 +1 @@
+@comment This file intentionally left empty