aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--multimedia/xawtv/Makefile36
-rw-r--r--multimedia/xvid/Makefile10
2 files changed, 17 insertions, 29 deletions
diff --git a/multimedia/xawtv/Makefile b/multimedia/xawtv/Makefile
index 8a791af32bd3..72008624788e 100644
--- a/multimedia/xawtv/Makefile
+++ b/multimedia/xawtv/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xawtv
-# Date created: 03 March 2001
-# Whom: George Reid <greid@ukug.uk.freebsd.org>
-#
+# Created by: George Reid <greid@ukug.uk.freebsd.org>
# $FreeBSD$
-#
PORTNAME= xawtv
PORTVERSION= 3.95
@@ -21,11 +17,11 @@ RUN_DEPENDS= iconv:${PORTSDIR}/converters/libiconv \
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
jpeg.11:${PORTSDIR}/graphics/jpeg
-OPTIONS= AA "Enable AA support" on \
- DV "Enable reading/writing raw dv files" off \
- QUICKTIME "Enable quicktime support" off \
- ZVBI "Enable libzvbi support" off \
- MMX "Enable mmx support (only for i386)" off
+OPTIONS_DEFINE= AA DV QUICKTIME ZVBI
+OPTIONS_DEFINE_i386= MMX
+OPTIONS_DEFAULT= AA
+AA_DESC= Enable AA support
+ZVBI_DESC= Enable libzvbi support
USE_MOTIF= yes
GNU_CONFIGURE= yes
@@ -49,16 +45,16 @@ MAN8= v4l-conf.8
.include <bsd.port.pre.mk>
-.if defined(WITHOUT_AA)
-CONFIGURE_ARGS+=--disable-aa
-PLIST_SUB+= AA="@comment "
-.else
+.if ${PORT_OPTIONS:MAA}
CONFIGURE_ARGS+=--enable-aa
LIB_DEPENDS+= aa.1:${PORTSDIR}/graphics/aalib
PLIST_SUB+= AA=""
+.else
+CONFIGURE_ARGS+=--disable-aa
+PLIST_SUB+= AA="@comment "
.endif
-.if defined(WITH_ZVBI)
+.if ${PORT_OPTIONS:MZVBI}
LIB_DEPENDS+= zvbi.13:${PORTSDIR}/devel/libzvbi
CONFIGURE_ARGS+=--enable-zvbi
PLIST_SUB+= ZVBI="" ZVBI5=""
@@ -67,7 +63,7 @@ CONFIGURE_ARGS+=--enable-zvbi=no
PLIST_SUB+= ZVBI="@comment " ZVBI5="@comment "
.endif
-.if defined(WITH_DV)
+.if ${PORT_OPTIONS:MDV}
LIB_DEPENDS+= dv.4:${PORTSDIR}/multimedia/libdv
CONFIGURE_ARGS+=--enable-dv
PLIST_SUB+= DV=
@@ -76,16 +72,12 @@ CONFIGURE_ARGS+=--enable-dv=no
PLIST_SUB+= DV="@comment "
.endif
-.if defined(WITH_MMX)
-.if ${ARCH} == i386
+.if ${PORT_OPTIONS:MMMX}
CONFIGURE_ARGS+=--enable-mmx
CFLAGS+= -DMMX=1
-.else
-BROKEN= MMX support only works on i386, and you are running ${ARCH}
-.endif
.endif
-.if defined(WITH_QUICKTIME)
+.if ${PORT_OPTIONS:MQUICKTIME}
CONFIGURE_ARGS+=--enable-quicktime
LIB_DEPENDS+= quicktime.0:${PORTSDIR}/multimedia/libquicktime
PLIST_SUB+= QT=
diff --git a/multimedia/xvid/Makefile b/multimedia/xvid/Makefile
index 23f3d619c55a..b411d6cbd631 100644
--- a/multimedia/xvid/Makefile
+++ b/multimedia/xvid/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xvid
-# Date created: 04 April 2002
-# Whom: Michael Nottebrock <michaelnottebrock@gmx.net> et al
-#
+# Created by: Michael Nottebrock <michaelnottebrock@gmx.net> et al
# $FreeBSD$
-#
PORTNAME= xvid
PORTVERSION= 1.3.2
@@ -29,7 +25,7 @@ PLIST_FILES= include/xvid.h \
WRKSRC= ${WRKDIR}/xvidcore/build/generic
-OPTIONS= OPTIMIZED_CFLAGS "Use XviD's default optimizations" off
+OPTIONS_DEFINE= OPTIMIZED_CFLAGS
.include <bsd.port.pre.mk>
@@ -40,7 +36,7 @@ CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
.endif
-.if defined(WITH_OPTIMIZED_CFLAGS)
+.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
CFLAGS= # let xvid's build system decide about those
.endif