aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Carp-Clan/Makefile22
-rw-r--r--devel/p5-Carp-Clan/distinfo2
-rw-r--r--devel/p5-Carp-Clan/pkg-descr5
-rw-r--r--devel/p5-Carp-Clan/pkg-plist6
5 files changed, 36 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 034f8f5b8ea0..2bf115336e13 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -621,6 +621,7 @@
SUBDIR += p5-Cache-Simple-TimedExpiry
SUBDIR += p5-Calendar-Simple
SUBDIR += p5-Carp-Assert
+ SUBDIR += p5-Carp-Clan
SUBDIR += p5-Carp-Datum
SUBDIR += p5-Cdk
SUBDIR += p5-Class-Accessor
diff --git a/devel/p5-Carp-Clan/Makefile b/devel/p5-Carp-Clan/Makefile
new file mode 100644
index 000000000000..b47bfb6e4a8f
--- /dev/null
+++ b/devel/p5-Carp-Clan/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: devel/p5-Carp-Clan
+# Date created: 02 November 2004
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Carp-Clan
+PORTVERSION= 5.3
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Carp
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Report errors from perspective of caller of a "clan" of modules
+
+PERL_CONFIGURE= yes
+
+MAN3= Carp::Clan.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Carp-Clan/distinfo b/devel/p5-Carp-Clan/distinfo
new file mode 100644
index 000000000000..64f4846c4b19
--- /dev/null
+++ b/devel/p5-Carp-Clan/distinfo
@@ -0,0 +1,2 @@
+MD5 (Carp-Clan-5.3.tar.gz) = d0a0431921b2c786aac234dfb6fe02ca
+SIZE (Carp-Clan-5.3.tar.gz) = 16789
diff --git a/devel/p5-Carp-Clan/pkg-descr b/devel/p5-Carp-Clan/pkg-descr
new file mode 100644
index 000000000000..b3486cdbe971
--- /dev/null
+++ b/devel/p5-Carp-Clan/pkg-descr
@@ -0,0 +1,5 @@
+This module is based on Carp.pm from Perl 5.005_03. It has been
+modified to skip all package names matching the pattern given in
+the "use" statement inside the "qw()" term (or argument list).
+
+WWW: http://search.cpan.org/dist/Carp-Clan
diff --git a/devel/p5-Carp-Clan/pkg-plist b/devel/p5-Carp-Clan/pkg-plist
new file mode 100644
index 000000000000..785f54a61476
--- /dev/null
+++ b/devel/p5-Carp-Clan/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/Carp/Clan.pm
+%%SITE_PERL%%/Carp/Clan.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Carp/Clan/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Carp/Clan 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Carp 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Carp 2>/dev/null || true