aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Statistics-LineFit/Makefile22
-rw-r--r--math/p5-Statistics-LineFit/distinfo3
-rw-r--r--math/p5-Statistics-LineFit/pkg-descr9
-rw-r--r--math/p5-Statistics-LineFit/pkg-plist6
5 files changed, 41 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 40dca06ef37e..240ca765413b 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -252,6 +252,7 @@
SUBDIR += p5-Statistics-Descriptive
SUBDIR += p5-Statistics-Distributions
SUBDIR += p5-Statistics-LTU
+ SUBDIR += p5-Statistics-LineFit
SUBDIR += p5-Statistics-Lite
SUBDIR += p5-Statistics-OLS
SUBDIR += p5-Task-Math-Symbolic
diff --git a/math/p5-Statistics-LineFit/Makefile b/math/p5-Statistics-LineFit/Makefile
new file mode 100644
index 000000000000..a0f0ba589a1a
--- /dev/null
+++ b/math/p5-Statistics-LineFit/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Statistics-LineFit
+# Date created: 2006-10-23
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Statistics-LineFit
+PORTVERSION= 0.06
+CATEGORIES= math
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Statistics
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Least squares line fit, weighted or unweighted
+
+PERL_CONFIGURE= yes
+
+MAN3= Statistics::LineFit.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Statistics-LineFit/distinfo b/math/p5-Statistics-LineFit/distinfo
new file mode 100644
index 000000000000..739b2f53a1f5
--- /dev/null
+++ b/math/p5-Statistics-LineFit/distinfo
@@ -0,0 +1,3 @@
+MD5 (Statistics-LineFit-0.06.tar.gz) = 9c59317652dbfbc97ba53fbd113c2402
+SHA256 (Statistics-LineFit-0.06.tar.gz) = 190bbf735f5b3924a525fe3aaf83315300e29ca722d01425a315291967f3cc12
+SIZE (Statistics-LineFit-0.06.tar.gz) = 23679
diff --git a/math/p5-Statistics-LineFit/pkg-descr b/math/p5-Statistics-LineFit/pkg-descr
new file mode 100644
index 000000000000..c813781b3677
--- /dev/null
+++ b/math/p5-Statistics-LineFit/pkg-descr
@@ -0,0 +1,9 @@
+The Statistics::LineFit module does weighted or unweighted least-squares
+line fitting to two-dimensional data (y = a + b * x). (This is also
+called linear regression.) In addition to the slope and y-intercept, the
+module can return the square of the correlation coefficient (R squared),
+the Durbin-Watson statistic, the mean squared error, sigma, the t
+statistics, the variance of the estimates of the slope and y-intercept,
+the predicted y values and the residuals of the y values.
+
+WWW: http://search.cpan.org/dist/Statistics-LineFit/
diff --git a/math/p5-Statistics-LineFit/pkg-plist b/math/p5-Statistics-LineFit/pkg-plist
new file mode 100644
index 000000000000..b47c3abba248
--- /dev/null
+++ b/math/p5-Statistics-LineFit/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Statistics/LineFit/.packlist
+%%SITE_PERL%%/Statistics/LineFit.pm
+@dirrmtry %%SITE_PERL%%/Statistics
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Statistics/LineFit
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Statistics