aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/bro/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/security/bro/Makefile b/security/bro/Makefile
index bd427d72ce35..5621eaf72902 100644
--- a/security/bro/Makefile
+++ b/security/bro/Makefile
@@ -41,19 +41,21 @@ CMAKE_ARGS+= -D CMAKE_INSTALL_PREFIX:PATH=${PREFIX} \
BROUSER?= bro
BROGROUP?= bro
-PLIST_SUB+= BROUSER="$(BROUSER)" BROGROUP="$(BROGROUP)"
+PLIST_SUB+= BROUSER=${BROUSER} \
+ BROGROUP=${BROGROUP}
USERS= ${BROUSER}
GROUPS= ${BROGROUP}
USE_OPENSSL= yes
-OPTIONS_DEFINE= BROCCOLI BROCTL DEBUG IPSUMDUMP LBL_CF LBL_HF PERFTOOLS PORTS_SSL
+OPTIONS_DEFINE= BROCCOLI BROCTL DEBUG ELASTICSEARCH IPSUMDUMP LBL_CF LBL_HF PERFTOOLS PORTS_SSL
OPTIONS_DEFAULT=BROCCOLI BROCTL IPSUMDUMP LBL_CF LBL_HF PORTS_SSL
BROCCOLI_DESC= Build support for libbroccoli communications
BROCTL_DESC= Build BroControl support (requires BROCCOLI)
DEBUG_DESC= Compile in debugging mode
+ELASTICSEARCH_DESC= Build the ElasticSearch log writer (requires curl)
IPSUMDUMP_DESC= Enables traffic summaries
LBL_CF_DESC= Unix time to formated time/date filter support
LBL_HF_DESC= Address to hostname filter support
@@ -94,6 +96,13 @@ CMAKE_ARGS+= -D INSTALL_BROCTL:BOOL=false
PLIST_SUB+= BROCTL="@comment "
.endif
+.if ${PORT_OPTIONS:MELASTICSEARCH}
+CMAKE_ARGS+= -D DISABLE_ELASTICSEARCH:BOOL=false
+LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
+.else
+CMAKE_ARGS+= -D DISABLE_ELASTICSEARCH:BOOL=true
+.endif
+
.if ${PORT_OPTIONS:MDEBUG}
CMAKE_ARGS+= -D ENABLE_DEBUG:BOOL=true
.else