aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/vpopmail-devel/Makefile6
-rw-r--r--mail/vpopmail-stable/Makefile6
-rw-r--r--mail/vpopmail/Makefile6
-rw-r--r--security/stunnel/Makefile1
4 files changed, 19 insertions, 0 deletions
diff --git a/mail/vpopmail-devel/Makefile b/mail/vpopmail-devel/Makefile
index 0d96bead0cf7..b12f83631615 100644
--- a/mail/vpopmail-devel/Makefile
+++ b/mail/vpopmail-devel/Makefile
@@ -19,6 +19,7 @@ RUN_DEPENDS= ${QMAIL_DIR}/bin/qmail-send:${PORTSDIR}/mail/qmail \
GNU_CONFIGURE= YES
USE_GMAKE= YES
+USE_REINPLACE= YES
VCFGDIR?= ${WRKDIR}/vcfg
VCFGFILES?= inc_deps lib_deps tcp.smtp
@@ -238,6 +239,11 @@ CONFIGURE_ARGS+= --enable-users-big-dir=n
CONFIGURE_ARGS+= --enable-make-seekable=n
.endif
+# autoconf and automake can remove our patches to the configure scripts.
+
+post-patch:
+ @${FIND} ${WRKSRC} -type f -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -E -e 's,@(ACLOCAL|AUTO(MAKE|CONF|HEADER))@,/usr/bin/true,'
+
#
# This port doesn't honour PREFIX, it honours vpopmail's home directory.
# Since we create vpopmail if it doesn't exist, we set it so that it
diff --git a/mail/vpopmail-stable/Makefile b/mail/vpopmail-stable/Makefile
index 490717558dc7..4e6a4e15cd2e 100644
--- a/mail/vpopmail-stable/Makefile
+++ b/mail/vpopmail-stable/Makefile
@@ -20,6 +20,7 @@ RUN_DEPENDS= ${QMAIL_DIR}/bin/qmail-send:${PORTSDIR}/mail/qmail \
GNU_CONFIGURE= YES
USE_GMAKE= YES
+USE_REINPLACE= YES
VCFGDIR?= ${WRKDIR}/vcfg
VCFGFILES?= inc_deps lib_deps tcp.smtp
@@ -163,6 +164,11 @@ CONFIGURE_ARGS+= --enable-deliver-filter=y
CONFIGURE_ARGS+= --enable-qmail-ext=y
.endif
+# autoconf and automake can remove our patches to the configure scripts.
+
+post-patch:
+ @${FIND} ${WRKSRC} -type f -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -E -e 's,@(ACLOCAL|AUTO(MAKE|CONF|HEADER))@,/usr/bin/true,'
+
#
# This port doesn't honour PREFIX, it honours vpopmail's home directory.
# Since we create vpopmail if it doesn't exist, we set it so that it
diff --git a/mail/vpopmail/Makefile b/mail/vpopmail/Makefile
index 0d96bead0cf7..b12f83631615 100644
--- a/mail/vpopmail/Makefile
+++ b/mail/vpopmail/Makefile
@@ -19,6 +19,7 @@ RUN_DEPENDS= ${QMAIL_DIR}/bin/qmail-send:${PORTSDIR}/mail/qmail \
GNU_CONFIGURE= YES
USE_GMAKE= YES
+USE_REINPLACE= YES
VCFGDIR?= ${WRKDIR}/vcfg
VCFGFILES?= inc_deps lib_deps tcp.smtp
@@ -238,6 +239,11 @@ CONFIGURE_ARGS+= --enable-users-big-dir=n
CONFIGURE_ARGS+= --enable-make-seekable=n
.endif
+# autoconf and automake can remove our patches to the configure scripts.
+
+post-patch:
+ @${FIND} ${WRKSRC} -type f -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -E -e 's,@(ACLOCAL|AUTO(MAKE|CONF|HEADER))@,/usr/bin/true,'
+
#
# This port doesn't honour PREFIX, it honours vpopmail's home directory.
# Since we create vpopmail if it doesn't exist, we set it so that it
diff --git a/security/stunnel/Makefile b/security/stunnel/Makefile
index df0b8be5ecd7..1801b043192a 100644
--- a/security/stunnel/Makefile
+++ b/security/stunnel/Makefile
@@ -34,6 +34,7 @@ post-patch:
${WRKSRC}/tools/stunnel.conf-sample.in
@${REINPLACE_CMD} -E -e 's|localstatedir/run/stunnel.pid|localstatedir/stunnel.pid|' \
${WRKSRC}/configure.ac ${WRKSRC}/configure
+ @${FIND} ${WRKSRC} -type f -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -E -e 's,@(ACLOCAL|AUTO(MAKE|CONF|HEADER))@,/usr/bin/true,'
.ifdef(NOPORTDOCS)
@${REINPLACE_CMD} -E -e 's/ install-docDATA/ /; s/^(SUBDIRS.+)doc/\1/' \
${WRKSRC}/Makefile.in