aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11/Makefile1
-rw-r--r--x11/bmpanel2/Makefile32
-rw-r--r--x11/bmpanel2/distinfo2
-rw-r--r--x11/bmpanel2/pkg-descr13
-rw-r--r--x11/bmpanel2/pkg-plist349
5 files changed, 397 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 375d98a7674e..a1f8d8677e11 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -24,6 +24,7 @@
SUBDIR += bigreqsproto
SUBDIR += bitmap
SUBDIR += blast
+ SUBDIR += bmpanel2
SUBDIR += bricons
SUBDIR += brightside
SUBDIR += cl-clx
diff --git a/x11/bmpanel2/Makefile b/x11/bmpanel2/Makefile
new file mode 100644
index 000000000000..66f6c2498149
--- /dev/null
+++ b/x11/bmpanel2/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: BMPanel 2
+# Date created: 17 May 2012
+# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bmpanel2
+DISTVERSION= 2.1pre1
+CATEGORIES= x11
+MASTER_SITES= GOOGLE_CODE
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Nice lightweight NETWM compliant panel for X
+
+LICENSE= MIT
+
+USE_CMAKE= yes
+USE_GNOME= pango
+USE_XORG= x11 xext
+
+LDFLAGS+= -L${LOCALBASE}/lib # XXX should not be needed
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,/usr/local,${PREFIX},' ${WRKSRC}/xdg.c
+ @${REINPLACE_CMD} -e '/^#include/s,alloca,stdlib,' \
+ ${WRKSRC}/widget-utils.c
+ @${REINPLACE_CMD} -e 's,uint,unsigned,' ${WRKSRC}/args.c
+# Disable unused optional features (and thus unbreak "make clean")
+ @${REINPLACE_CMD} -e '/^OPTION/s, ON, OFF,' ${WRKSRC}/CMakeLists.txt
+
+.include <bsd.port.mk>
diff --git a/x11/bmpanel2/distinfo b/x11/bmpanel2/distinfo
new file mode 100644
index 000000000000..e8e23111fb04
--- /dev/null
+++ b/x11/bmpanel2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (bmpanel2-2.1pre1.tar.gz) = 56c316ea3cd35ae033610d073b7d532c6a12070f9c349ec3c09e85c60591564c
+SIZE (bmpanel2-2.1pre1.tar.gz) = 386297
diff --git a/x11/bmpanel2/pkg-descr b/x11/bmpanel2/pkg-descr
new file mode 100644
index 000000000000..c8fda3f1ae27
--- /dev/null
+++ b/x11/bmpanel2/pkg-descr
@@ -0,0 +1,13 @@
+BMPanel (bitmap panel) is lightweight, nice NETWM-compatible panel for your
+X11 desktop. It features:
+
+ - Look'n'feel customization via themes (20 of them included)
+ - A bunch of widgets: desktop switcher, taskbar, launchbar, systray,
+ clock, decor, empty
+ - Pseudo-transparency support
+ - Written in C with speed and clarity in mind
+ - Small number of dependencies, briefly: glib2, cairo, pango, libX11
+ - Small memory footprint (about 2-4 megabytes)
+ - Small executable (80 kilobytes at the moment)
+
+WWW: http://code.google.com/p/bmpanel2/
diff --git a/x11/bmpanel2/pkg-plist b/x11/bmpanel2/pkg-plist
new file mode 100644
index 000000000000..e8321582c84d
--- /dev/null
+++ b/x11/bmpanel2/pkg-plist
@@ -0,0 +1,349 @@
+bin/bmpanel2
+%%DATADIR%%/themes/alduin-glossy/default_icon.png
+%%DATADIR%%/themes/alduin-glossy/launchbar-arrow.png
+%%DATADIR%%/themes/alduin-glossy/tb-left-active-hover.png
+%%DATADIR%%/themes/alduin-glossy/tb-left-active.png
+%%DATADIR%%/themes/alduin-glossy/tb-left-hover.png
+%%DATADIR%%/themes/alduin-glossy/tb-lr-idle.png
+%%DATADIR%%/themes/alduin-glossy/tb-right-active-hover.png
+%%DATADIR%%/themes/alduin-glossy/tb-right-active.png
+%%DATADIR%%/themes/alduin-glossy/tb-right-hover.png
+%%DATADIR%%/themes/alduin-glossy/tb-tile-active-hover.png
+%%DATADIR%%/themes/alduin-glossy/tb-tile-active.png
+%%DATADIR%%/themes/alduin-glossy/tb-tile-hover.png
+%%DATADIR%%/themes/alduin-glossy/theme
+%%DATADIR%%/themes/alduin-glossy/tile.png
+%%DATADIR%%/themes/alduin-smooth/default_icon.png
+%%DATADIR%%/themes/alduin-smooth/launchbar-arrow.png
+%%DATADIR%%/themes/alduin-smooth/tb-left-active-hover.png
+%%DATADIR%%/themes/alduin-smooth/tb-left-active.png
+%%DATADIR%%/themes/alduin-smooth/tb-left-hover.png
+%%DATADIR%%/themes/alduin-smooth/tb-lr-idle.png
+%%DATADIR%%/themes/alduin-smooth/tb-right-active-hover.png
+%%DATADIR%%/themes/alduin-smooth/tb-right-active.png
+%%DATADIR%%/themes/alduin-smooth/tb-right-hover.png
+%%DATADIR%%/themes/alduin-smooth/tb-tile-active-hover.png
+%%DATADIR%%/themes/alduin-smooth/tb-tile-active.png
+%%DATADIR%%/themes/alduin-smooth/tb-tile-hover.png
+%%DATADIR%%/themes/alduin-smooth/theme
+%%DATADIR%%/themes/alduin-smooth/tile.png
+%%DATADIR%%/themes/auriel-blue-opaque/default_icon.png
+%%DATADIR%%/themes/auriel-blue-opaque/separator.png
+%%DATADIR%%/themes/auriel-blue-opaque/tb-left-active-hover.png
+%%DATADIR%%/themes/auriel-blue-opaque/tb-left-active.png
+%%DATADIR%%/themes/auriel-blue-opaque/tb-left-hover.png
+%%DATADIR%%/themes/auriel-blue-opaque/tb-lr-idle.png
+%%DATADIR%%/themes/auriel-blue-opaque/tb-right-active-hover.png
+%%DATADIR%%/themes/auriel-blue-opaque/tb-right-active.png
+%%DATADIR%%/themes/auriel-blue-opaque/tb-right-hover.png
+%%DATADIR%%/themes/auriel-blue-opaque/tb-tile-active-hover.png
+%%DATADIR%%/themes/auriel-blue-opaque/tb-tile-active.png
+%%DATADIR%%/themes/auriel-blue-opaque/tb-tile-hover.png
+%%DATADIR%%/themes/auriel-blue-opaque/theme
+%%DATADIR%%/themes/auriel-blue-opaque/tile.png
+%%DATADIR%%/themes/auriel-blue-smooth/default_icon.png
+%%DATADIR%%/themes/auriel-blue-smooth/separator.png
+%%DATADIR%%/themes/auriel-blue-smooth/tb-left-active-hover.png
+%%DATADIR%%/themes/auriel-blue-smooth/tb-left-active.png
+%%DATADIR%%/themes/auriel-blue-smooth/tb-left-hover.png
+%%DATADIR%%/themes/auriel-blue-smooth/tb-lr-idle.png
+%%DATADIR%%/themes/auriel-blue-smooth/tb-right-active-hover.png
+%%DATADIR%%/themes/auriel-blue-smooth/tb-right-active.png
+%%DATADIR%%/themes/auriel-blue-smooth/tb-right-hover.png
+%%DATADIR%%/themes/auriel-blue-smooth/tb-tile-active-hover.png
+%%DATADIR%%/themes/auriel-blue-smooth/tb-tile-active.png
+%%DATADIR%%/themes/auriel-blue-smooth/tb-tile-hover.png
+%%DATADIR%%/themes/auriel-blue-smooth/theme
+%%DATADIR%%/themes/auriel-blue-smooth/tile.png
+%%DATADIR%%/themes/auriel-green-opaque/default_icon.png
+%%DATADIR%%/themes/auriel-green-opaque/separator.png
+%%DATADIR%%/themes/auriel-green-opaque/tb-left-active-hover.png
+%%DATADIR%%/themes/auriel-green-opaque/tb-left-active.png
+%%DATADIR%%/themes/auriel-green-opaque/tb-left-hover.png
+%%DATADIR%%/themes/auriel-green-opaque/tb-lr-idle.png
+%%DATADIR%%/themes/auriel-green-opaque/tb-right-active-hover.png
+%%DATADIR%%/themes/auriel-green-opaque/tb-right-active.png
+%%DATADIR%%/themes/auriel-green-opaque/tb-right-hover.png
+%%DATADIR%%/themes/auriel-green-opaque/tb-tile-active-hover.png
+%%DATADIR%%/themes/auriel-green-opaque/tb-tile-active.png
+%%DATADIR%%/themes/auriel-green-opaque/tb-tile-hover.png
+%%DATADIR%%/themes/auriel-green-opaque/theme
+%%DATADIR%%/themes/auriel-green-opaque/tile.png
+%%DATADIR%%/themes/auriel-green-smooth/default_icon.png
+%%DATADIR%%/themes/auriel-green-smooth/separator.png
+%%DATADIR%%/themes/auriel-green-smooth/tb-left-active-hover.png
+%%DATADIR%%/themes/auriel-green-smooth/tb-left-active.png
+%%DATADIR%%/themes/auriel-green-smooth/tb-left-hover.png
+%%DATADIR%%/themes/auriel-green-smooth/tb-lr-idle.png
+%%DATADIR%%/themes/auriel-green-smooth/tb-right-active-hover.png
+%%DATADIR%%/themes/auriel-green-smooth/tb-right-active.png
+%%DATADIR%%/themes/auriel-green-smooth/tb-right-hover.png
+%%DATADIR%%/themes/auriel-green-smooth/tb-tile-active-hover.png
+%%DATADIR%%/themes/auriel-green-smooth/tb-tile-active.png
+%%DATADIR%%/themes/auriel-green-smooth/tb-tile-hover.png
+%%DATADIR%%/themes/auriel-green-smooth/theme
+%%DATADIR%%/themes/auriel-green-smooth/tile.png
+%%DATADIR%%/themes/auriel-pink-opaque/default_icon.png
+%%DATADIR%%/themes/auriel-pink-opaque/separator.png
+%%DATADIR%%/themes/auriel-pink-opaque/tb-left-active-hover.png
+%%DATADIR%%/themes/auriel-pink-opaque/tb-left-active.png
+%%DATADIR%%/themes/auriel-pink-opaque/tb-left-hover.png
+%%DATADIR%%/themes/auriel-pink-opaque/tb-lr-idle.png
+%%DATADIR%%/themes/auriel-pink-opaque/tb-right-active-hover.png
+%%DATADIR%%/themes/auriel-pink-opaque/tb-right-active.png
+%%DATADIR%%/themes/auriel-pink-opaque/tb-right-hover.png
+%%DATADIR%%/themes/auriel-pink-opaque/tb-tile-active-hover.png
+%%DATADIR%%/themes/auriel-pink-opaque/tb-tile-active.png
+%%DATADIR%%/themes/auriel-pink-opaque/tb-tile-hover.png
+%%DATADIR%%/themes/auriel-pink-opaque/theme
+%%DATADIR%%/themes/auriel-pink-opaque/tile.png
+%%DATADIR%%/themes/auriel-pink-smooth/default_icon.png
+%%DATADIR%%/themes/auriel-pink-smooth/separator.png
+%%DATADIR%%/themes/auriel-pink-smooth/tb-left-active-hover.png
+%%DATADIR%%/themes/auriel-pink-smooth/tb-left-active.png
+%%DATADIR%%/themes/auriel-pink-smooth/tb-left-hover.png
+%%DATADIR%%/themes/auriel-pink-smooth/tb-lr-idle.png
+%%DATADIR%%/themes/auriel-pink-smooth/tb-right-active-hover.png
+%%DATADIR%%/themes/auriel-pink-smooth/tb-right-active.png
+%%DATADIR%%/themes/auriel-pink-smooth/tb-right-hover.png
+%%DATADIR%%/themes/auriel-pink-smooth/tb-tile-active-hover.png
+%%DATADIR%%/themes/auriel-pink-smooth/tb-tile-active.png
+%%DATADIR%%/themes/auriel-pink-smooth/tb-tile-hover.png
+%%DATADIR%%/themes/auriel-pink-smooth/theme
+%%DATADIR%%/themes/auriel-pink-smooth/tile.png
+%%DATADIR%%/themes/curvy-blue/default_icon.png
+%%DATADIR%%/themes/curvy-blue/ds-right.png
+%%DATADIR%%/themes/curvy-blue/ds.png
+%%DATADIR%%/themes/curvy-blue/tb-left-active-hover.png
+%%DATADIR%%/themes/curvy-blue/tb-left-active.png
+%%DATADIR%%/themes/curvy-blue/tb-left-idle.png
+%%DATADIR%%/themes/curvy-blue/tb-right.png
+%%DATADIR%%/themes/curvy-blue/tb-tile-active-hover.png
+%%DATADIR%%/themes/curvy-blue/tb-tile-active.png
+%%DATADIR%%/themes/curvy-blue/theme
+%%DATADIR%%/themes/curvy-blue/tile.png
+%%DATADIR%%/themes/curvy-green/default_icon.png
+%%DATADIR%%/themes/curvy-green/ds-right.png
+%%DATADIR%%/themes/curvy-green/ds.png
+%%DATADIR%%/themes/curvy-green/tb-left-active-hover.png
+%%DATADIR%%/themes/curvy-green/tb-left-active.png
+%%DATADIR%%/themes/curvy-green/tb-left-idle.png
+%%DATADIR%%/themes/curvy-green/tb-right.png
+%%DATADIR%%/themes/curvy-green/tb-tile-active-hover.png
+%%DATADIR%%/themes/curvy-green/tb-tile-active.png
+%%DATADIR%%/themes/curvy-green/theme
+%%DATADIR%%/themes/curvy-green/tile.png
+%%DATADIR%%/themes/curvy-pink/default_icon.png
+%%DATADIR%%/themes/curvy-pink/ds-right.png
+%%DATADIR%%/themes/curvy-pink/ds.png
+%%DATADIR%%/themes/curvy-pink/tb-left-active-hover.png
+%%DATADIR%%/themes/curvy-pink/tb-left-active.png
+%%DATADIR%%/themes/curvy-pink/tb-left-idle.png
+%%DATADIR%%/themes/curvy-pink/tb-right.png
+%%DATADIR%%/themes/curvy-pink/tb-tile-active-hover.png
+%%DATADIR%%/themes/curvy-pink/tb-tile-active.png
+%%DATADIR%%/themes/curvy-pink/theme
+%%DATADIR%%/themes/curvy-pink/tile.png
+%%DATADIR%%/themes/flora-blue/default_icon.png
+%%DATADIR%%/themes/flora-blue/ds-left-active.png
+%%DATADIR%%/themes/flora-blue/ds-left-idle.png
+%%DATADIR%%/themes/flora-blue/ds-right-active.png
+%%DATADIR%%/themes/flora-blue/ds-right-idle.png
+%%DATADIR%%/themes/flora-blue/ds-tile-active.png
+%%DATADIR%%/themes/flora-blue/ds-tile-idle.png
+%%DATADIR%%/themes/flora-blue/tb-left-active-hover.png
+%%DATADIR%%/themes/flora-blue/tb-left-active.png
+%%DATADIR%%/themes/flora-blue/tb-left-hover.png
+%%DATADIR%%/themes/flora-blue/tb-left-idle.png
+%%DATADIR%%/themes/flora-blue/tb-right-active-hover.png
+%%DATADIR%%/themes/flora-blue/tb-right-active.png
+%%DATADIR%%/themes/flora-blue/tb-right-hover.png
+%%DATADIR%%/themes/flora-blue/tb-right-idle.png
+%%DATADIR%%/themes/flora-blue/tb-tile-active-hover.png
+%%DATADIR%%/themes/flora-blue/tb-tile-active.png
+%%DATADIR%%/themes/flora-blue/tb-tile-hover.png
+%%DATADIR%%/themes/flora-blue/tb-tile-idle.png
+%%DATADIR%%/themes/flora-blue/theme
+%%DATADIR%%/themes/flora-blue/tile.png
+%%DATADIR%%/themes/flora-green/default_icon.png
+%%DATADIR%%/themes/flora-green/ds-left-active.png
+%%DATADIR%%/themes/flora-green/ds-left-idle.png
+%%DATADIR%%/themes/flora-green/ds-right-active.png
+%%DATADIR%%/themes/flora-green/ds-right-idle.png
+%%DATADIR%%/themes/flora-green/ds-tile-active.png
+%%DATADIR%%/themes/flora-green/ds-tile-idle.png
+%%DATADIR%%/themes/flora-green/tb-left-active-hover.png
+%%DATADIR%%/themes/flora-green/tb-left-active.png
+%%DATADIR%%/themes/flora-green/tb-left-hover.png
+%%DATADIR%%/themes/flora-green/tb-left-idle.png
+%%DATADIR%%/themes/flora-green/tb-right-active-hover.png
+%%DATADIR%%/themes/flora-green/tb-right-active.png
+%%DATADIR%%/themes/flora-green/tb-right-hover.png
+%%DATADIR%%/themes/flora-green/tb-right-idle.png
+%%DATADIR%%/themes/flora-green/tb-tile-active-hover.png
+%%DATADIR%%/themes/flora-green/tb-tile-active.png
+%%DATADIR%%/themes/flora-green/tb-tile-hover.png
+%%DATADIR%%/themes/flora-green/tb-tile-idle.png
+%%DATADIR%%/themes/flora-green/theme
+%%DATADIR%%/themes/flora-green/tile.png
+%%DATADIR%%/themes/flora-pink/default_icon.png
+%%DATADIR%%/themes/flora-pink/ds-left-active.png
+%%DATADIR%%/themes/flora-pink/ds-left-idle.png
+%%DATADIR%%/themes/flora-pink/ds-right-active.png
+%%DATADIR%%/themes/flora-pink/ds-right-idle.png
+%%DATADIR%%/themes/flora-pink/ds-tile-active.png
+%%DATADIR%%/themes/flora-pink/ds-tile-idle.png
+%%DATADIR%%/themes/flora-pink/tb-left-active-hover.png
+%%DATADIR%%/themes/flora-pink/tb-left-active.png
+%%DATADIR%%/themes/flora-pink/tb-left-hover.png
+%%DATADIR%%/themes/flora-pink/tb-left-idle.png
+%%DATADIR%%/themes/flora-pink/tb-right-active-hover.png
+%%DATADIR%%/themes/flora-pink/tb-right-active.png
+%%DATADIR%%/themes/flora-pink/tb-right-hover.png
+%%DATADIR%%/themes/flora-pink/tb-right-idle.png
+%%DATADIR%%/themes/flora-pink/tb-tile-active-hover.png
+%%DATADIR%%/themes/flora-pink/tb-tile-active.png
+%%DATADIR%%/themes/flora-pink/tb-tile-hover.png
+%%DATADIR%%/themes/flora-pink/tb-tile-idle.png
+%%DATADIR%%/themes/flora-pink/theme
+%%DATADIR%%/themes/flora-pink/tile.png
+%%DATADIR%%/themes/native/clock_left_img.png
+%%DATADIR%%/themes/native/clock_right_img.png
+%%DATADIR%%/themes/native/clock_tile_img.png
+%%DATADIR%%/themes/native/decor_test.png
+%%DATADIR%%/themes/native/default_icon.png
+%%DATADIR%%/themes/native/ds_left_corner_idle_img.png
+%%DATADIR%%/themes/native/ds_left_corner_pressed_img.png
+%%DATADIR%%/themes/native/ds_left_idle_img.png
+%%DATADIR%%/themes/native/ds_left_pressed_img.png
+%%DATADIR%%/themes/native/ds_right_corner_idle_img.png
+%%DATADIR%%/themes/native/ds_right_corner_pressed_img.png
+%%DATADIR%%/themes/native/ds_right_idle_img.png
+%%DATADIR%%/themes/native/ds_right_pressed_img.png
+%%DATADIR%%/themes/native/ds_separator_img.png
+%%DATADIR%%/themes/native/separator_img.png
+%%DATADIR%%/themes/native/tb_left_idle_img.png
+%%DATADIR%%/themes/native/tb_left_pressed_img.png
+%%DATADIR%%/themes/native/tb_right_idle_img.png
+%%DATADIR%%/themes/native/tb_right_pressed_img.png
+%%DATADIR%%/themes/native/tb_tile_idle_img.png
+%%DATADIR%%/themes/native/tb_tile_pressed_img.png
+%%DATADIR%%/themes/native/theme
+%%DATADIR%%/themes/native/tile_img.png
+%%DATADIR%%/themes/noir/clock_left_img.png
+%%DATADIR%%/themes/noir/clock_right_img.png
+%%DATADIR%%/themes/noir/clock_tile_img.png
+%%DATADIR%%/themes/noir/decor_test.png
+%%DATADIR%%/themes/noir/default_icon.png
+%%DATADIR%%/themes/noir/ds_left_corner_idle_img.png
+%%DATADIR%%/themes/noir/ds_left_corner_pressed_img.png
+%%DATADIR%%/themes/noir/ds_left_pressed_img.png
+%%DATADIR%%/themes/noir/ds_leftright_idle_img.png
+%%DATADIR%%/themes/noir/ds_right_corner_idle_img.png
+%%DATADIR%%/themes/noir/ds_right_corner_pressed_img.png
+%%DATADIR%%/themes/noir/ds_right_pressed_img.png
+%%DATADIR%%/themes/noir/ds_separator_img.png
+%%DATADIR%%/themes/noir/separator_img.png
+%%DATADIR%%/themes/noir/tb_left_idle_img.png
+%%DATADIR%%/themes/noir/tb_left_pressed_img.png
+%%DATADIR%%/themes/noir/tb_right_idle_img.png
+%%DATADIR%%/themes/noir/tb_right_pressed_img.png
+%%DATADIR%%/themes/noir/tb_tile_idle_img.png
+%%DATADIR%%/themes/noir/tb_tile_pressed_img.png
+%%DATADIR%%/themes/noir/theme
+%%DATADIR%%/themes/noir/tile_img.png
+%%DATADIR%%/themes/striped/default_icon.png
+%%DATADIR%%/themes/striped/empty.png
+%%DATADIR%%/themes/striped/tb-left-active-hover.png
+%%DATADIR%%/themes/striped/tb-left-active.png
+%%DATADIR%%/themes/striped/tb-left-hover.png
+%%DATADIR%%/themes/striped/tb-lr-idle.png
+%%DATADIR%%/themes/striped/tb-right-active-hover.png
+%%DATADIR%%/themes/striped/tb-right-active.png
+%%DATADIR%%/themes/striped/tb-right-hover.png
+%%DATADIR%%/themes/striped/tb-tile-active-hover.png
+%%DATADIR%%/themes/striped/tb-tile-active.png
+%%DATADIR%%/themes/striped/tb-tile-hover.png
+%%DATADIR%%/themes/striped/theme
+%%DATADIR%%/themes/striped/tile.png
+%%DATADIR%%/themes/transpy/bg.png
+%%DATADIR%%/themes/transpy/black_l.png
+%%DATADIR%%/themes/transpy/black_r.png
+%%DATADIR%%/themes/transpy/black_t.png
+%%DATADIR%%/themes/transpy/blue_l.png
+%%DATADIR%%/themes/transpy/blue_r.png
+%%DATADIR%%/themes/transpy/blue_t.png
+%%DATADIR%%/themes/transpy/default_icon.png
+%%DATADIR%%/themes/transpy/lblack_l.png
+%%DATADIR%%/themes/transpy/lblack_r.png
+%%DATADIR%%/themes/transpy/lblack_t.png
+%%DATADIR%%/themes/transpy/lblue_l.png
+%%DATADIR%%/themes/transpy/lblue_r.png
+%%DATADIR%%/themes/transpy/lblue_t.png
+%%DATADIR%%/themes/transpy/theme
+%%DATADIR%%/themes/xsocam-dark/clock_left_img.png
+%%DATADIR%%/themes/xsocam-dark/clock_right_img.png
+%%DATADIR%%/themes/xsocam-dark/clock_tile_img.png
+%%DATADIR%%/themes/xsocam-dark/decor_test.png
+%%DATADIR%%/themes/xsocam-dark/default_icon.png
+%%DATADIR%%/themes/xsocam-dark/ds_left_corner_idle_img.png
+%%DATADIR%%/themes/xsocam-dark/ds_left_corner_pressed_img.png
+%%DATADIR%%/themes/xsocam-dark/ds_left_pressed_img.png
+%%DATADIR%%/themes/xsocam-dark/ds_leftright_idle_img.png
+%%DATADIR%%/themes/xsocam-dark/ds_right_corner_idle_img.png
+%%DATADIR%%/themes/xsocam-dark/ds_right_corner_pressed_img.png
+%%DATADIR%%/themes/xsocam-dark/ds_right_pressed_img.png
+%%DATADIR%%/themes/xsocam-dark/ds_separator_img.png
+%%DATADIR%%/themes/xsocam-dark/separator_img.png
+%%DATADIR%%/themes/xsocam-dark/tb_left_idle_img.png
+%%DATADIR%%/themes/xsocam-dark/tb_left_pressed_img.png
+%%DATADIR%%/themes/xsocam-dark/tb_right_idle_img.png
+%%DATADIR%%/themes/xsocam-dark/tb_right_pressed_img.png
+%%DATADIR%%/themes/xsocam-dark/tb_tile_idle_img.png
+%%DATADIR%%/themes/xsocam-dark/tb_tile_pressed_img.png
+%%DATADIR%%/themes/xsocam-dark/theme
+%%DATADIR%%/themes/xsocam-dark/tile_img.png
+%%DATADIR%%/themes/xsocam/clock_left_img.png
+%%DATADIR%%/themes/xsocam/clock_right_img.png
+%%DATADIR%%/themes/xsocam/clock_tile_img.png
+%%DATADIR%%/themes/xsocam/decor_test.png
+%%DATADIR%%/themes/xsocam/default_icon.png
+%%DATADIR%%/themes/xsocam/ds_left_corner_idle_img.png
+%%DATADIR%%/themes/xsocam/ds_left_corner_pressed_img.png
+%%DATADIR%%/themes/xsocam/ds_left_pressed_img.png
+%%DATADIR%%/themes/xsocam/ds_leftright_idle_img.png
+%%DATADIR%%/themes/xsocam/ds_right_corner_idle_img.png
+%%DATADIR%%/themes/xsocam/ds_right_corner_pressed_img.png
+%%DATADIR%%/themes/xsocam/ds_right_pressed_img.png
+%%DATADIR%%/themes/xsocam/ds_separator_img.png
+%%DATADIR%%/themes/xsocam/separator_img.png
+%%DATADIR%%/themes/xsocam/tb_left_idle_img.png
+%%DATADIR%%/themes/xsocam/tb_left_pressed_img.png
+%%DATADIR%%/themes/xsocam/tb_right_idle_img.png
+%%DATADIR%%/themes/xsocam/tb_right_pressed_img.png
+%%DATADIR%%/themes/xsocam/tb_tile_idle_img.png
+%%DATADIR%%/themes/xsocam/tb_tile_pressed_img.png
+%%DATADIR%%/themes/xsocam/theme
+%%DATADIR%%/themes/xsocam/tile_img.png
+@dirrm %%DATADIR%%/themes/xsocam-dark
+@dirrm %%DATADIR%%/themes/xsocam
+@dirrm %%DATADIR%%/themes/transpy
+@dirrm %%DATADIR%%/themes/striped
+@dirrm %%DATADIR%%/themes/noir
+@dirrm %%DATADIR%%/themes/native
+@dirrm %%DATADIR%%/themes/flora-pink
+@dirrm %%DATADIR%%/themes/flora-green
+@dirrm %%DATADIR%%/themes/flora-blue
+@dirrm %%DATADIR%%/themes/curvy-pink
+@dirrm %%DATADIR%%/themes/curvy-green
+@dirrm %%DATADIR%%/themes/curvy-blue
+@dirrm %%DATADIR%%/themes/auriel-pink-smooth
+@dirrm %%DATADIR%%/themes/auriel-pink-opaque
+@dirrm %%DATADIR%%/themes/auriel-green-smooth
+@dirrm %%DATADIR%%/themes/auriel-green-opaque
+@dirrm %%DATADIR%%/themes/auriel-blue-smooth
+@dirrm %%DATADIR%%/themes/auriel-blue-opaque
+@dirrm %%DATADIR%%/themes/alduin-smooth
+@dirrm %%DATADIR%%/themes/alduin-glossy
+@dirrm %%DATADIR%%/themes
+@dirrm %%DATADIR%%