aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--irc/Makefile1
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-RSS-Headlines/Makefile35
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-RSS-Headlines/distinfo3
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-RSS-Headlines/pkg-descr5
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-RSS-Headlines/pkg-plist15
5 files changed, 59 insertions, 0 deletions
diff --git a/irc/Makefile b/irc/Makefile
index 8851448f9714..9b87e85a23e8 100644
--- a/irc/Makefile
+++ b/irc/Makefile
@@ -84,6 +84,7 @@
SUBDIR += p5-POE-Component-IRC-Object
SUBDIR += p5-POE-Component-IRC-Plugin-Bollocks
SUBDIR += p5-POE-Component-IRC-Plugin-CoreList
+ SUBDIR += p5-POE-Component-IRC-Plugin-RSS-Headlines
SUBDIR += p5-POE-Component-Server-IRC
SUBDIR += p5-POE-Filter-IRCD
SUBDIR += party
diff --git a/irc/p5-POE-Component-IRC-Plugin-RSS-Headlines/Makefile b/irc/p5-POE-Component-IRC-Plugin-RSS-Headlines/Makefile
new file mode 100644
index 000000000000..124459350f8c
--- /dev/null
+++ b/irc/p5-POE-Component-IRC-Plugin-RSS-Headlines/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-POE-Component-IRC-Plugin-RSS-Headlines
+# Date created: 20.06.2008
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-IRC-Plugin-RSS-Headlines
+PORTVERSION= 1.06
+CATEGORIES= irc perl5 devel
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= A POE::Component::IRC plugin that provides RSS headline retrieval
+
+BUILD_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
+ ${SITE_PERL}/POE/Component/IRC.pm:${PORTSDIR}/irc/p5-POE-Component-IRC \
+ p5-POE-Component-Client-DNS>=1.00:${PORTSDIR}/dns/p5-POE-Component-Client-DNS
+RUN_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
+ ${SITE_PERL}/POE/Component/IRC.pm:${PORTSDIR}/irc/p5-POE-Component-IRC \
+ p5-POE-Component-Client-DNS>=1.00:${PORTSDIR}/dns/p5-POE-Component-Client-DNS
+
+PLIST_SUB= EXAMPLESDIR="share/examples/${PORTNAME}"
+PERL_CONFIGURE= yes
+
+MAN3= POE::Component::IRC::Plugin::RSS::Headlines.3
+
+post-install:
+.ifndef(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/irc/p5-POE-Component-IRC-Plugin-RSS-Headlines/distinfo b/irc/p5-POE-Component-IRC-Plugin-RSS-Headlines/distinfo
new file mode 100644
index 000000000000..dfb7235c4d9a
--- /dev/null
+++ b/irc/p5-POE-Component-IRC-Plugin-RSS-Headlines/distinfo
@@ -0,0 +1,3 @@
+MD5 (POE-Component-IRC-Plugin-RSS-Headlines-1.06.tar.gz) = 0f37c89986c7994f5be24737187488d2
+SHA256 (POE-Component-IRC-Plugin-RSS-Headlines-1.06.tar.gz) = 0a419c2363c2a8048f838fe57a416c118ff8cc00e93d99ddf78252d26cc6b2dc
+SIZE (POE-Component-IRC-Plugin-RSS-Headlines-1.06.tar.gz) = 21486
diff --git a/irc/p5-POE-Component-IRC-Plugin-RSS-Headlines/pkg-descr b/irc/p5-POE-Component-IRC-Plugin-RSS-Headlines/pkg-descr
new file mode 100644
index 000000000000..2290e58ce6af
--- /dev/null
+++ b/irc/p5-POE-Component-IRC-Plugin-RSS-Headlines/pkg-descr
@@ -0,0 +1,5 @@
+POE::Component::IRC::Plugin::RSS::Headlines, is a POE::Component::IRC
+plugin that provides a mechanism for retrieving RSS headlines from given
+URLs.
+
+WWW: http://search.cpan.org/dist/POE-Component-IRC-Plugin-RSS-Headlines/
diff --git a/irc/p5-POE-Component-IRC-Plugin-RSS-Headlines/pkg-plist b/irc/p5-POE-Component-IRC-Plugin-RSS-Headlines/pkg-plist
new file mode 100644
index 000000000000..09db9745db55
--- /dev/null
+++ b/irc/p5-POE-Component-IRC-Plugin-RSS-Headlines/pkg-plist
@@ -0,0 +1,15 @@
+%%SITE_PERL%%/POE/Component/IRC/Plugin/RSS/Headlines.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC/Plugin/RSS/Headlines/.packlist
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/synopsis.pl
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC/Plugin/RSS/Headlines
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC/Plugin/RSS
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC/Plugin
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE
+@dirrm %%SITE_PERL%%/POE/Component/IRC/Plugin/RSS
+@dirrm %%SITE_PERL%%/POE/Component/IRC/Plugin
+@dirrm %%SITE_PERL%%/POE/Component/IRC
+@dirrm %%SITE_PERL%%/POE/Component
+@dirrm %%SITE_PERL%%/POE