aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--comms/aprsd/Makefile3
-rw-r--r--databases/gnats4/Makefile3
-rw-r--r--deskutils/easystroke/Makefile3
-rw-r--r--devel/gitg0/Makefile3
-rw-r--r--devel/zpu-gcc/Makefile5
-rw-r--r--dns/bundy/Makefile9
-rw-r--r--finance/ledger/Makefile8
-rw-r--r--games/lander/Makefile3
-rw-r--r--games/rlvm/Makefile3
-rw-r--r--multimedia/cclive/Makefile3
-rw-r--r--print/pdf-tools/Makefile3
-rw-r--r--security/fwbuilder/Makefile3
-rw-r--r--security/pam_ssh_agent_auth/Makefile3
-rw-r--r--sysutils/acpica-tools/Makefile3
-rw-r--r--sysutils/usbhotkey/Makefile5
-rw-r--r--textproc/apertium/Makefile3
-rw-r--r--www/mod_authnz_crowd/Makefile3
17 files changed, 41 insertions, 25 deletions
diff --git a/comms/aprsd/Makefile b/comms/aprsd/Makefile
index 32615cc5db3e..4ff55a4c4ed7 100644
--- a/comms/aprsd/Makefile
+++ b/comms/aprsd/Makefile
@@ -13,7 +13,8 @@ COMMENT= Server daemon providing Internet access to APRS packet data
LICENSE= GPLv2
-BROKEN_powerpc64= fails to link: httpserver.o:(.text+0x1074): undefined reference to `convertUpTime(int)'
+BROKEN_FreeBSD_11_powerpc64= fails to link on powerpc64 elfv1: httpserver.o:(.text+0x1074): undefined reference to `convertUpTime(int)'
+BROKEN_FreeBSD_12_powerpc64= fails to link on powerpc64 elfv1: httpserver.o:(.text+0x1074): undefined reference to `convertUpTime(int)'
GNU_CONFIGURE= yes
SUB_FILES= pkg-message pkg-deinstall
diff --git a/databases/gnats4/Makefile b/databases/gnats4/Makefile
index dfb12e879990..88ad1fdd6bce 100644
--- a/databases/gnats4/Makefile
+++ b/databases/gnats4/Makefile
@@ -13,7 +13,8 @@ COMMENT= GNATS, the GNU Problem Report Management System
BROKEN_mips= Does not build: error: conflicting types for yy_scan_string
BROKEN_mips64= Does not build: error: conflicting types for yy_scan_string
-BROKEN_powerpc64= Does not build: error: conflicting types for yy_scan_string
+BROKEN_FreeBSD_11_powerpc64= fails to build on powerpc64 elfv1: conflicting types for yy_scan_string
+BROKEN_FreeBSD_12_powerpc64= fails to build on powerpc64 elfv1: conflicting types for yy_scan_string
GNU_CONFIGURE= yes
USES= cpe gmake makeinfo
diff --git a/deskutils/easystroke/Makefile b/deskutils/easystroke/Makefile
index 29511ea73921..48bd8a0bc7c6 100644
--- a/deskutils/easystroke/Makefile
+++ b/deskutils/easystroke/Makefile
@@ -13,7 +13,8 @@ COMMENT= Easystroke is a gesture-recognition application for X11
LICENSE= ISCL
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_powerpc64= fails to build: handler.cc:560:27: call of overloaded 'abs(float&)' is ambiguous
+BROKEN_FreeBSD_11_powerpc64= fails to build on powerpc64 elfv1: handler.cc:560:27: call of overloaded 'abs(float&)' is ambiguous
+BROKEN_FreeBSD_12_powerpc64= fails to build on powerpc64 elfv1: handler.cc:560:27: call of overloaded 'abs(float&)' is ambiguous
BUILD_DEPENDS= help2man:misc/help2man \
${LOCALBASE}/include/xorg/xserver-properties.h:x11-servers/xorg-server
diff --git a/devel/gitg0/Makefile b/devel/gitg0/Makefile
index 6df875d0387a..d1973ee6a326 100644
--- a/devel/gitg0/Makefile
+++ b/devel/gitg0/Makefile
@@ -14,7 +14,8 @@ COMMENT= GTK-based git repository viewer (gtk2 version)
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_powerpc64= fails to link: gitg-branch-actions.o(.text+0x46c): unresolvable R_PPC64_REL24 relocation against symbol gitg_revision_get_subject
+BROKEN_FreeBSD_11_powerpc64= fails to link on powerpc64 elfv1: gitg-branch-actions.o(.text+0x46c): unresolvable R_PPC64_REL24 relocation against symbol gitg_revision_get_subject
+BROKEN_FreeBSD_12_powerpc64= fails to link on powerpc64 elfv1: gitg-branch-actions.o(.text+0x46c): unresolvable R_PPC64_REL24 relocation against symbol gitg_revision_get_subject
RUN_DEPENDS= git:devel/git
diff --git a/devel/zpu-gcc/Makefile b/devel/zpu-gcc/Makefile
index 2c824f1c2eba..9ba44ec5872f 100644
--- a/devel/zpu-gcc/Makefile
+++ b/devel/zpu-gcc/Makefile
@@ -12,11 +12,12 @@ COMMENT= ZPU gcc compiler
LICENSE= GPLv2
+BROKEN_FreeBSD_11_powerpc64= fails to compile on powerpc64 elfv1: libgcc2.h: conflicting types for '__structdi3'
+BROKEN_FreeBSD_12_powerpc64= fails to compile on powerpc64 elfv1: libgcc2.h: conflicting types for '__structdi3'
+
BUILD_DEPENDS= ${LOCALBASE}/zpu/bin/zpu-elf-as:devel/zpu-binutils
RUN_DEPENDS:= ${BUILD_DEPENDS}
-BROKEN_powerpc64= fails to compile: libgcc2.h: conflicting types for '__structdi3'
-
WRKSRC= ${WRKDIR}/${DISTNAME}/toolchain
USES= gettext gmake makeinfo
MANDIRS= ${PREFIX}/zpu/man
diff --git a/dns/bundy/Makefile b/dns/bundy/Makefile
index f9f91de5ec08..a82823a11439 100644
--- a/dns/bundy/Makefile
+++ b/dns/bundy/Makefile
@@ -17,6 +17,11 @@ LICENSE_NAME= ISC License
LICENSE_FILE= ${WRKSRC}/COPYING
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+BROKEN_armv6= fails to build: Child process terminated abnormally: Segmentation fault
+BROKEN_armv7= fails to build: Child process terminated abnormally: Segmentation fault
+BROKEN_FreeBSD_11_powerpc64= fails to configure on powerpc64 elfv1: checking for botan/botan.h... no
+BROKEN_FreeBSD_12_powerpc64= fails to configure on powerpc64 elfv1: checking for botan/botan.h... no
+
BUILD_DEPENDS= ${LOCALBASE}/include/log4cplus/logger.h:devel/log4cplus \
sqlite3>=3.3.9:databases/sqlite3 \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
@@ -26,10 +31,6 @@ LIB_DEPENDS= libbotan-1.10.so:security/botan110 \
libsqlite3.so:databases/sqlite3
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
-BROKEN_armv6 = fails to build: Child process terminated abnormally: Segmentation fault
-BROKEN_armv7 = fails to build: Child process terminated abnormally: Segmentation fault
-BROKEN_powerpc64= fails to configure: checking for botan/botan.h... no
-
USES= compiler:c++11-lang pathfix pkgconfig libtool python:3.4+ autoreconf ssl
USE_CSTD= gnu99
USE_CXXSTD= gnu++98
diff --git a/finance/ledger/Makefile b/finance/ledger/Makefile
index ce31b59d22ce..a851867e8158 100644
--- a/finance/ledger/Makefile
+++ b/finance/ledger/Makefile
@@ -16,17 +16,17 @@ COMMENT= John Wiegley's command line accounting program
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.md
+BROKEN_FreeBSD_11_powerpc64= fails to link on powerpc64 elfv1: ibledger.so.3: undefined reference to boost::match_results
+BROKEN_FreeBSD_12_powerpc64= fails to link on powerpc64 elfv1: ibledger.so.3: undefined reference to boost::match_results
+
BUILD_DEPENDS= ${LOCALBASE}/include/utf8.h:devel/utf8cpp
LIB_DEPENDS= libgmp.so:math/gmp \
libmpfr.so:math/mpfr \
libboost_system.so:devel/boost-libs
-BROKEN_powerpc64= fails to link: ibledger.so.3: undefined reference to boost::match_results
-
+USES= cmake compiler:c++11-lib libedit
USE_GITHUB= yes
-
USE_LDCONFIG= yes
-USES= cmake compiler:c++11-lib libedit
CMAKE_ARGS= -DCMAKE_INSTALL_MANDIR=${MANPREFIX}/man \
-DCMAKE_INCLUDE_PATH=${LOCALBASE}/include
diff --git a/games/lander/Makefile b/games/lander/Makefile
index 08149389aa8b..97e094ef178b 100644
--- a/games/lander/Makefile
+++ b/games/lander/Makefile
@@ -14,7 +14,8 @@ COMMENT= Lunar Lander clone
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_powerpc64= fails to configure: error: Could not link against boost_filesystem-boost_filesystem
+BROKEN_FreeBSD_11_powerpc64= fails to configure on powerpc64 elfv1: could not link against boost_filesystem-boost_filesystem
+BROKEN_FreeBSD_12_powerpc64= fails to configure on powerpc64 elfv1: could not link against boost_filesystem-boost_filesystem
LIB_DEPENDS= libfreetype.so:print/freetype2 \
libboost_filesystem.so:devel/boost-libs \
diff --git a/games/rlvm/Makefile b/games/rlvm/Makefile
index 12ca9582dada..929ccb339fbf 100644
--- a/games/rlvm/Makefile
+++ b/games/rlvm/Makefile
@@ -16,7 +16,8 @@ COMMENT= RealLive virtual machine clone
LICENSE= GPLv2 GPLv3 MIT
LICENSE_COMB= multi
-BROKEN_powerpc64= fails to link: gcn_platform.cc: undefined reference to gcn::Exception::Exception
+BROKEN_FreeBSD_11_powerpc64= fails to link on powerpc64 elfv1: gcn_platform.cc: undefined reference to gcn::Exception::Exception
+BROKEN_FreeBSD_12_powerpc64= fails to link on powerpc64 elfv1: gcn_platform.cc: undefined reference to gcn::Exception::Exception
BUILD_DEPENDS= ${LOCALBASE}/include/utf8.h:devel/utf8cpp
LIB_DEPENDS= libvorbisfile.so:audio/libvorbis \
diff --git a/multimedia/cclive/Makefile b/multimedia/cclive/Makefile
index 3403ba575ea5..90163a16c46d 100644
--- a/multimedia/cclive/Makefile
+++ b/multimedia/cclive/Makefile
@@ -12,7 +12,8 @@ COMMENT= Lightweight command line video extraction tool
LICENSE= GPLv3
-BROKEN_powerpc64= fails to configure: cannot find the flags to link with Boost date_time
+BROKEN_FreeBSD_11_powerpc64= fails to configure on powerpc64 elfv1: cannot find the flags to link with Boost date_time
+BROKEN_FreeBSD_12_powerpc64= fails to configure on powerpc64 elfv1: cannot find the flags to link with Boost date_time
LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libcurl.so:ftp/curl \
diff --git a/print/pdf-tools/Makefile b/print/pdf-tools/Makefile
index 2b9ab2fdc667..bf64aecccdb6 100644
--- a/print/pdf-tools/Makefile
+++ b/print/pdf-tools/Makefile
@@ -14,7 +14,8 @@ COMMENT= Emacs support library for PDF files
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_powerpc64= fails to configure: cannot find necessary poppler-private header (see README.org)
+BROKEN_FreeBSD_11_powerpc64= fails to configure on powerpc64 elfv1: cannot find necessary poppler-private header (see README.org)
+BROKEN_FreeBSD_12_powerpc64= fails to configure on powerpc64 elfv1: cannot find necessary poppler-private header (see README.org)
BUILD_DEPENDS= cask${EMACS_PKGNAMESUFFIX}>0:devel/cask@${EMACS_FLAVOR} \
tablist${EMACS_PKGNAMESUFFIX}>=0.70.4:devel/tablist@${EMACS_FLAVOR}
diff --git a/security/fwbuilder/Makefile b/security/fwbuilder/Makefile
index 660988d2a7cb..eaaf53fb9e5b 100644
--- a/security/fwbuilder/Makefile
+++ b/security/fwbuilder/Makefile
@@ -10,7 +10,8 @@ CATEGORIES= security
MAINTAINER= cy@FreeBSD.org
COMMENT= Firewall Builder GUI and policy compilers
-BROKEN_powerpc64= fails to configure: libz library not found
+BROKEN_FreeBSD_11_powerpc64= fails to configure on powerpc64 elfv1: libz library not found
+BROKEN_FreeBSD_12_powerpc64= fails to configure on powerpc64 elfv1: libz library not found
LIB_DEPENDS= libxslt.so:textproc/libxslt \
libnetsnmp.so:net-mgmt/net-snmp
diff --git a/security/pam_ssh_agent_auth/Makefile b/security/pam_ssh_agent_auth/Makefile
index bdb6b39c8d96..1467318a41d2 100644
--- a/security/pam_ssh_agent_auth/Makefile
+++ b/security/pam_ssh_agent_auth/Makefile
@@ -11,7 +11,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= PAM module which permits authentication via ssh-agent
BROKEN_mips64= fails to compile: ed25519-donna-portable.h:85:4: Need a uint128_t implementation!
-BROKEN_powerpc64= fails to compile: ed25519-donna-portable.h: warning: ALIGN redefined
+BROKEN_FreeBSD_11_powerpc64= fails to compile on powerpc64 elfv1: ed25519-donna-portable.h: warning: ALIGN redefined
+BROKEN_FreeBSD_12_powerpc64= fails to compile on powerpc64 elfv1: ed25519-donna-portable.h: warning: ALIGN redefined
USES= perl5 ssl tar:bzip2
USE_PERL5= build
diff --git a/sysutils/acpica-tools/Makefile b/sysutils/acpica-tools/Makefile
index 7e5d4aa9991c..6cf65ac211cf 100644
--- a/sysutils/acpica-tools/Makefile
+++ b/sysutils/acpica-tools/Makefile
@@ -14,7 +14,8 @@ COMMENT= Tools from the ACPI Component Architecture (ACPICA) project
LICENSE= BSD3CLAUSE GPLv2
LICENSE_COMB= dual
-BROKEN_powerpc64= fails to compile: comparison is always true due to limited range of data type
+BROKEN_FreeBSD_11_powerpc64= fails to compile on powerpc64 elfv1: comparison is always true due to limited range of data type
+BROKEN_FreeBSD_12_powerpc64= fails to compile on powerpc64 elfv1: comparison is always true due to limited range of data type
USES= gmake
diff --git a/sysutils/usbhotkey/Makefile b/sysutils/usbhotkey/Makefile
index 681b3b66c910..e36fffabc8ff 100644
--- a/sysutils/usbhotkey/Makefile
+++ b/sysutils/usbhotkey/Makefile
@@ -12,11 +12,12 @@ COMMENT= Utility to remap USB keyboards under X11
LICENSE= GPLv2
+BROKEN_FreeBSD_11_powerpc64= fails to compile on powerpc64 elfv1: ruby.h: wrong number of arguments specified for 'deprecated' attribute
+BROKEN_FreeBSD_12_powerpc64= fails to compile on powerpc64 elfv1: ruby.h: wrong number of arguments specified for 'deprecated' attribute
+
LIB_DEPENDS= libhid.so:devel/libhid \
libXtst.so:x11/libXtst
-BROKEN_powerpc64= fails to compile: ruby.h: wrong number of arguments specified for 'deprecated' attribute
-
USES= gmake
USE_RUBY= yes
GNU_CONFIGURE= yes
diff --git a/textproc/apertium/Makefile b/textproc/apertium/Makefile
index da50f6698917..fa9357ceafb2 100644
--- a/textproc/apertium/Makefile
+++ b/textproc/apertium/Makefile
@@ -12,7 +12,8 @@ COMMENT= Toolbox to build shallow-transfer machine translation systems
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_powerpc64= fails to configure: error: *** unable to locate pcrecpp library ***
+BROKEN_FreeBSD_11_powerpc64= fails to configure on powerpc64 elfv1: *** unable to locate pcrecpp library ***
+BROKEN_FreeBSD_12_powerpc64= fails to configure on powerpc64 elfv1: *** unable to locate pcrecpp library ***
BUILD_DEPENDS= bash:shells/bash
LIB_DEPENDS= liblttoolbox3.so:textproc/lttoolbox \
diff --git a/www/mod_authnz_crowd/Makefile b/www/mod_authnz_crowd/Makefile
index a1206910ebca..40d8bf452b18 100644
--- a/www/mod_authnz_crowd/Makefile
+++ b/www/mod_authnz_crowd/Makefile
@@ -15,7 +15,8 @@ LICENSE= APACHE20
BROKEN_mips= fails to build: error: curl/curl.h: No such file or directory
BROKEN_mips64= fails to build: error: curl/curl.h: No such file or directory
-BROKEN_powerpc64= fails to build: error: curl/curl.h: No such file or directory
+BROKEN_FreeBSD_11_powerpc64= fails to build on powerpc64 elfv1: curl/curl.h: No such file or directory
+BROKEN_FreeBSD_12_powerpc64= fails to build on powerpc64 elfv1: curl/curl.h: No such file or directory
LIB_DEPENDS= libsvn_client-1.so:devel/subversion \
libcurl.so:ftp/curl