aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/py-spambayes/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/mail/py-spambayes/Makefile b/mail/py-spambayes/Makefile
index c6c7b9d58ecb..a10e281fdb8d 100644
--- a/mail/py-spambayes/Makefile
+++ b/mail/py-spambayes/Makefile
@@ -7,6 +7,7 @@
PORTNAME= spambayes
PORTVERSION= 1.0.1
+PORTREVISION= 1
CATEGORIES= mail python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,9 +19,11 @@ COMMENT= A Bayesian anti-spam filter written in Python
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_bsddb.so:${PORTSDIR}/databases/py-bsddb
-USE_PYTHON= yes
+USE_PYTHON= 2.3
USE_PYDISTUTILS= yes
+USE_REINPLACE= yes
+
PORTDOCS= CHANGELOG.txt \
LICENSE.txt \
NEWTRICKS.txt \
@@ -35,6 +38,12 @@ PORTDOCS= CHANGELOG.txt \
post-extract:
@${CHMOD} -Rf u+w ${WRKSRC}
+post-patch:
+ @${FIND} ${WRKSRC} -type f | \
+ ${XARGS} -n 10 -x \
+ ${REINPLACE_CMD} -E \
+ -e 's|/usr/bin/env python|${PYTHONBASE}/bin/${PYTHON_VERSION}|'
+
post-install:
.ifndef(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}