aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-net-http-persistent/Makefile23
-rw-r--r--www/rubygem-net-http-persistent/distinfo2
-rw-r--r--www/rubygem-net-http-persistent/pkg-descr10
4 files changed, 36 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 1e3814d2cd8c..85dc312514e2 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1640,6 +1640,7 @@
SUBDIR += rubygem-mongrel
SUBDIR += rubygem-mongrel_cluster
SUBDIR += rubygem-multipart-post
+ SUBDIR += rubygem-net-http-persistent
SUBDIR += rubygem-nicovideo
SUBDIR += rubygem-passenger
SUBDIR += rubygem-rack
diff --git a/www/rubygem-net-http-persistent/Makefile b/www/rubygem-net-http-persistent/Makefile
new file mode 100644
index 000000000000..0f08318999ef
--- /dev/null
+++ b/www/rubygem-net-http-persistent/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: rubygem-net-http-persistent
+# Date created: 2011-10-31
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= net-http-persistent
+PORTVERSION= 2.3.1
+CATEGORIES= www net ruby
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Manages persistent connections using Net::HTTP
+
+RUN_DEPENDS= rubygem-hoe>=2.12:${PORTSDIR}/devel/rubygem-hoe \
+ rubygem-minitest>=2.6:${PORTSDIR}/devel/rubygem-minitest
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-net-http-persistent/distinfo b/www/rubygem-net-http-persistent/distinfo
new file mode 100644
index 000000000000..b3049d504f5b
--- /dev/null
+++ b/www/rubygem-net-http-persistent/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/net-http-persistent-2.3.1.gem) = 07615b98e8dc36f8ca58cad2977bcd1338616f4d1003c2777de739666636253d
+SIZE (rubygem/net-http-persistent-2.3.1.gem) = 20992
diff --git a/www/rubygem-net-http-persistent/pkg-descr b/www/rubygem-net-http-persistent/pkg-descr
new file mode 100644
index 000000000000..c6c89eed4fa9
--- /dev/null
+++ b/www/rubygem-net-http-persistent/pkg-descr
@@ -0,0 +1,10 @@
+net-http-persistent manages persistent connections using Net::HTTP plus a speed
+fix for Ruby 1.8. It's thread-safe too! Using persistent HTTP connections can
+dramatically increase the speed of HTTP. Creating a new HTTP connection for
+every request involves an extra TCP round-trip and causes TCP congestion
+avoidance negotiation to start over. Net::HTTP supports persistent connections
+with some API methods but does not handle reconnection gracefully.
+Net::HTTP::Persistent supports reconnection and retry according to RFC 2616.
+
+WWW: https://github.com/drbrain/net-http-persistent
+WWW: https://rubygems.org/gems/net-http-persistent