aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.port.mk3
-rw-r--r--editors/calligra/Makefile3
-rw-r--r--editors/koffice-kde4/Makefile3
-rw-r--r--emulators/openmsx/Makefile2
-rw-r--r--games/balazar/Makefile3
-rw-r--r--games/balazarbrothers/Makefile3
-rw-r--r--games/slune/Makefile5
-rw-r--r--games/spring/Makefile3
-rw-r--r--games/tnl/Makefile5
-rw-r--r--games/vdrift/Makefile5
-rw-r--r--games/windstille/Makefile3
-rw-r--r--graphics/blender/Makefile3
-rw-r--r--graphics/enblend/Makefile5
-rw-r--r--graphics/hugin/Makefile4
-rw-r--r--graphics/py-amanith/Makefile4
-rw-r--r--graphics/py-glewpy/Makefile2
-rw-r--r--graphics/py-soya3d/Makefile3
-rw-r--r--graphics/reallyslick/Makefile2
-rw-r--r--graphics/tulip/Makefile5
19 files changed, 27 insertions, 39 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 0edfa18ef189..d10445319efa 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -383,7 +383,7 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# USE_GL - A list of Mesa or GL related dependencies needed by the port.
# Supported components are: glut, glu, glw, gl and linux.
# If set to "yes", this is equivalent to "glu". Note that
-# glut depends on glu, glw and glu depend on gl.
+# glew and glut depend on glu, glw and glu depend on gl.
# USE_MOTIF - If set, this port uses a Motif toolkit. Implies USE_XORG+= xpm
# NO_OPENMOTIF - If set, this port uses a custom Motif toolkit
# instead of Openmotif.
@@ -1993,6 +1993,7 @@ PKG_IGNORE_DEPENDS?= 'this_port_does_not_exist'
PLIST_SUB+= XAWVER=${XAWVER}
_GL_gl_LIB_DEPENDS= GL.1:${PORTSDIR}/graphics/libGL
+_GL_glew_LIB_DEPENDS= GLEW.1:${PORTSDIR}/graphics/glew
_GL_glu_LIB_DEPENDS= GLU.1:${PORTSDIR}/graphics/libGLU
_GL_glw_LIB_DEPENDS= GLw.1:${PORTSDIR}/graphics/libGLw
_GL_glut_LIB_DEPENDS= glut.3:${PORTSDIR}/graphics/libglut
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index 424175514c30..692c4b13765d 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -33,7 +33,6 @@ LIB_DEPENDS= GraphicsMagick++.1:${PORTSDIR}/graphics/GraphicsMagick \
qimageblitz.4:${PORTSDIR}/x11/qimageblitz \
boost_thread.4:${PORTSDIR}/devel/boost-libs \
qca.2:${PORTSDIR}/devel/qca \
- GLEW.1:${PORTSDIR}/graphics/glew \
gsl:${PORTSDIR}/math/gsl \
wv2.4:${PORTSDIR}/textproc/wv2 \
kipi.6:${PORTSDIR}/graphics/kdegraphics4
@@ -46,7 +45,7 @@ USE_KDE4= kdelibs pimlibs kdehier kdeprefix sharedmime automoc4
USE_QT_VER= 4
QT_COMPONENTS= corelib phonon qmake_build moc_build porting_build rcc_build uic_build \
uic3_build
-USE_GL= glut
+USE_GL= glut glew
USE_LDCONFIG= yes
CMAKE_VERBOSE= yes
diff --git a/editors/koffice-kde4/Makefile b/editors/koffice-kde4/Makefile
index 424175514c30..692c4b13765d 100644
--- a/editors/koffice-kde4/Makefile
+++ b/editors/koffice-kde4/Makefile
@@ -33,7 +33,6 @@ LIB_DEPENDS= GraphicsMagick++.1:${PORTSDIR}/graphics/GraphicsMagick \
qimageblitz.4:${PORTSDIR}/x11/qimageblitz \
boost_thread.4:${PORTSDIR}/devel/boost-libs \
qca.2:${PORTSDIR}/devel/qca \
- GLEW.1:${PORTSDIR}/graphics/glew \
gsl:${PORTSDIR}/math/gsl \
wv2.4:${PORTSDIR}/textproc/wv2 \
kipi.6:${PORTSDIR}/graphics/kdegraphics4
@@ -46,7 +45,7 @@ USE_KDE4= kdelibs pimlibs kdehier kdeprefix sharedmime automoc4
USE_QT_VER= 4
QT_COMPONENTS= corelib phonon qmake_build moc_build porting_build rcc_build uic_build \
uic3_build
-USE_GL= glut
+USE_GL= glut glew
USE_LDCONFIG= yes
CMAKE_VERBOSE= yes
diff --git a/emulators/openmsx/Makefile b/emulators/openmsx/Makefile
index 60ac679416c5..a817451f8cb0 100644
--- a/emulators/openmsx/Makefile
+++ b/emulators/openmsx/Makefile
@@ -16,7 +16,6 @@ COMMENT= Open source MSX emulator
LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2 \
jack:${PORTSDIR}/audio/jack \
- GLEW:${PORTSDIR}/graphics/glew \
png:${PORTSDIR}/graphics/png
MAKE_ARGS+= INSTALL_BINARY_DIR=${PREFIX}/bin \
@@ -25,6 +24,7 @@ MAKE_ARGS+= INSTALL_BINARY_DIR=${PREFIX}/bin \
OPENMSX_CXX=${CXX}
MAKEFILE= GNUmakefile
+USE_GL= glew
USE_GMAKE= yes
USE_TCL= 84+
USE_SDL= sdl image ttf
diff --git a/games/balazar/Makefile b/games/balazar/Makefile
index 65c4b47c970d..cfe4d925e3a1 100644
--- a/games/balazar/Makefile
+++ b/games/balazar/Makefile
@@ -16,7 +16,6 @@ MAINTAINER= acm@FreeBSD.org
COMMENT= 3D adventure and roleplaying game
LIB_DEPENDS= cal3d.12:${PORTSDIR}/graphics/cal3d \
- GLEW.1:${PORTSDIR}/graphics/glew \
freetype.9:${PORTSDIR}/print/freetype2
RUN_DEPENDS= soya_editor:${PORTSDIR}/graphics/py-soya3d \
${PYTHON_SITELIBDIR}/_openal.so:${PORTSDIR}/audio/py-openal \
@@ -28,7 +27,7 @@ USE_BZIP2= yes
USE_PYTHON= yes
USE_PYDISTUTILS= yes
USE_TWISTED= yes
-USE_GL= yes
+USE_GL= glew
USE_SDL= sdl mixer
USE_GETTEXT= yes
diff --git a/games/balazarbrothers/Makefile b/games/balazarbrothers/Makefile
index 056abaf8a774..4e01e97fc180 100644
--- a/games/balazarbrothers/Makefile
+++ b/games/balazarbrothers/Makefile
@@ -16,7 +16,6 @@ MAINTAINER= acm@FreeBSD.org
COMMENT= Balazar Brother is a free software 3D puzzle game
LIB_DEPENDS= cal3d.12:${PORTSDIR}/graphics/cal3d \
- GLEW.1:${PORTSDIR}/graphics/glew \
freetype.9:${PORTSDIR}/print/freetype2
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/cerealizer/__init__.py:${PORTSDIR}/security/py-cerealizer \
${PYTHON_SITELIBDIR}/soya/__init__.py:${PORTSDIR}/graphics/py-soya3d \
@@ -28,7 +27,7 @@ USE_GETTEXT= yes
USE_PYTHON= yes
USE_PYDISTUTILS=yes
USE_TWISTED= yes
-USE_GL= yes
+USE_GL= glew
USE_GMAKE= yes
PYDISTUTILS_PKGNAME= BalazarBrothers
diff --git a/games/slune/Makefile b/games/slune/Makefile
index d0bdaac35570..42f20ffd086f 100644
--- a/games/slune/Makefile
+++ b/games/slune/Makefile
@@ -19,15 +19,14 @@ RUN_DEPENDS= soya_editor:${PORTSDIR}/graphics/py-soya3d \
${PYTHON_SITELIBDIR}/_openal.so:${PORTSDIR}/audio/py-openal \
${PYTHON_SITELIBDIR}/ogg/vorbis.so:${PORTSDIR}/audio/py-vorbis \
${PYTHON_SITELIBDIR}/py2play/level.py:${PORTSDIR}/net-p2p/py-py2play
-LIB_DEPENDS= cal3d.12:${PORTSDIR}/graphics/cal3d \
- GLEW.1:${PORTSDIR}/graphics/glew
+LIB_DEPENDS= cal3d.12:${PORTSDIR}/graphics/cal3d
USE_BZIP2= yes
USE_DOS2UNIX= *.po *.mo
USE_GETTEXT= yes
USE_PYTHON= yes
USE_PYDISTUTILS= yes
-USE_GL= yes
+USE_GL= glew
USE_SDL= sdl mixer
PYDISTUTILS_PKGNAME= Slune
diff --git a/games/spring/Makefile b/games/spring/Makefile
index 9610921900c9..8db664234fa7 100644
--- a/games/spring/Makefile
+++ b/games/spring/Makefile
@@ -15,7 +15,6 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= A project aiming to create a new and versatile RTS Engine
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
- GLEW.1:${PORTSDIR}/graphics/glew \
boost_thread.4:${PORTSDIR}/devel/boost-libs \
IL.2:${PORTSDIR}/graphics/devil \
ogg.6:${PORTSDIR}/audio/libogg \
@@ -28,7 +27,7 @@ ONLY_FOR_ARCHS_REASON= relies on x86 floating-point math
USE_SDL= sdl
USE_OPENAL= al
-USE_GL= gl glu
+USE_GL= glew
USE_XORG= x11 xcursor
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
diff --git a/games/tnl/Makefile b/games/tnl/Makefile
index 85c819050f46..f6334e44f00b 100644
--- a/games/tnl/Makefile
+++ b/games/tnl/Makefile
@@ -22,15 +22,14 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libiovmall.so:${PORTSDIR}/lang/io
RUN_DEPENDS= ${BUILD_DEPENDS}
LIB_DEPENDS= sigc-1.2.5:${PORTSDIR}/devel/libsigc++12 \
CEGUIBase.3:${PORTSDIR}/graphics/cegui \
- png.6:${PORTSDIR}/graphics/png \
- GLEW.1:${PORTSDIR}/graphics/glew
+ png.6:${PORTSDIR}/graphics/png
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_SDL= sdl
USE_GCC= 4.2+
-USE_GL= yes
+USE_GL= glew
USE_OPENAL= al alut
CONFIGURE_ARGS= --with-io-cflags="-I${LOCALBASE}/include/io" \
diff --git a/games/vdrift/Makefile b/games/vdrift/Makefile
index cd4f28991bfb..497853d67e84 100644
--- a/games/vdrift/Makefile
+++ b/games/vdrift/Makefile
@@ -18,12 +18,11 @@ COMMENT= Open source driving simulation
BUILD_DEPENDS= scons:${PORTSDIR}/devel/scons \
${LOCALBASE}/lib/libbulletcollision.a:${PORTSDIR}/devel/bullet
-LIB_DEPENDS= vorbis.4:${PORTSDIR}/audio/libvorbis \
- GLEW:${PORTSDIR}/graphics/glew
+LIB_DEPENDS= vorbis.4:${PORTSDIR}/audio/libvorbis
RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME}/settings/VDrift.config:${PORTSDIR}/games/vdrift-data
USE_BZIP2= yes
-USE_GL= yes
+USE_GL= glew
USE_SDL= sdl image net gfx
SCONS_ARGS= prefix=${PREFIX} \
diff --git a/games/windstille/Makefile b/games/windstille/Makefile
index 66af20dffd5e..8d4f3b0c0530 100644
--- a/games/windstille/Makefile
+++ b/games/windstille/Makefile
@@ -18,7 +18,6 @@ LIB_DEPENDS= physfs.1:${PORTSDIR}/devel/physfs \
ogg.6:${PORTSDIR}/audio/libogg \
vorbis.4:${PORTSDIR}/audio/libvorbis \
png.6:${PORTSDIR}/graphics/png \
- GLEW.1:${PORTSDIR}/graphics/glew \
squirrel.0:${PORTSDIR}/lang/squirrel \
freetype.9:${PORTSDIR}/print/freetype2
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
@@ -26,7 +25,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost
USE_BZIP2= yes
USE_SCONS= yes
USE_OPENAL= al
-USE_GL= gl
+USE_GL= glew
USE_SDL= sdl image
USE_BISON= build
MAKE_JOBS_SAFE= yes
diff --git a/graphics/blender/Makefile b/graphics/blender/Makefile
index 6d363454002f..83d289f4c8b4 100644
--- a/graphics/blender/Makefile
+++ b/graphics/blender/Makefile
@@ -19,13 +19,12 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libode.a:${PORTSDIR}/devel/ode
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
png.6:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
- GLEW.1:${PORTSDIR}/graphics/glew \
IlmThread.6:${PORTSDIR}/graphics/ilmbase
USE_XORG= x11 xext xmu xi
USE_PYTHON= 2.5+
USE_SDL= sdl
-USE_GL= gl glu
+USE_GL= glew
USE_GMAKE= yes
MAKE_JOBS_UNSAFE= yes
diff --git a/graphics/enblend/Makefile b/graphics/enblend/Makefile
index 77bfd14f7439..d7e84673c254 100644
--- a/graphics/enblend/Makefile
+++ b/graphics/enblend/Makefile
@@ -17,8 +17,7 @@ COMMENT= A tool for image blending with multiresolution splines
BUILD_DEPENDS= ${LOCALBASE}/include/boost/pool/pool.hpp:${PORTSDIR}/devel/boost-libs \
OpenEXR>=1.0:${PORTSDIR}/graphics/OpenEXR
-LIB_DEPENDS= GLEW.1:${PORTSDIR}/graphics/glew \
- jpeg.11:${PORTSDIR}/graphics/jpeg \
+LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
lcms:${PORTSDIR}/graphics/lcms \
xmi.1:${PORTSDIR}/graphics/plotutils \
tiff.4:${PORTSDIR}/graphics/tiff
@@ -32,7 +31,7 @@ USE_AUTOTOOLS= automake:110:env autoconf:262:env
# http://groups.google.com/group/hugin-ptx/browse_thread/thread/725b1581c9889e37/50abe3387d61541a#50abe3387d61541a
# Gerald Pfeifer <gerald@pfeifer.com> asked to use 4.4+ instead of 4.3+
USE_GCC= 4.4+
-USE_GL= glut
+USE_GL= glew glut
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/graphics/hugin/Makefile b/graphics/hugin/Makefile
index 6f7eb1ea2e5c..d371d81fb763 100644
--- a/graphics/hugin/Makefile
+++ b/graphics/hugin/Makefile
@@ -21,8 +21,6 @@ LIB_DEPENDS= tiff:${PORTSDIR}/graphics/tiff \
exiv2:${PORTSDIR}/graphics/exiv2 \
pano13:${PORTSDIR}/graphics/libpano13 \
boost_python:${PORTSDIR}/devel/boost-python-libs \
- GLEW:${PORTSDIR}/graphics/glew \
- glut:${PORTSDIR}/graphics/libglut \
IlmImf:${PORTSDIR}/graphics/OpenEXR \
Imath:${PORTSDIR}/graphics/ilmbase
# gmake is really needed at _runtime_, do not remove it from below
@@ -44,6 +42,8 @@ USE_WX= 2.8+
USE_GETTEXT= yes
+USE_GL= glew glut
+
MAN1= \
PTBatcherGUI.1 \
align_image_stack.1 \
diff --git a/graphics/py-amanith/Makefile b/graphics/py-amanith/Makefile
index 8040264cedd7..adde583be2e6 100644
--- a/graphics/py-amanith/Makefile
+++ b/graphics/py-amanith/Makefile
@@ -17,10 +17,10 @@ DIST_SUBDIR= python
MAINTAINER= acm@FreeBSD.org
COMMENT= Python wrapper for the amanith 2D vector graphics library
-LIB_DEPENDS= GLEW.1:${PORTSDIR}/graphics/glew \
- amanith.1:${PORTSDIR}/graphics/amanith
+LIB_DEPENDS= amanith.1:${PORTSDIR}/graphics/amanith
BUILD_DEPENDS= swig:${PORTSDIR}/devel/swig13
+USE_GL= glew
USE_PYTHON= 2.4+
USE_PYDISTUTILS=yes
PYDISTUTILS_PKGNAME= PyAmanith
diff --git a/graphics/py-glewpy/Makefile b/graphics/py-glewpy/Makefile
index 549df259c962..91a600e3ca55 100644
--- a/graphics/py-glewpy/Makefile
+++ b/graphics/py-glewpy/Makefile
@@ -20,8 +20,8 @@ MAINTAINER= acm@FreeBSD.org
COMMENT= Advanced OpenGL extensions to Python
BUILD_DEPENDS= pyrex>=0.9.6.2:${PORTSDIR}/devel/pyrex
-LIB_DEPENDS= GLEW.1:${PORTSDIR}/graphics/glew
+USE_GL= glew
USE_PYTHON= 2.4+
USE_PYDISTUTILS=yes
diff --git a/graphics/py-soya3d/Makefile b/graphics/py-soya3d/Makefile
index 9b2daf982830..014df2d8cba7 100644
--- a/graphics/py-soya3d/Makefile
+++ b/graphics/py-soya3d/Makefile
@@ -21,7 +21,6 @@ COMMENT= Very high level 3D engine for Python
BUILD_DEPENDS= ${LOCALBASE}/lib/libode.a:${PORTSDIR}/devel/ode \
${PYTHON_SITELIBDIR}/PIL.pth:${PORTSDIR}/graphics/py-imaging
LIB_DEPENDS= cal3d.12:${PORTSDIR}/graphics/cal3d \
- GLEW.1:${PORTSDIR}/graphics/glew \
freetype.9:${PORTSDIR}/print/freetype2
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/editobj/editor.py:${PORTSDIR}/graphics/py-editobj \
${PYTHON_SITELIBDIR}/tofu/client.py:${PORTSDIR}/net/py-tofu \
@@ -31,7 +30,7 @@ USE_BZIP2= yes
USE_PYTHON= yes
USE_PYDISTUTILS= yes
USE_OPENAL= al alut
-USE_GL= gl
+USE_GL= glew
USE_GMAKE= yes
USE_SDL= sdl
diff --git a/graphics/reallyslick/Makefile b/graphics/reallyslick/Makefile
index 5f25e5d86ad5..4205ec8ef814 100644
--- a/graphics/reallyslick/Makefile
+++ b/graphics/reallyslick/Makefile
@@ -46,7 +46,7 @@ CONFIGURE_ARGS+= --disable-sound
.endif
.if defined(WITH_GLEW)
-LIB_DEPENDS+= GLEW.1:${PORTSDIR}/graphics/glew
+USE_GL+= glew
.else
CONFIGURE_ENV+= ac_cv_header_GL_glew_h=no
.endif
diff --git a/graphics/tulip/Makefile b/graphics/tulip/Makefile
index 504d48abbb4b..eef80aef9c89 100644
--- a/graphics/tulip/Makefile
+++ b/graphics/tulip/Makefile
@@ -15,14 +15,13 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= gahr@FreeBSD.org
COMMENT= A system dedicated to the visualization of huge graphs
-LIB_DEPENDS= GLEW.1:${PORTSDIR}/graphics/glew \
- freetype.9:${PORTSDIR}/print/freetype2
+LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
USE_BZIP2= yes
USE_QT_VER= 4
QT_COMPONENTS= corelib moc_build uic_build rcc_build gui opengl xml network \
designer assistant assistantclient
-USE_GL= glut
+USE_GL= glew glut
USE_GMAKE= yes
USE_GNOME= libxml2
USE_AUTOTOOLS= libtool:22