aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--misc/veles/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/misc/veles/Makefile b/misc/veles/Makefile
index 0a7e5a8b9262..aaf7e171f4b6 100644
--- a/misc/veles/Makefile
+++ b/misc/veles/Makefile
@@ -22,7 +22,7 @@ BUILD_DEPENDS= msgpack>0:devel/msgpack \
${PYTHON_DEPENDS}
RUN_DEPENDS= ${PYTHON_DEPENDS}
-USES= cmake python:3.6+ qt:5 shebangfix
+USES= cmake compiler python:3.6+ qt:5 shebangfix
SHEBANG_GLOB= *.py
SHEBANG_FILES= python/plugin python/proxy resources/install/postinst python/test_dis
USE_GITHUB= yes
@@ -35,11 +35,18 @@ CMAKE_ARGS= -DFREEBSD_PYTHON_CMD:STRING=${PYTHON_CMD} \
-DFREEBSD_PYTHON_SITELIBDIR:STRING=${PYTHON_SITELIBDIR} \
-DMSGPACK_INCLUDE_PATH:STRING=${LOCALBASE}/include/mgpack
+.include <bsd.port.pre.mk>
+
# veles needs clang-format and clang-tidy that are only provided by the port
BUILD_DEPENDS+= clang${LLVM_DEFAULT}:devel/llvm${LLVM_DEFAULT}
+
+.if ${CHOSEN_COMPILER_TYPE} == clang
CPP= clang-cpp${LLVM_DEFAULT}
CC= clang${LLVM_DEFAULT}
CXX= clang++${LLVM_DEFAULT}
+.else
+USE_GCC= yes
+.endif
post-patch:
@${REINPLACE_CMD} 's|QString python_interpreter_executable("/usr/local/bin/python3");|QString python_interpreter_executable("${PYTHON_CMD}");|' \
@@ -50,4 +57,4 @@ post-install:
cd ${WRKSRC}/python/veles && ${COPYTREE_SHARE} . ${STAGEDIR}${PYTHON_SITELIBDIR}/${PORTNAME}
${INSTALL_SCRIPT} ${WRKSRC}/python/srv.py ${STAGEDIR}${PREFIX}/bin/veles-server
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>