aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/scourge/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/games/scourge/Makefile b/games/scourge/Makefile
index f26bbef1386e..c207ecc041f7 100644
--- a/games/scourge/Makefile
+++ b/games/scourge/Makefile
@@ -17,12 +17,15 @@ COMMENT= S.C.O.U.R.G.E. is a rogue-like game
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
USE_X_PREFIX= yes
-USE_GL= yes
+USE_GL= yes
USE_SDL= sdl mixer net
USE_GMAKE= yes
USE_GCC= 3.3+
GNU_CONFIGURE= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}
+CPPFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -L${X11BASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+WRKSRC= ${WRKDIR}/${PORTNAME}
CONFIGURE_ARGS= --with-data-dir=${DATADIR}