aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/sdl_net/Makefile31
-rw-r--r--net/sdl_net/distinfo1
-rw-r--r--net/sdl_net/files/patch-aa14
-rw-r--r--net/sdl_net/pkg-comment1
-rw-r--r--net/sdl_net/pkg-descr5
-rw-r--r--net/sdl_net/pkg-plist4
7 files changed, 57 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 0be475c6ba53..b49bed7d4183 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -226,6 +226,7 @@
SUBDIR += samba
SUBDIR += scotty
SUBDIR += scotty3
+ SUBDIR += sdl_net
SUBDIR += sendfile
SUBDIR += sharity-light
SUBDIR += slirp
diff --git a/net/sdl_net/Makefile b/net/sdl_net/Makefile
new file mode 100644
index 000000000000..51862173a195
--- /dev/null
+++ b/net/sdl_net/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: sdl_net
+# Date created: 20 September 2000
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sdl_net
+PORTVERSION= 1.1.1
+CATEGORIES= net
+MASTER_SITES= http://www.devolution.com/~slouken/SDL/projects/SDL_net/src/
+DISTNAME= SDL_net-${PORTVERSION}
+
+MAINTAINER= sobomax@FreeBSD.org
+
+LIB_DEPENDS= SDL-1.0.2:${PORTSDIR}/devel/sdl \
+ GUI.0:${PORTSDIR}/graphics/guilib
+
+USE_LIBTOOL= yes
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+
+post-extract:
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|-release \$$\(LT_RELEASE\)||g'
+
+post-configure:
+ @${PERL} -pi -e 's|^deplibs_check_method=.*|deplibs_check_method=pass_all|' \
+ ${WRKSRC}/libtool
+
+.include <bsd.port.mk>
diff --git a/net/sdl_net/distinfo b/net/sdl_net/distinfo
new file mode 100644
index 000000000000..c30e5c7b020e
--- /dev/null
+++ b/net/sdl_net/distinfo
@@ -0,0 +1 @@
+MD5 (SDL_net-1.1.1.tar.gz) = fc85251bad967f056c41fe2709088801
diff --git a/net/sdl_net/files/patch-aa b/net/sdl_net/files/patch-aa
new file mode 100644
index 000000000000..db99084f9e97
--- /dev/null
+++ b/net/sdl_net/files/patch-aa
@@ -0,0 +1,14 @@
+--- SDLnetsys.h.orig Sun Jul 2 02:28:47 2000
++++ SDLnetsys.h Wed Sep 20 18:42:27 2000
+@@ -41,6 +41,11 @@
+ #include <unistd.h>
+ #include <fcntl.h>
+ #ifndef __BEOS__
++#ifdef __FreeBSD__
++#include <sys/types.h>
++#include <sys/socket.h>
++#include <netinet/in.h>
++#endif /* FreeBSD */
+ #include <arpa/inet.h>
+ #endif
+ #include <netinet/in.h>
diff --git a/net/sdl_net/pkg-comment b/net/sdl_net/pkg-comment
new file mode 100644
index 000000000000..ae0ab999e085
--- /dev/null
+++ b/net/sdl_net/pkg-comment
@@ -0,0 +1 @@
+A small sample cross-platform networking library
diff --git a/net/sdl_net/pkg-descr b/net/sdl_net/pkg-descr
new file mode 100644
index 000000000000..1118a2308b6e
--- /dev/null
+++ b/net/sdl_net/pkg-descr
@@ -0,0 +1,5 @@
+This is a small sample cross-platform networking library, with a sample chat
+client and server application. The chat client uses the GUIlib GUI framework
+library.
+
+WWW: http://www.devolution.com/~slouken/SDL/projects/SDL_net/
diff --git a/net/sdl_net/pkg-plist b/net/sdl_net/pkg-plist
new file mode 100644
index 000000000000..e8b9b46ac404
--- /dev/null
+++ b/net/sdl_net/pkg-plist
@@ -0,0 +1,4 @@
+include/SDL/SDL_net.h
+lib/libSDL_net.a
+lib/libSDL_net.so
+lib/libSDL_net.so.0