aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/cyrus-sasl2-saslauthd/Makefile5
-rw-r--r--security/cyrus-sasl2/Makefile5
2 files changed, 8 insertions, 2 deletions
diff --git a/security/cyrus-sasl2-saslauthd/Makefile b/security/cyrus-sasl2-saslauthd/Makefile
index 8e05ef92414f..2521ccd9b0f6 100644
--- a/security/cyrus-sasl2-saslauthd/Makefile
+++ b/security/cyrus-sasl2-saslauthd/Makefile
@@ -56,8 +56,11 @@ CONFIGURE_ARGS+=--with-bdb-incdir=${LOCALBASE}/include/db41 --with-bdb=db41
.elif ${WITH_BDB_VER} == 42
LIB_DEPENDS+= db-4.2.2:${PORTSDIR}/databases/db42
CONFIGURE_ARGS+=--with-bdb-incdir=${LOCALBASE}/include/db42 --with-bdb=db-4.2
+.elif ${WITH_BDB_VER} == 43
+LIB_DEPENDS+= db-4.3.0:${PORTSDIR}/databases/db43
+CONFIGURE_ARGS+=--with-bdb-incdir=${LOCALBASE}/include/db43 --with-bdb=db-4.3
.else
-BROKEN= "WITH_BDB_VER must be 3, 4, 41 or 42"
+BROKEN= "WITH_BDB_VER must be 3, 4, 41, 42 or 43"
.endif
CONFIGURE_ARGS+=--with-dblib=berkeley --with-bdb-libdir=${LOCALBASE}/lib
.else
diff --git a/security/cyrus-sasl2/Makefile b/security/cyrus-sasl2/Makefile
index e8b2fbe43112..a4bc4f3c0576 100644
--- a/security/cyrus-sasl2/Makefile
+++ b/security/cyrus-sasl2/Makefile
@@ -66,8 +66,11 @@ CONFIGURE_ARGS+=--with-bdb-incdir=${LOCALBASE}/include/db41 --with-bdb=db41
.elif ${WITH_BDB_VER} == 42
LIB_DEPENDS+= db-4.2.2:${PORTSDIR}/databases/db42
CONFIGURE_ARGS+=--with-bdb-incdir=${LOCALBASE}/include/db42 --with-bdb=db-4.2
+.elif ${WITH_BDB_VER} == 43
+LIB_DEPENDS+= db-4.3.0:${PORTSDIR}/databases/db43
+CONFIGURE_ARGS+=--with-bdb-incdir=${LOCALBASE}/include/db43 --with-bdb=db-4.3
.else
-BROKEN= "WITH_BDB_VER must be 3, 4, 41 or 42"
+BROKEN= "WITH_BDB_VER must be 3, 4, 41, 42 or 43"
.endif
CONFIGURE_ARGS+=--with-dblib=berkeley --with-bdb-libdir=${LOCALBASE}/lib
SASLDB_NAME= sasldb2