aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/hg-git/Makefile3
-rw-r--r--devel/hg-git/distinfo4
-rw-r--r--devel/hg-git/files/patch-hggit_gitdirstate.py15
3 files changed, 3 insertions, 19 deletions
diff --git a/devel/hg-git/Makefile b/devel/hg-git/Makefile
index 99843d5c2c00..a606e48d329f 100644
--- a/devel/hg-git/Makefile
+++ b/devel/hg-git/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= hg-git
-PORTVERSION= 0.8.0
-PORTREVISION= 1
+PORTVERSION= 0.8.1
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/devel/hg-git/distinfo b/devel/hg-git/distinfo
index 93ad8fc19918..df6177050961 100644
--- a/devel/hg-git/distinfo
+++ b/devel/hg-git/distinfo
@@ -1,2 +1,2 @@
-SHA256 (hg-git-0.8.0.tar.gz) = 91a16e34612595eca8c4e23d847c6ab697267b68008594926123c6c0064298dc
-SIZE (hg-git-0.8.0.tar.gz) = 46004
+SHA256 (hg-git-0.8.1.tar.gz) = ceeddfb48dc160e4c6be8c15a722a44b8554b7f68e1838f6af1018ed78b9451d
+SIZE (hg-git-0.8.1.tar.gz) = 46817
diff --git a/devel/hg-git/files/patch-hggit_gitdirstate.py b/devel/hg-git/files/patch-hggit_gitdirstate.py
deleted file mode 100644
index fdf47e3178e6..000000000000
--- a/devel/hg-git/files/patch-hggit_gitdirstate.py
+++ /dev/null
@@ -1,15 +0,0 @@
---- hggit/gitdirstate.py.orig 2014-05-09 14:26:29 UTC
-+++ hggit/gitdirstate.py
-@@ -161,7 +161,11 @@ class gitdirstate(dirstate.dirstate):
- results, work, dirsnotfound = self._walkexplicit(match, subrepos)
-
- skipstep3 = skipstep3 and not (work or dirsnotfound)
-- work = [d for d in work if not dirignore(d)]
-+ if work and isinstance(work[0], tuple):
-+ # Mercurial >= 3.3.3
-+ work = [nd for nd, d in work if not dirignore(d)]
-+ else:
-+ work = [d for d in work if not dirignore(d)]
- wadd = work.append
-
- # step 2: visit subdirectories