aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/chtml/Makefile22
-rw-r--r--www/chtml/distinfo1
-rw-r--r--www/chtml/files/patch-makefile101
-rw-r--r--www/chtml/pkg-comment1
-rw-r--r--www/chtml/pkg-descr14
-rw-r--r--www/chtml/pkg-plist7
7 files changed, 147 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 4ee3a3d15b30..be943577be99 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -46,6 +46,7 @@
SUBDIR += cheetah
SUBDIR += chimera
SUBDIR += chimera2
+ SUBDIR += chtml
SUBDIR += comclear
SUBDIR += comline
SUBDIR += crawl
diff --git a/www/chtml/Makefile b/www/chtml/Makefile
new file mode 100644
index 000000000000..4dadc9909b40
--- /dev/null
+++ b/www/chtml/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: chtml
+# Date created: 1 Aug 2001
+# Whom: David Bushong <david+ports@bushong.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= chtml
+PORTVERSION= 0.0
+CATEGORIES= www devel lang
+MASTER_SITES= http://people.delphi.com/gjc/
+DISTNAME= chtml
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= david+ports@bushong.net
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/csiod:${PORTSDIR}/lang/siod
+
+WRKSRC= ${WRKDIR}
+MAKEFILE= makefile
+
+.include <bsd.port.mk>
diff --git a/www/chtml/distinfo b/www/chtml/distinfo
new file mode 100644
index 000000000000..d3fd64fb8037
--- /dev/null
+++ b/www/chtml/distinfo
@@ -0,0 +1 @@
+MD5 (chtml.tgz) = 9d3de46c562d1b3eb9d805b2929382e2
diff --git a/www/chtml/files/patch-makefile b/www/chtml/files/patch-makefile
new file mode 100644
index 000000000000..4729310b1848
--- /dev/null
+++ b/www/chtml/files/patch-makefile
@@ -0,0 +1,101 @@
+*** makefile.orig Mon Jun 22 05:43:44 1998
+--- makefile Wed Aug 1 12:04:24 2001
+***************
+*** 17,23 ****
+ .SUFFIXES: .html .html-bin .smd .cgi .pl .cgi .scm .cgi
+
+ .html.html-bin:
+! chtml $< :o=$@
+
+ .pl.cgi:
+ echo "#!`which perl`" > $@
+--- 17,23 ----
+ .SUFFIXES: .html .html-bin .smd .cgi .pl .cgi .scm .cgi
+
+ .html.html-bin:
+! ./chtml $< :o=$@
+
+ .pl.cgi:
+ echo "#!`which perl`" > $@
+***************
+*** 191,197 ****
+
+
+ pure_chtmlt.err: pure_chtmlt
+! pure_chtmlt 2> pure_chtmlt.err
+
+ pure_next.err: pure_next.cgi
+ (PATH_INFO=/homes.html-bin; export PATH_INFO; pure_next.cgi 2> pure_next.err)
+--- 191,197 ----
+
+
+ pure_chtmlt.err: pure_chtmlt
+! ./pure_chtmlt 2> pure_chtmlt.err
+
+ pure_next.err: pure_next.cgi
+ (PATH_INFO=/homes.html-bin; export PATH_INFO; pure_next.cgi 2> pure_next.err)
+***************
+*** 201,231 ****
+ chtml.scm chtml-cmp.scm
+
+ chtml-cmp.c-bin: chtml-cmp.c
+! chtml chtml-cmp.c :o=chtml-cmp.c-bin
+
+ idiom_test: all link.html-bin-bin link_html-bin-bin.c link_html-bin-bin.scm
+! chtmlt link.html-bin-bin
+
+ link.html-bin-bin: link.html-bin link1.html-bin link2.html-bin
+! chtml -v03 :action=link link.html-bin link1.html-bin link2.html-bin
+
+
+ link_html-bin-bin.c: link.html-bin link1.html-bin link2.html-bin
+! chtml -v03 :action=link link.html-bin link1.html-bin link2.html-bin \
+ :o=link_html-bin-bin.c :p=c
+
+ link_html-bin-bin.scm: link.html-bin link1.html-bin link2.html-bin
+! chtml -v03 :action=link link.html-bin link1.html-bin link2.html-bin \
+ :o=link_html-bin-bin.scm :p=read
+
+ link.html-bin: link.html
+! chtml -v02 link.html
+
+ link1.html-bin: link1.html
+! chtml -v02 link1.html
+
+ link2.html-bin: link2.html
+! chtml -v02 link2.html
+
+ # these targets are is of local use only.
+
+--- 201,231 ----
+ chtml.scm chtml-cmp.scm
+
+ chtml-cmp.c-bin: chtml-cmp.c
+! ./chtml chtml-cmp.c :o=chtml-cmp.c-bin
+
+ idiom_test: all link.html-bin-bin link_html-bin-bin.c link_html-bin-bin.scm
+! ./chtmlt link.html-bin-bin
+
+ link.html-bin-bin: link.html-bin link1.html-bin link2.html-bin
+! ./chtml -v03 :action=link link.html-bin link1.html-bin link2.html-bin
+
+
+ link_html-bin-bin.c: link.html-bin link1.html-bin link2.html-bin
+! ./chtml -v03 :action=link link.html-bin link1.html-bin link2.html-bin \
+ :o=link_html-bin-bin.c :p=c
+
+ link_html-bin-bin.scm: link.html-bin link1.html-bin link2.html-bin
+! ./chtml -v03 :action=link link.html-bin link1.html-bin link2.html-bin \
+ :o=link_html-bin-bin.scm :p=read
+
+ link.html-bin: link.html
+! ./chtml -v02 link.html
+
+ link1.html-bin: link1.html
+! ./chtml -v02 link1.html
+
+ link2.html-bin: link2.html
+! ./chtml -v02 link2.html
+
+ # these targets are is of local use only.
+
diff --git a/www/chtml/pkg-comment b/www/chtml/pkg-comment
new file mode 100644
index 000000000000..c208a104dbad
--- /dev/null
+++ b/www/chtml/pkg-comment
@@ -0,0 +1 @@
+Chunked HTML templating engine
diff --git a/www/chtml/pkg-descr b/www/chtml/pkg-descr
new file mode 100644
index 000000000000..5de78beaa5d4
--- /dev/null
+++ b/www/chtml/pkg-descr
@@ -0,0 +1,14 @@
+CHTML works by transforming static HTML documents residing on the server into
+dynamic HTML documents that are actually seen by the user. This is similar to
+but different from server-side-include (e.g. shtml) or web-sql/gsql mechanisms
+in that it:
+
+ * avoids embedding into HTML the kinds of directives which only
+ programmers would be comfortable with.
+ * avoids overly extending HTML semantics in a way that prevents the
+ documents from being edited by wysiwyg tools.
+ * only uses templates that are complete and valid stand-alone HTML
+ documents. Therefore the documents can be verified as to HTML
+ level conformance independently from running the scripts that use them.
+
+WWW: http://people.delphi.com/gjc/chtml.html
diff --git a/www/chtml/pkg-plist b/www/chtml/pkg-plist
new file mode 100644
index 000000000000..99ee11b506df
--- /dev/null
+++ b/www/chtml/pkg-plist
@@ -0,0 +1,7 @@
+man/man1/chtml.1
+lib/libchtml.a
+bin/chtml
+include/chtml.h
+lib/siod/chtml.scm
+lib/siod/chtml-cmp.c-bin
+lib/perl5/site_perl/chtml.pl