aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-toolkits/fox17/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/x11-toolkits/fox17/Makefile b/x11-toolkits/fox17/Makefile
index 9eddffb0b7e3..50e7e1e9f48d 100644
--- a/x11-toolkits/fox17/Makefile
+++ b/x11-toolkits/fox17/Makefile
@@ -36,19 +36,16 @@ CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-opengl=yes
CPPFLAGS= -I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2
-LDFLAGS= -L${LOCALBASE}/lib
+LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
MAN1= reswrap.1 shutterbug.1 adie.1 PathFinder.1 calculator.1 \
ControlPanel.1
.include <bsd.port.pre.mk>
-.if (${ARCH} == "alpha" || ${ARCH} == "sparc64") && ${OSVERSION} < 700000
-THREAD_LIBS= -lthr
-.else
-THREAD_LIBS= ${PTHREAD_LIBS}
+.if ${ARCH} == "amd64" && ${OSVERSION} < 900000
+BROKEN= does not build on amd64
.endif
-LDFLAGS+= ${THREAD_LIBS}
post-patch:
.if defined(NOPORTDOCS)