aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/mod_access_identd/Makefile16
-rw-r--r--www/mod_access_identd/pkg-plist3
-rw-r--r--www/mod_auth_any/Makefile16
-rw-r--r--www/mod_auth_any/pkg-plist3
4 files changed, 14 insertions, 24 deletions
diff --git a/www/mod_access_identd/Makefile b/www/mod_access_identd/Makefile
index d916ce8f805c..4b24aacf80f9 100644
--- a/www/mod_access_identd/Makefile
+++ b/www/mod_access_identd/Makefile
@@ -13,13 +13,11 @@ MASTER_SITES= http://MeepZor.Com/packages/mod_access_identd/
MAINTAINER= ports@FreeBSD.org
COMMENT= Apache module to supply access control based on ident reply
-USE_APACHE= yes
-WRKSRC= ${WRKDIR}/mod_access_identd
+WRKSRC= ${WRKDIR}/${PORTNAME}
+WANT_APACHE= 13
+AP_FAST_BUILD= YES
+AP_GENPLIST= YES
-do-build:
- @cd ${WRKSRC} && ${APXS} -c ${PORTNAME}.c
-
-do-install:
- ${APXS} -i -A -n ${PORTNAME:S/_//g} ${WRKSRC}/${PORTNAME}.so
-
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/www/apache2/Makefile.modules.3rd"
+.include <bsd.port.post.mk>
diff --git a/www/mod_access_identd/pkg-plist b/www/mod_access_identd/pkg-plist
deleted file mode 100644
index 40fd54c83cd6..000000000000
--- a/www/mod_access_identd/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-libexec/apache/mod_access_identd.so
-@exec %D/sbin/apxs -e -A -n access_identd %D/%F
-@unexec %D/sbin/apxs -e -A -n access_identd %D/%F
diff --git a/www/mod_auth_any/Makefile b/www/mod_auth_any/Makefile
index bcc7c269f91c..c563226b9619 100644
--- a/www/mod_auth_any/Makefile
+++ b/www/mod_auth_any/Makefile
@@ -13,13 +13,11 @@ MASTER_SITES= http://www.itlab.musc.edu/webNIS/dist/
MAINTAINER= clement@FreeBSD.org
COMMENT= Apache module to use any command line program to authenticate a user
-USE_APACHE= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}
+WANT_APACHE= 13
+AP_FAST_BUILD= yes
+AP_GENPLIST= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}/src
-do-build:
- @cd ${WRKSRC}/src && ${APXS} -c ${PORTNAME}.c
-
-do-install:
- ${APXS} -i -A -n ${PORTNAME:S/mod_//g} ${WRKSRC}/src/${PORTNAME}.so
-
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/www/apache2/Makefile.modules.3rd"
+.include <bsd.port.post.mk>
diff --git a/www/mod_auth_any/pkg-plist b/www/mod_auth_any/pkg-plist
deleted file mode 100644
index 3fffd2cc8e60..000000000000
--- a/www/mod_auth_any/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-libexec/apache/mod_auth_any.so
-@exec %D/sbin/apxs -e -A -n auth_any %D/%F
-@unexec %D/sbin/apxs -e -A -n auth_any %D/%F