aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--irc/Makefile1
-rw-r--r--irc/ii/Makefile37
-rw-r--r--irc/ii/distinfo3
-rw-r--r--irc/ii/files/patch-Makefile15
-rw-r--r--irc/ii/files/patch-config.mk24
-rw-r--r--irc/ii/pkg-descr9
6 files changed, 89 insertions, 0 deletions
diff --git a/irc/Makefile b/irc/Makefile
index 29a8d4876535..79d580dc744c 100644
--- a/irc/Makefile
+++ b/irc/Makefile
@@ -33,6 +33,7 @@
SUBDIR += gseen.mod
SUBDIR += hybserv
SUBDIR += icbirc
+ SUBDIR += ii
SUBDIR += iip
SUBDIR += infobot
SUBDIR += inspircd
diff --git a/irc/ii/Makefile b/irc/ii/Makefile
new file mode 100644
index 000000000000..16da194fd6d2
--- /dev/null
+++ b/irc/ii/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: ii
+# Date created: July 13, 2008
+# Whom: Julien Laffaye <kimelto@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ii
+PORTVERSION= 1.3
+CATEGORIES= irc
+MASTER_SITES= http://code.suckless.org/dl/tools/ \
+ http://laffaye.free.fr/distfiles/
+
+MAINTAINER= kimelto@gmail.com
+COMMENT= A minimalist FIFO and filesystem-based IRC client
+
+MAN1= ii.1
+PLIST_FILES= bin/ii
+PORTDOCS= CHANGES README FAQ LICENSE
+PORTEXAMPLES= query.sh
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} "installing additional documentation to ${DOCSDIR}"
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_MAN} ${WRKSRC}/CHANGES ${DOCSDIR}
+ @${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
+ @${INSTALL_MAN} ${WRKSRC}/FAQ ${DOCSDIR}
+ @${INSTALL_MAN} ${WRKSRC}/LICENSE ${DOCSDIR}
+.endif
+.if !defined(NOPORTEXAMPLES)
+ @${ECHO_MSG} "installing additional examples to ${EXAMPLESDIR}"
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_MAN} ${WRKSRC}/query.sh ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/irc/ii/distinfo b/irc/ii/distinfo
new file mode 100644
index 000000000000..b44df22d03d6
--- /dev/null
+++ b/irc/ii/distinfo
@@ -0,0 +1,3 @@
+MD5 (ii-1.3.tar.gz) = 529bcc4c2ed3aecc18e131f2bfce48c1
+SHA256 (ii-1.3.tar.gz) = afdb638a9e157cdc1ad9f80d57e99993c3083e354aa3ca097df4e15fe3dfa6e0
+SIZE (ii-1.3.tar.gz) = 9335
diff --git a/irc/ii/files/patch-Makefile b/irc/ii/files/patch-Makefile
new file mode 100644
index 000000000000..8cf916e71ee4
--- /dev/null
+++ b/irc/ii/files/patch-Makefile
@@ -0,0 +1,15 @@
+--- Makefile.orig 2007-07-14 20:39:41.000000000 +0200
++++ Makefile 2008-07-17 21:27:32.000000000 +0200
+@@ -35,12 +35,10 @@
+ @${CC} -o $@ ${OBJ} ${LDFLAGS}
+
+ install: all
+- @mkdir -p ${DESTDIR}${DOCDIR}
+ @mkdir -p ${DESTDIR}${BINDIR}
+ @mkdir -p ${DESTDIR}${MAN1DIR}
+
+ @install -d ${DESTDIR}${BINDIR} ${DESTDIR}${MAN1DIR}
+- @install -m 644 CHANGES README query.sh FAQ LICENSE ${DESTDIR}${DOCDIR}
+ @install -m 775 ii ${DESTDIR}${BINDIR}
+ @install -m 444 ii.1 ${DESTDIR}${MAN1DIR}
+ @echo "installed ii"
diff --git a/irc/ii/files/patch-config.mk b/irc/ii/files/patch-config.mk
new file mode 100644
index 000000000000..997d0fcaa937
--- /dev/null
+++ b/irc/ii/files/patch-config.mk
@@ -0,0 +1,24 @@
+--- config.mk.orig 2007-07-14 20:39:41.000000000 +0200
++++ config.mk 2008-07-13 15:38:45.000000000 +0200
+@@ -1,9 +1,9 @@
+ # Customize to fit your system
+
+ # paths
+-PREFIX = /usr/local
++PREFIX ?= /usr/local
+ BINDIR = ${PREFIX}/bin
+-MANDIR = ${PREFIX}/share/man
++MANDIR = ${PREFIX}/man
+ MAN1DIR = ${MANDIR}/man1
+ DOCDIR = ${PREFIX}/share/doc/ii
+
+@@ -22,6 +22,6 @@
+ #CFLAGS = -g ${INCLUDES} -DVERSION=\"${VERSION}\"
+
+ # compiler
+-CC = cc
+-CFLAGS = -g -O0 -W -Wall ${INCLUDES} -DVERSION=\"${VERSION}\"
+-LDFLAGS = ${LIBS}
++CC ?= cc
++CFLAGS += -g -O0 -W -Wall ${INCLUDES} -DVERSION=\"${VERSION}\"
++LDFLAGS += ${LIBS}
diff --git a/irc/ii/pkg-descr b/irc/ii/pkg-descr
new file mode 100644
index 000000000000..056f57925e0d
--- /dev/null
+++ b/irc/ii/pkg-descr
@@ -0,0 +1,9 @@
+ii is a minimalist FIFO and filesystem-based IRC client. It createsan
+irc directory tree with server, channel and nick name directories.
+In every directory a FIFO in file and a normal out file is created.
+The in file is used to communicate with the servers and the out files
+contain the server messages. For every channel and every nick name there
+are related in and out files created. This allows IRC communication from
+command line and adheres to the Unix philosophy.
+
+WWW: http://www.suckless.org/wiki/tools/irc/irc_it/