aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/screenfetch/Makefile40
-rw-r--r--sysutils/screenfetch/distinfo2
-rw-r--r--sysutils/screenfetch/files/patch-screenfetch-dev20
-rw-r--r--sysutils/screenfetch/pkg-descr10
5 files changed, 73 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 8243e1de6e74..eb30d80cbaa1 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -866,6 +866,7 @@
SUBDIR += schedutils
SUBDIR += scprotect
SUBDIR += screen
+ SUBDIR += screenfetch
SUBDIR += screenie
SUBDIR += sdd
SUBDIR += sdparm
diff --git a/sysutils/screenfetch/Makefile b/sysutils/screenfetch/Makefile
new file mode 100644
index 000000000000..0528cb328693
--- /dev/null
+++ b/sysutils/screenfetch/Makefile
@@ -0,0 +1,40 @@
+# Created by: Jason Helfman <jgh@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= screenFetch
+PORTVERSION= 3.0.5
+CATEGORIES= sysutils
+MASTER_SITES= GH
+
+MAINTAINER= jgh@FreeBSD.org
+COMMENT= Bash Screenshot Information Tool
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
+ xdpyinfo:${PORTSDIR}/x11/xdpyinfo
+
+OPTIONS_DEFINE= DOCS
+
+NO_BUILD= yes
+USE_GITHUB= yes
+GH_ACCOUNT= KittyKatt
+GH_TAGNAME= dcf0dd9
+GH_COMMIT= ${GH_TAGNAME}
+
+PLIST_FILES= bin/screenFetch
+PORTDOCS= CHANGELOG README.mkdn TODO
+
+.include <bsd.port.options.mk>
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME:L}-dev ${PREFIX}/bin/${PORTNAME}
+
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+.for file in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/screenfetch/distinfo b/sysutils/screenfetch/distinfo
new file mode 100644
index 000000000000..3eb61c3add65
--- /dev/null
+++ b/sysutils/screenfetch/distinfo
@@ -0,0 +1,2 @@
+SHA256 (screenFetch-3.0.5.tar.gz) = ac7f7aad7a600d5cb84e464d533d8a0d7104635f702c86a4eb44dfe96bae6646
+SIZE (screenFetch-3.0.5.tar.gz) = 45192
diff --git a/sysutils/screenfetch/files/patch-screenfetch-dev b/sysutils/screenfetch/files/patch-screenfetch-dev
new file mode 100644
index 000000000000..8b51d3717a34
--- /dev/null
+++ b/sysutils/screenfetch/files/patch-screenfetch-dev
@@ -0,0 +1,20 @@
+--- ./screenfetch-dev.orig 2013-07-19 23:33:57.000000000 -0700
++++ ./screenfetch-dev 2013-07-19 23:35:46.000000000 -0700
+@@ -686,13 +686,16 @@
+ pkgs=$((${pkgs} + ${brew_pkgs}))
+ fi
+ ;;
+- 'FreeBSD'|'OpenBSD')
++ 'OpenBSD')
+ pkgs=$(pkg_info | wc -l | awk '{sub(" ", "");print $1}')
+ if type -p portmaster >/dev/null 2>&1; then
+ ports=$(portmaster -l | grep -Eo '[0-9]+ total installed' | sed 's/ total installed//')
+ pkgs=$((${pkgs} + ${ports}))
+ fi
+ ;;
++ 'FreeBSD')
++ pkgs=$(pkg info |wc -l|awk '{print $1}' || pkg_info | wc -l | awk '{sub(" ", "");print $1}')
++ ;;
+ 'Cygwin') cygfix=2; pkgs=$(($(cygcheck -cd | wc -l)-$cygfix)) ;;
+ esac
+ [[ "$verbosity" -eq "1" ]] && verboseOut "Finding current package count...found as '$pkgs'"
diff --git a/sysutils/screenfetch/pkg-descr b/sysutils/screenfetch/pkg-descr
new file mode 100644
index 000000000000..f76f2cb71769
--- /dev/null
+++ b/sysutils/screenfetch/pkg-descr
@@ -0,0 +1,10 @@
+screenFetch is a "Bash Screenshot Information Tool". This handy Bash script can
+be used to generate one of those nifty terminal theme information + ASCII
+distribution logos you see in everyone's screenshots nowadays. It will
+auto-detect your distribution and display an ASCII version of that
+distribution's logo and some valuable information to the right. There are
+options to specify no ascii art, colors, taking a screenshot upon displaying
+info, and even customizing the screenshot command! This script is very easy to
+add to and can easily be extended.
+
+WWW: https://github.com/KittyKatt/screenFetch