aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Glib-Object-Introspection/Makefile31
-rw-r--r--devel/p5-Glib-Object-Introspection/distinfo2
-rw-r--r--devel/p5-Glib-Object-Introspection/pkg-descr5
-rw-r--r--devel/p5-Glib-Object-Introspection/pkg-plist12
5 files changed, 51 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ae9d2762dfa4..98059788091d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1795,6 +1795,7 @@
SUBDIR += p5-Git-PurePerl
SUBDIR += p5-Git-Repository
SUBDIR += p5-Git-Wrapper
+ SUBDIR += p5-Glib-Object-Introspection
SUBDIR += p5-Glib2
SUBDIR += p5-Gnome2-GConf
SUBDIR += p5-Goo-Canvas
diff --git a/devel/p5-Glib-Object-Introspection/Makefile b/devel/p5-Glib-Object-Introspection/Makefile
new file mode 100644
index 000000000000..6d06ecfdcd3a
--- /dev/null
+++ b/devel/p5-Glib-Object-Introspection/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Glib-Object-Introspection
+# Date created: 2011-10-15
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Glib-Object-Introspection
+PORTVERSION= 0.003
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Dynamically create Perl language bindings
+
+BUILD_DEPENDS= gobject-introspection>=0.10.0:${PORTSDIR}/devel/gobject-introspection \
+ p5-ExtUtils-Depends>=0.300:${PORTSDIR}/devel/p5-ExtUtils-Depends \
+ p5-ExtUtils-PkgConfig>=1:${PORTSDIR}/devel/p5-ExtUtils-PkgConfig \
+ p5-Glib2>=1.240:${PORTSDIR}/devel/p5-Glib2
+RUN_DEPENDS= gobject-introspection>=0.10.0:${PORTSDIR}/devel/gobject-introspection \
+ p5-Glib2>=1.240:${PORTSDIR}/devel/p5-Glib2
+
+PERL_CONFIGURE= yes
+
+MAN3= Glib::Object::Introspection.3
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|gcc -shared -g|& -fPIC|' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Glib-Object-Introspection/distinfo b/devel/p5-Glib-Object-Introspection/distinfo
new file mode 100644
index 000000000000..1c7d7618d156
--- /dev/null
+++ b/devel/p5-Glib-Object-Introspection/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Glib-Object-Introspection-0.003.tar.gz) = 4543a347ac08647f4c0b07e7df3e6497cba15eb24586698a63a52559680bc4a8
+SIZE (Glib-Object-Introspection-0.003.tar.gz) = 46150
diff --git a/devel/p5-Glib-Object-Introspection/pkg-descr b/devel/p5-Glib-Object-Introspection/pkg-descr
new file mode 100644
index 000000000000..18431952b7b7
--- /dev/null
+++ b/devel/p5-Glib-Object-Introspection/pkg-descr
@@ -0,0 +1,5 @@
+Glib::Object::Introspection uses the gobject-introspection and libffi projects
+to dynamically create Perl bindings for a wide variety of libraries. Examples
+include gtk+, webkit, libsoup and many more.
+
+WWW: http://search.cpan.org/dist/Glib-Object-Introspection/
diff --git a/devel/p5-Glib-Object-Introspection/pkg-plist b/devel/p5-Glib-Object-Introspection/pkg-plist
new file mode 100644
index 000000000000..c098a557f8ed
--- /dev/null
+++ b/devel/p5-Glib-Object-Introspection/pkg-plist
@@ -0,0 +1,12 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Glib/Object/Introspection.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Glib/Object/Introspection/Install/Files.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Glib/Object/Introspection/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Glib/Object/Introspection/Introspection.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Glib/Object/Introspection/Introspection.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Glib/Object/Introspection
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Glib/Object
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Glib
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Glib/Object/Introspection/Install
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Glib/Object/Introspection
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Glib/Object
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Glib