aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/gqmpeg/Makefile9
-rw-r--r--audio/soundtracker/Makefile16
-rw-r--r--deskutils/gaddr/Makefile9
-rw-r--r--editors/gnotepad+/Makefile9
-rw-r--r--ftp/gftp/Makefile8
-rw-r--r--ftp/gftp/pkg-plist2
-rw-r--r--games/xpuyopuyo/Makefile10
-rw-r--r--graphics/jumpgis/Makefile13
-rw-r--r--graphics/jumpgis/pkg-plist3
-rw-r--r--japanese/nethack34/Makefile6
-rw-r--r--x11/metisse/Makefile4
11 files changed, 11 insertions, 78 deletions
diff --git a/audio/gqmpeg/Makefile b/audio/gqmpeg/Makefile
index e9f584861aa6..3522e23fbc2f 100644
--- a/audio/gqmpeg/Makefile
+++ b/audio/gqmpeg/Makefile
@@ -24,8 +24,8 @@ RUN_DEPENDS+= mpg123:${PORTSDIR}/audio/mpg123
USE_GNOME= gdkpixbuf
NO_STAGE= yes
USES= gettext
-WANT_GNOME= yes
USE_AUTOTOOLS= autoconf213 libtool
+CONFIGURE_ENV+= USE_GNOME=""
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
LDFLAGS+= -L${LOCALBASE}/lib -lintl
@@ -34,13 +34,6 @@ MAN1= gqmpeg.1
.include <bsd.port.pre.mk>
-.if ${HAVE_GNOME:Mgnomelibs}!=""
-USE_GNOME+= gnomeprefix gnomelibs
-CONFIGURE_ENV+= USE_GNOME="yes"
-.else
-CONFIGURE_ENV+= USE_GNOME=""
-.endif
-
.if !defined(WITH_MPG321)
pre-everything::
@${ECHO_MSG}
diff --git a/audio/soundtracker/Makefile b/audio/soundtracker/Makefile
index 68d4005a3879..8ac8031180f5 100644
--- a/audio/soundtracker/Makefile
+++ b/audio/soundtracker/Makefile
@@ -4,7 +4,7 @@
PORTNAME= soundtracker
PORTVERSION= 0.6.8
PORTREVISION= 14
-CATEGORIES= audio gnome
+CATEGORIES= audio
MASTER_SITES= http://www.soundtracker.org/dl/%SUBDIR%/
MASTER_SITE_SUBDIR= v${PORTVERSION:R}
@@ -13,7 +13,7 @@ COMMENT= Mod player/tracking tool which supports XM and MOD formats
LICENSE= GPLv2
-LIB_DEPENDS= sndfile:${PORTSDIR}/audio/libsndfile
+LIB_DEPENDS= libsndfile.so:${PORTSDIR}/audio/libsndfile
GNU_CONFIGURE= yes
USES= pathfix pkgconfig
@@ -23,11 +23,12 @@ USE_GNOME= esound gdkpixbuf
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS_DEFINE= GNOME1 JACK SDL NLS
+OPTIONS_DEFINE= JACK SDL NLS
OPTIONS_DEFINE_i386= ASM
-GNOME1_DESC= Use GNOME 1.x (enables envelope editing)
ASM_DESC= Use optimized assembly (potentially unstable)
+CONFIGURE_ARGS+= --disable-gnome
+
DESKTOP_ENTRIES="SoundTracker" "Pattern-oriented music editor" \
"${PREFIX}/share/pixmaps/${PORTNAME}.xpm" \
"soundtracker" "AudioVideo;Audio;AudioVideoEditing;" false
@@ -38,13 +39,6 @@ DESKTOP_ENTRIES="SoundTracker" "Pattern-oriented music editor" \
CONFIGURE_ARGS+= --enable-asm
.endif
-.if ${PORT_OPTIONS:MGNOME}
-USE_GNOME+= gnomelibs gnomeprefix
-CONFIGURE_ARGS+= --enable-gnome
-.else
-CONFIGURE_ARGS+= --disable-gnome
-.endif
-
.if ${PORT_OPTIONS:MJACK}
LIB_DEPENDS+= jack:${PORTSDIR}/audio/jack
.else
diff --git a/deskutils/gaddr/Makefile b/deskutils/gaddr/Makefile
index fe42d025218b..882be8b6a825 100644
--- a/deskutils/gaddr/Makefile
+++ b/deskutils/gaddr/Makefile
@@ -14,16 +14,7 @@ COMMENT= GTK 1.x address book
PLIST_FILES= bin/gaddr
GNU_CONFIGURE= yes
USE_GNOME= gtk12
-WANT_GNOME= yes
MAKE_ARGS+= PREFIX="${STAGEDIR}${PREFIX}"
-.include <bsd.port.pre.mk>
-
-.if ${HAVE_GNOME:Mgnomelibs}!=""
-USE_GNOME+= gnomelibs
-PKGNAMESUFFIX= -gnome
-CONFIGURE_ARGS+=--enable-gnome
-.endif
-
.include <bsd.port.post.mk>
diff --git a/editors/gnotepad+/Makefile b/editors/gnotepad+/Makefile
index 2d6ccc777331..f9fb3cb6ce6d 100644
--- a/editors/gnotepad+/Makefile
+++ b/editors/gnotepad+/Makefile
@@ -26,6 +26,8 @@ GNU_CONFIGURE= yes
MAN1= gnp.1
+CONFIGURE_ARGS= --disable-gnome
+
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -34,13 +36,6 @@ DOCVERSION= 1.2.0
NO_STAGE= yes
.include <bsd.port.pre.mk>
-.if ${HAVE_GNOME:Mgnomelibs}!=""
-USE_GNOME+= gnomelibs
-PKGNAMESUFFIX= -gnome
-.else
-CONFIGURE_ARGS+=--disable-gnome
-.endif
-
.if defined(NOPORTDOCS)
PLIST_SUB+= NOPORTDOCS=""
.else
diff --git a/ftp/gftp/Makefile b/ftp/gftp/Makefile
index 68993f649e2f..878540a5c5bc 100644
--- a/ftp/gftp/Makefile
+++ b/ftp/gftp/Makefile
@@ -57,14 +57,6 @@ PLIST_SUB+= NLS="@comment "
.include <bsd.port.pre.mk>
-.if ${HAVE_GNOME:Mgnomelibs}!="" && ! ${PORT_OPTIONS:MGTK2}
-USE_GNOME+= gnomeprefix gnomelibs
-PLIST_SUB+= MYGNOME=""
-MAKE_ENV= HAVE_GNOME=1
-.else
-PLIST_SUB+= MYGNOME="@comment "
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
diff --git a/ftp/gftp/pkg-plist b/ftp/gftp/pkg-plist
index 578f0e591a51..2b2a37302ae5 100644
--- a/ftp/gftp/pkg-plist
+++ b/ftp/gftp/pkg-plist
@@ -1,7 +1,6 @@
bin/gftp
%%NOX11:%%bin/gftp-gtk
bin/gftp-text
-%%NOX11:%%%%MYGNOME%%share/applications/gftp.desktop
%%NOX11:%%%%DATADIR%%/COPYING
%%NOX11:%%%%DATADIR%%/bookmarks
%%NOX11:%%%%DATADIR%%/connect.xpm
@@ -89,7 +88,6 @@ bin/gftp-text
%%NLS%%share/locale/zh_CN/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/zh_HK/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/gftp.mo
-%%NOX11:%%%%MYGNOME%%share/pixmaps/gftp.png
%%NOX11:%%@dirrm %%DATADIR%%
@dirrmtry share/applications
@dirrmtry share/locale/dz/LC_MESSAGES
diff --git a/games/xpuyopuyo/Makefile b/games/xpuyopuyo/Makefile
index a8b8f4b14e4a..02131354af4b 100644
--- a/games/xpuyopuyo/Makefile
+++ b/games/xpuyopuyo/Makefile
@@ -22,6 +22,8 @@ OPTIONS_DEFINE= MIKMOD ROTATE_FIXED AIBREED
ROTATE_FIXED_DESC= Fix position of one blob during rotation
AIBREED_DESC= Allow AI breeding
+CONFIGURE_ARGS+= --without-gnome
+
NO_STAGE= yes
.include <bsd.port.pre.mk>
@@ -30,14 +32,6 @@ LIB_DEPENDS+= mikmod.2:${PORTSDIR}/audio/libmikmod
CONFIGURE_ARGS+=--with-libmikmod-prefix=${LOCALBASE}
.endif
-.if ${HAVE_GNOME:Mgnomelibs}!=""
-USES= pathfix
-USE_GNOME+= gnomelibs
-PKGNAMESUFFIX= -gnome
-.else
-CONFIGURE_ARGS+= --without-gnome
-.endif
-
.if ${PORT_OPTIONS:MROTATE_FIXED}
CONFIGURE_ARGS+=--enable-rotate-fixed
.endif
diff --git a/graphics/jumpgis/Makefile b/graphics/jumpgis/Makefile
index 86c56b44d019..3a8be762da69 100644
--- a/graphics/jumpgis/Makefile
+++ b/graphics/jumpgis/Makefile
@@ -22,7 +22,6 @@ USE_JAVA= yes
JAVA_VERSION= 1.6+
USE_ZIP= yes
NO_BUILD= yes
-WANT_GNOME= yes
PORTDOCS= *
REINPLACE_ARGS= -i ""
@@ -30,12 +29,6 @@ REINPLACE_ARGS= -i ""
NO_STAGE= yes
.include <bsd.port.pre.mk>
-.if ${HAVE_GNOME:Mgnomelibs}!=""
-PLIST_SUB+= GNOMELINKS=""
-.else
-PLIST_SUB+= GNOMELINKS="@comment "
-.endif
-
post-patch:
@${REINPLACE_CMD} -e "s,#!sh,#!/bin/sh,g" \
-e "s,^LIB=../lib,LIB=${TARGET_DIR}/lib,g" \
@@ -58,10 +51,4 @@ do-install:
@${ECHO_MSG} "---> Skipping documentation"
.endif
-.if ${HAVE_GNOME:Mgnomelibs}!=""
- @${ECHO_MSG} "---> Installing GNOME application links"
- ${INSTALL_DATA} ${DISTDIR}/jump.desktop ${LOCALBASE}/share/applications/
- ${INSTALL_DATA} ${DISTDIR}/jump.png ${LOCALBASE}/share/pixmaps/
-.endif
-
.include <bsd.port.post.mk>
diff --git a/graphics/jumpgis/pkg-plist b/graphics/jumpgis/pkg-plist
index 1d15e98caedd..3992b4fdb373 100644
--- a/graphics/jumpgis/pkg-plist
+++ b/graphics/jumpgis/pkg-plist
@@ -7,10 +7,7 @@ jumpgis/lib/jump-1.1.2.jar
jumpgis/lib/junit.jar
jumpgis/lib/xercesImpl.jar
jumpgis/lib/xml-apis.jar
-%%GNOMELINKS%%share/applications/jump.desktop
-%%GNOMELINKS%%share/pixmaps/jump.png
@exec mkdir -p %D/jumpgis/lib/ext
@dirrm jumpgis/lib/ext
@dirrm jumpgis/lib
@dirrm jumpgis
-%%GNOMELINKS%%@dirrmtry share/applications
diff --git a/japanese/nethack34/Makefile b/japanese/nethack34/Makefile
index d98e3f7e2974..93954c21f470 100644
--- a/japanese/nethack34/Makefile
+++ b/japanese/nethack34/Makefile
@@ -36,11 +36,7 @@ HACKDOCSDIR?= share/doc/ja/nethack
USE_XORG= xaw xpm
GRAPHICS= X11_GRAPHICS
.else
-.if ${PKGNAMESUFFIX} == "-gnome"
-CATEGORIES+= gnome
-USE_GNOME= gnomelibs
-GRAPHICS= GNOME_GRAPHICS
-.elif ${PKGNAMESUFFIX} == "-nox11"
+.if ${PKGNAMESUFFIX} == "-nox11"
GRAPHICS= # none
.endif
.endif
diff --git a/x11/metisse/Makefile b/x11/metisse/Makefile
index ecec1558338b..5077bbb81a62 100644
--- a/x11/metisse/Makefile
+++ b/x11/metisse/Makefile
@@ -101,10 +101,6 @@ USE_GNOME+= gtk12
USE_GNOME+= imlib
.endif
-.if ${HAVE_GNOME:Mgnomelibs} || ${PORT_OPTIONS:MGNOME}
-USE_GNOME+= gnomelibs
-.endif
-
MAN1= FvwmAnimate.1 FvwmAuto.1 FvwmBacker.1 FvwmBanner.1 FvwmButtons.1 \
FvwmCommand.1 FvwmConsole.1 FvwmConsoleC.pl.1 FvwmCpp.1 FvwmDebug.1 \
FvwmDragWell.1 FvwmEvent.1 FvwmForm.1 FvwmGtkDebug.1 FvwmIconBox.1 \