aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.gstreamer.mk26
-rw-r--r--multimedia/Makefile3
-rw-r--r--multimedia/gstreamer-plugins-all/Makefile1
-rw-r--r--multimedia/gstreamer-plugins-bad/Makefile6
-rw-r--r--multimedia/gstreamer-plugins-bad/files/patch-sys_dvb_gstdvbsrc.c10
-rw-r--r--multimedia/gstreamer-plugins-bad/pkg-plist18
-rw-r--r--multimedia/gstreamer-plugins-resindvd/Makefile17
-rw-r--r--multimedia/gstreamer-plugins-schroedinger/Makefile17
-rw-r--r--multimedia/gstreamer-plugins-vp8/Makefile17
-rw-r--r--multimedia/gstreamer-plugins/Makefile7
-rw-r--r--multimedia/gstreamer-plugins/Makefile.common79
-rw-r--r--multimedia/gstreamer-plugins/distinfo6
-rw-r--r--x11/Makefile1
-rw-r--r--x11/gstreamer-plugins-vdpau/Makefile17
14 files changed, 205 insertions, 20 deletions
diff --git a/Mk/bsd.gstreamer.mk b/Mk/bsd.gstreamer.mk
index 269ebcc9ffd7..f26dbbf9b8c5 100644
--- a/Mk/bsd.gstreamer.mk
+++ b/Mk/bsd.gstreamer.mk
@@ -53,13 +53,15 @@ GST_SHLIB_VERSION= 1
#
# These are the current supported gstreamer-plugins modules
#
-_USE_GSTREAMER10_ALL= a52dec aalib amrnb amrwbdec annodex bz2 cairo cdaudio cdparanoia dts \
- dv dvd esound faac faad ffmpeg flac gconf gio gl gnomevfs \
- gnonlin gsm hal jack jpeg ladspa lame \
- libcaca libmms libpng libvisual mm mp3 mpeg2enc mpeg2dec \
- musepack nas neon ogg pango pulse python sdl shout2 sidplay \
- sndfile spc soundtouch soup speex taglib \
- theora twolame v4l2 vorbis wavpack x264 xvid
+_USE_GSTREAMER10_ALL= a52dec aalib amrnb amrwbdec annodex bz2 cairo \
+ cdaudio cdparanoia dts dv dvd esound faac faad \
+ ffmpeg flac gconf gio gl gnomevfs gnonlin \
+ gsm hal jack jpeg ladspa lame libcaca libmms \
+ libpng libvisual mm mp3 mpeg2enc mpeg2dec musepack \
+ nas neon ogg pango pulse python resindvd schroedinger \
+ sdl shout2 sidplay sndfile spc soundtouch soup \
+ speex taglib theora twolame v4l2 vorbis vdpau \
+ vp8 wavpack x264 xvid
# other plugins
OTHER_GSTREAMER_PLUGINS+=bad good ugly core yes ${_USE_GSTREAMER10_ALL} fluendo-mp3 mad
@@ -222,6 +224,8 @@ mplex_DEPENDS= multimedia/gstreamer-plugins-mplex
v4l2_DEPENDS= multimedia/gstreamer-plugins-v4l2
+vp8_DEPENDS= multimedia/gstreamer-plugins-vp8
+
# XXX: This is a quick solution for ports with USE_GSTREAMER=python
# but without USE_PYTHON.
PYTHON_PKGNAMEPREFIX?= py*-
@@ -232,6 +236,10 @@ python_GST_PREFIX= ${PYTHON_PKGNAMEPREFIX}
python_GST_SUFX= # empty
python_GST_VERSION= 0.10.4
+resindvd_DEPENDS= multimedia/gstreamer-plugins-resindvd
+
+schroedinger_DEPENDS= multimedia/gstreamer-plugins-schroedinger
+
theora_DEPENDS= multimedia/gstreamer-plugins-theora
ugly_DEPENDS= multimedia/gstreamer-plugins-ugly
@@ -244,6 +252,10 @@ xvid_DEPENDS= multimedia/gstreamer-plugins-xvid
libmms_DEPENDS= net/gstreamer-plugins-libmms
+# X11 Plugin Section
+
+vdpau_DEPENDS= x11/gstreamer-plugins-vdpau
+
# X11-Toolkits Plugins Section
pango_DEPENDS= x11-toolkits/gstreamer-plugins-pango
diff --git a/multimedia/Makefile b/multimedia/Makefile
index ffb16efb53ce..f33863d5e38c 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -105,9 +105,12 @@
SUBDIR += gstreamer-plugins-good
SUBDIR += gstreamer-plugins-mpeg2dec
SUBDIR += gstreamer-plugins-mpeg2enc
+ SUBDIR += gstreamer-plugins-resindvd
+ SUBDIR += gstreamer-plugins-schroedinger
SUBDIR += gstreamer-plugins-theora
SUBDIR += gstreamer-plugins-ugly
SUBDIR += gstreamer-plugins-v4l2
+ SUBDIR += gstreamer-plugins-vp8
SUBDIR += gstreamer-plugins-x264
SUBDIR += gstreamer-plugins-xvid
SUBDIR += gstreamermm
diff --git a/multimedia/gstreamer-plugins-all/Makefile b/multimedia/gstreamer-plugins-all/Makefile
index 1ba42423149d..f3aef2b2ad9c 100644
--- a/multimedia/gstreamer-plugins-all/Makefile
+++ b/multimedia/gstreamer-plugins-all/Makefile
@@ -29,6 +29,7 @@ WITHOUT_FAAC= yes # Mp4 Dolby license , no package
WITHOUT_LAME= yes # MP3 License , no package
WITHOUT_SWFDEC= yes # Broken
WITHOUT_MPEG2ENC= yes # Broken
+WITHOUT_VDPAU= yes # Needs to be build agains running kernel
.endif
.if ${ARCH}!="i386"
WITHOUT_SPC= yes # i386 only
diff --git a/multimedia/gstreamer-plugins-bad/Makefile b/multimedia/gstreamer-plugins-bad/Makefile
index 86cded2b81bc..f7b1cafc17a6 100644
--- a/multimedia/gstreamer-plugins-bad/Makefile
+++ b/multimedia/gstreamer-plugins-bad/Makefile
@@ -6,7 +6,7 @@
# $MCom: ports/multimedia/gstreamer-plugins-bad/Makefile,v 1.11 2008/03/19 14:05:35 ahze Exp $
#
-PORTREVISION= 1
+PORTREVISION= 0
CATEGORIES= multimedia
COMMENT= Bad gstreamer-plugins
@@ -16,8 +16,8 @@ GST_PLUGIN_SUFFIX= -bad
MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
-BUILD_DEPENDS+= gstreamer-plugins>=${GST_VERSION}${GST_MINOR_VERSION}:${PORTSDIR}/multimedia/gstreamer-plugins
-LIB_DEPENDS+= oil-0.3.0:${PORTSDIR}/devel/liboil
+BUILD_DEPENDS+= gstreamer-plugins>=${GST_VERSION}${GST_MINOR_VERSION}:${PORTSDIR}/multimedia/gstreamer-plugins \
+ v4l_compat>=1.0.20100321:${PORTSDIR}/multimedia/v4l_compat
RUN_DEPENDS+= gstreamer-plugins>=${GST_VERSION}${GST_MINOR_VERSION}:${PORTSDIR}/multimedia/gstreamer-plugins
gst_bad_DIST= bad
diff --git a/multimedia/gstreamer-plugins-bad/files/patch-sys_dvb_gstdvbsrc.c b/multimedia/gstreamer-plugins-bad/files/patch-sys_dvb_gstdvbsrc.c
new file mode 100644
index 000000000000..a6352fff5a0f
--- /dev/null
+++ b/multimedia/gstreamer-plugins-bad/files/patch-sys_dvb_gstdvbsrc.c
@@ -0,0 +1,10 @@
+--- ./sys/dvb/gstdvbsrc.c.orig 2010-09-07 18:04:03.000000000 +0200
++++ ./sys/dvb/gstdvbsrc.c 2010-09-07 18:04:12.000000000 +0200
+@@ -45,7 +45,6 @@
+ #include <sys/ioctl.h>
+ #include <sys/poll.h>
+ #include <fcntl.h>
+-#include <error.h>
+ #include <errno.h>
+ #include <stdio.h>
+ #include <stdlib.h>
diff --git a/multimedia/gstreamer-plugins-bad/pkg-plist b/multimedia/gstreamer-plugins-bad/pkg-plist
index f3fcfe179526..c24c5e5d77de 100644
--- a/multimedia/gstreamer-plugins-bad/pkg-plist
+++ b/multimedia/gstreamer-plugins-bad/pkg-plist
@@ -24,6 +24,8 @@ lib/gstreamer-%%VERSION%%/libgstcamerabin.la
lib/gstreamer-%%VERSION%%/libgstcamerabin.so
lib/gstreamer-%%VERSION%%/libgstcdxaparse.la
lib/gstreamer-%%VERSION%%/libgstcdxaparse.so
+lib/gstreamer-%%VERSION%%/libgstcoloreffects.la
+lib/gstreamer-%%VERSION%%/libgstcoloreffects.so
lib/gstreamer-%%VERSION%%/libgstdataurisrc.la
lib/gstreamer-%%VERSION%%/libgstdataurisrc.so
lib/gstreamer-%%VERSION%%/libgstdccp.la
@@ -32,6 +34,8 @@ lib/gstreamer-%%VERSION%%/libgstdebugutilsbad.la
lib/gstreamer-%%VERSION%%/libgstdebugutilsbad.so
lib/gstreamer-%%VERSION%%/libgstdtmf.la
lib/gstreamer-%%VERSION%%/libgstdtmf.so
+lib/gstreamer-%%VERSION%%/libgstdvb.la
+lib/gstreamer-%%VERSION%%/libgstdvb.so
lib/gstreamer-%%VERSION%%/libgstdvdspu.la
lib/gstreamer-%%VERSION%%/libgstdvdspu.so
lib/gstreamer-%%VERSION%%/libgstfestival.la
@@ -40,6 +44,10 @@ lib/gstreamer-%%VERSION%%/libgstfreeze.la
lib/gstreamer-%%VERSION%%/libgstfreeze.so
lib/gstreamer-%%VERSION%%/libgstfrei0r.la
lib/gstreamer-%%VERSION%%/libgstfrei0r.so
+lib/gstreamer-%%VERSION%%/libgstgaudieffects.la
+lib/gstreamer-%%VERSION%%/libgstgaudieffects.so
+lib/gstreamer-%%VERSION%%/libgstgeometrictransform.la
+lib/gstreamer-%%VERSION%%/libgstgeometrictransform.so
lib/gstreamer-%%VERSION%%/libgsth264parse.la
lib/gstreamer-%%VERSION%%/libgsth264parse.so
lib/gstreamer-%%VERSION%%/libgsthdvparse.la
@@ -48,6 +56,8 @@ lib/gstreamer-%%VERSION%%/libgstid3tag.la
lib/gstreamer-%%VERSION%%/libgstid3tag.so
lib/gstreamer-%%VERSION%%/libgstinvtelecine.la
lib/gstreamer-%%VERSION%%/libgstinvtelecine.so
+lib/gstreamer-%%VERSION%%/libgstivfparse.la
+lib/gstreamer-%%VERSION%%/libgstivfparse.so
lib/gstreamer-%%VERSION%%/libgstjpegformat.la
lib/gstreamer-%%VERSION%%/libgstjpegformat.so
lib/gstreamer-%%VERSION%%/libgstlegacyresample.la
@@ -95,6 +105,8 @@ lib/gstreamer-%%VERSION%%/libgstsegmentclip.la
lib/gstreamer-%%VERSION%%/libgstsegmentclip.so
lib/gstreamer-%%VERSION%%/libgstselector.la
lib/gstreamer-%%VERSION%%/libgstselector.so
+lib/gstreamer-%%VERSION%%/libgstshm.la
+lib/gstreamer-%%VERSION%%/libgstshm.so
lib/gstreamer-%%VERSION%%/libgstsiren.la
lib/gstreamer-%%VERSION%%/libgstsiren.so
lib/gstreamer-%%VERSION%%/libgstspeed.la
@@ -107,6 +119,8 @@ lib/gstreamer-%%VERSION%%/libgsttta.la
lib/gstreamer-%%VERSION%%/libgsttta.so
lib/gstreamer-%%VERSION%%/libgstvalve.la
lib/gstreamer-%%VERSION%%/libgstvalve.so
+lib/gstreamer-%%VERSION%%/libgstvideomaxrate.la
+lib/gstreamer-%%VERSION%%/libgstvideomaxrate.so
lib/gstreamer-%%VERSION%%/libgstvideomeasure.la
lib/gstreamer-%%VERSION%%/libgstvideomeasure.so
lib/gstreamer-%%VERSION%%/libgstvideosignal.la
@@ -132,11 +146,13 @@ share/locale/ca/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/cs/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/da/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/de/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
+share/locale/el/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/en_GB/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/es/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/eu/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/fi/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/fr/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
+share/locale/gl/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/hu/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/id/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/it/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
@@ -150,8 +166,10 @@ share/locale/nl/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/or/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/pl/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/pt_BR/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
+share/locale/ro/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/ru/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/sk/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
+share/locale/sl/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/sq/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/sr/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/sv/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
diff --git a/multimedia/gstreamer-plugins-resindvd/Makefile b/multimedia/gstreamer-plugins-resindvd/Makefile
new file mode 100644
index 000000000000..75002309020d
--- /dev/null
+++ b/multimedia/gstreamer-plugins-resindvd/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: gstreamer-plugins-resindvd
+# Date created: 10 Sep 2010
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+CATEGORIES= multimedia
+
+COMMENT= Gstreamer resindvd plugin
+
+GST_PLUGIN= resindvd
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
+
+.include "${MASTERDIR}/Makefile"
diff --git a/multimedia/gstreamer-plugins-schroedinger/Makefile b/multimedia/gstreamer-plugins-schroedinger/Makefile
new file mode 100644
index 000000000000..92b2d534a61e
--- /dev/null
+++ b/multimedia/gstreamer-plugins-schroedinger/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: gstreamer-plugins-schroedinger
+# Date created: 10 Sep 2010
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+CATEGORIES= multimedia
+
+COMMENT= Gstreamer Dirac high-speed codec plugin
+
+GST_PLUGIN= schroedinger
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
+
+.include "${MASTERDIR}/Makefile"
diff --git a/multimedia/gstreamer-plugins-vp8/Makefile b/multimedia/gstreamer-plugins-vp8/Makefile
new file mode 100644
index 000000000000..4e55b5aa4e15
--- /dev/null
+++ b/multimedia/gstreamer-plugins-vp8/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: gstreamer-plugins-vp8
+# Date created: 10 Sep 2010
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+CATEGORIES= multimedia
+
+COMMENT= Gstreamer vp8 codec plugin
+
+GST_PLUGIN= vp8
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
+
+.include "${MASTERDIR}/Makefile"
diff --git a/multimedia/gstreamer-plugins/Makefile b/multimedia/gstreamer-plugins/Makefile
index 1bb9fbe19c63..6e146a9d48ee 100644
--- a/multimedia/gstreamer-plugins/Makefile
+++ b/multimedia/gstreamer-plugins/Makefile
@@ -33,7 +33,7 @@ CFLAGS:= ${CFLAGS} -O2 -Wno-format
BASE_PORTVERSION= 0.10.30
BASE_DISTNAME= gst-plugins-base-${BASE_PORTVERSION}
BASE_DISTFILE= ${BASE_DISTNAME}${EXTRACT_SUFX}
-BAD_PORTVERSION= 0.10.19
+BAD_PORTVERSION= 0.10.20
BAD_DISTNAME= gst-plugins-bad-${BAD_PORTVERSION}
BAD_DISTFILE= ${BAD_DISTNAME}${EXTRACT_SUFX}
GOOD_PORTVERSION= 0.10.25
@@ -133,12 +133,12 @@ post-patch:
s|$$(top_builddir)/gst-libs/gst/audio/libgstaudio-$$(GST_MAJORMINOR).la|${LOCALBASE}/lib/libgstaudio-@GST_MAJORMINOR@.la|; \
s|$$(top_builddir)/gst-libs/gst/riff/libgstriff-$$(GST_MAJORMINOR).la|${LOCALBASE}/lib/libgstriff-@GST_MAJORMINOR@.la|; \
s|$$(top_builddir)/gst-libs/gst/signalprocessor/libgstsignalprocessor-$$(GST_MAJORMINOR).la|${LOCALBASE}/lib/libgstsignalprocessor-@GST_MAJORMINOR@.la|; \
+ s|$$(top_builddir)/gst-libs/gst/video/libgstbasevideo-$$(GST_MAJORMINOR).la|${LOCALBASE}/lib/libgstbasevideo-@GST_MAJORMINOR@.la|; \
s|$$(top_builddir)/gst-libs/gst/video/libgstvideo-$$(GST_MAJORMINOR).la|${LOCALBASE}/lib/libgstvideo-@GST_MAJORMINOR@.la|; \
s|$$(top_builddir)/gst-libs/gst/cdda/libgstcdda-$$(GST_MAJORMINOR).la|${LOCALBASE}/lib/libgstcdda-@GST_MAJORMINOR@.la|'
@${FIND} ${WRKSRC} -type f | \
${XARGS} -n 10 ${REINPLACE_CMD} -e \
- 's|malloc\.h|stdlib.h|; \
- s|<stdint\.h|<inttypes.h|; \
+ 's|<stdint\.h|<inttypes.h|; \
s|%%VERSION%%|${VERSION}|'
@${FIND} ${WRKSRC}/ext -name Makefile.in | \
${XARGS} -n 10 ${REINPLACE_CMD} -e \
@@ -146,6 +146,7 @@ post-patch:
s|$$(top_builddir)/gst-libs/gst/audio/libgstaudio-@GST_MAJORMINOR@.la|${LOCALBASE}/lib/libgstaudio-@GST_MAJORMINOR@.la|; \
s|$$(top_builddir)/gst-libs/gst/riff/libgstriff-@GST_MAJORMINOR@.la|${LOCALBASE}/lib/libgstriff-@GST_MAJORMINOR@.la|; \
s|$$(top_builddir)/gst-libs/gst/signalprocessor/libgstsignalprocessor-@GST_MAJORMINOR@.la|${LOCALBASE}/lib/libgstsignalprocessor-@GST_MAJORMINOR@.la|; \
+ s|$$(top_builddir)/gst-libs/gst/video/libgstbasevideo-@GST_MAJORMINOR@.la|${LOCALBASE}/lib/libgstbasevideo-@GST_MAJORMINOR@.la|; \
s|$$(top_builddir)/gst-libs/gst/video/libgstvideo-@GST_MAJORMINOR@.la|${LOCALBASE}/lib/libgstvideo-@GST_MAJORMINOR@.la|; \
s|$$(top_builddir)/gst-libs/gst/cdda/libgstcdda-@GST_MAJORMINOR@.la|${LOCALBASE}/lib/libgstcdda-@GST_MAJORMINOR@.la|'
@${REINPLACE_CMD} -e 's|DEFAULT_AUDIOSINK="alsasink"|DEFAULT_AUDIOSINK="${DEFAULT_AUDIOSINK}"|; \
diff --git a/multimedia/gstreamer-plugins/Makefile.common b/multimedia/gstreamer-plugins/Makefile.common
index 4e3ce689d327..ad25e13f03a8 100644
--- a/multimedia/gstreamer-plugins/Makefile.common
+++ b/multimedia/gstreamer-plugins/Makefile.common
@@ -26,8 +26,10 @@ BAD_GST_ALL_PLUGINS+= \
directfb \
divx \
dts \
+ exif \
faac \
faad \
+ flite \
gme \
gsm \
jack \
@@ -49,14 +51,17 @@ BAD_GST_ALL_PLUGINS+= \
ofa \
resindvd \
rsvg \
- schroedinger \
+ schro \
sdl \
+ shm \
sndfile \
soundtouch \
spc \
swfdec \
- theora \
+ theoradec \
timidity \
+ vdpau \
+ vp8 \
xvid \
zbar
@@ -116,10 +121,14 @@ CONFIGURE_ARGS+= --enable-${GST_PLUGIN}
CONFIGURE_ARGS+=--disable-tests \
--disable-examples \
- --disable-1394 \
+ --disable-cd1394 \
--disable-acm \
+ --disable-apexsink \
--disable-alsa \
- --disable-dvb \
+ --enable-cog \
+ --enable-dvb \
+ --disable-fbdev \
+ --disable-directfb \
--disable-http \
--enable-cdrom \
--disable-gconf \
@@ -132,13 +141,18 @@ CONFIGURE_ARGS+=--disable-tests \
--disable-directdrawsink \
--disable-directsoundsink \
--disable-tarkin \
+ --enable-shm \
--enable-static \
--disable-sunaudio \
+ --disable-wildmidi \
--disable-xine \
--enable-x \
--enable-xshm \
--enable-xvideo
+# we need glib 2.26 for this. (is from -bad)
+CONFIGURE_ARGS+=--disable-gsettings
+
.if !defined(NO_GSTREAMER_COMMON)
GST_PLUGIN_SUFFIX?= -${GST_PLUGIN}
@@ -146,6 +160,7 @@ GST_PLUGIN_SUFFIX?= -${GST_PLUGIN}
CONFIGURE_ARGS:=${CONFIGURE_ARGS:S|--disable-${GST_PLUGIN}|--enable-${GST_PLUGIN}|}
+GST_INC_DIR= include/gstreamer-${VERSION}
GST_LIB_DIR= lib/gstreamer-${VERSION}
# Auto create PLIST
@@ -240,6 +255,13 @@ gst_esound_CONFIGURE_ENV+= ESD_CFLAGS="`pkg-config --cflags esound`" \
gst_esound_PLIST_FILES= ${GST_LIB_DIR}/libgstesd.so \
${GST_LIB_DIR}/libgstesd.la
+# exif
+# hmm not a real plugin, seems to be part of metadata?
+#gst_exif_LIB_DEPENDS+= exif.12:${PORTSDIR}/graphics/libexif
+#gst_exif_PLIST_FILES= ${GST_LIB_DIR}/libgstexif.la \
+# ${GST_LIB_DIR}/libgstexif.so
+#gst_exif_DIST= bad
+
# faac
gst_faac_LIB_DEPENDS+= faac.0:${PORTSDIR}/audio/faac
gst_faac_PLIST_FILES= ${GST_LIB_DIR}/libgstfaac.la \
@@ -258,6 +280,12 @@ gst_flac_LIB_DEPENDS+= FLAC.10:${PORTSDIR}/audio/flac
gst_flac_PLIST_FILES= ${GST_LIB_DIR}/libgstflac.la \
${GST_LIB_DIR}/libgstflac.so
+# flite
+gst_flite_BUILD_DEPENDS+= ${LOCALBASE}/lib/libflite.a:${PORTSDIR}/audio/flite
+gst_flite_PLIST_FILES= ${GST_LIB_DIR}/libgstflite.la \
+ ${GST_LIB_DIR}/libgstflite.so
+gst_flite_DIST= bad
+
# gconf
gst_gconf_USE_GNOME+= gnomeprefix gconf2
gst_gconf_GST_PLUGIN_DIR= ext/gconf \
@@ -406,6 +434,13 @@ gst_pulse_PLIST_FILES= ${GST_LIB_DIR}/libgstpulse.la \
${GST_LIB_DIR}/libgstpulse.so
gst_pulse_DIST= good
+# resindvd
+gst_resindvd_BUILD_DEPENDS+= libdvdnav>=4.1.2:${PORTSDIR}/multimedia/libdvdnav
+gst_resindvd_RUN_DEPENDS+= libdvdnav>=4.1.2:${PORTSDIR}/multimedia/libdvdnav
+gst_resindvd_PLIST_FILES= ${GST_LIB_DIR}/libresindvd.la \
+ ${GST_LIB_DIR}/libresindvd.so
+gst_resindvd_DIST= bad
+
# sdl
gst_sdl_USE_SDL+= sdl
gst_sdl_PLIST_FILES= ${GST_LIB_DIR}/libgstsdl.la \
@@ -452,6 +487,13 @@ gst_speex_LIB_DEPENDS+= speex.1:${PORTSDIR}/audio/speex
gst_speex_PLIST_FILES= ${GST_LIB_DIR}/libgstspeex.la \
${GST_LIB_DIR}/libgstspeex.so
+# schro(edinger)
+gst_schroedinger_LIB_DEPENDS+= schroedinger-1.0.3:${PORTSDIR}/multimedia/schroedinger
+gst_schroedinger_CONFIGURE_ARGS+=--enable-schro
+gst_schroedinger_PLIST_FILES= ${GST_LIB_DIR}/libgstschro.la \
+ ${GST_LIB_DIR}/libgstschro.so
+gst_schroedinger_DIST= bad
+
# swfdec
gst_swfdec_LIB_DEPENDS+=swfdec-0.4.1:${PORTSDIR}/graphics/swfdec
gst_swfdec_DIST= bad
@@ -484,6 +526,28 @@ gst_gst_v4l2_CONFIGURE_ARGS+= --enable-gst_v4l2
gst_gst_v4l2_GST_PLUGIN_DIR=sys/v4l2
gst_gst_v4l2_DIST= good
+# vdpau
+gst_vdpau_LIB_DEPENDS+= vdpau.1:${PORTSDIR}/x11/nvidia-driver
+gst_vdpau_GST_PLUGIN_DIR=sys/vdpau
+gst_vdpau_PLIST_FILES= ${GST_INC_DIR}/gst/vdpau/gstvdp.h \
+ ${GST_INC_DIR}/gst/vdpau/gstvdpbuffer.h \
+ ${GST_INC_DIR}/gst/vdpau/gstvdpbufferpool.h \
+ ${GST_INC_DIR}/gst/vdpau/gstvdpdecoder.h \
+ ${GST_INC_DIR}/gst/vdpau/gstvdpdevice.h \
+ ${GST_INC_DIR}/gst/vdpau/gstvdpoutputbuffer.h \
+ ${GST_INC_DIR}/gst/vdpau/gstvdpoutputbufferpool.h \
+ ${GST_INC_DIR}/gst/vdpau/gstvdpoutputsrcpad.h \
+ ${GST_INC_DIR}/gst/vdpau/gstvdputils.h \
+ ${GST_INC_DIR}/gst/vdpau/gstvdpvideobuffer.h \
+ ${GST_INC_DIR}/gst/vdpau/gstvdpvideobufferpool.h \
+ ${GST_INC_DIR}/gst/vdpau/gstvdpvideosrcpad.h \
+ ${GST_LIB_DIR}/libgstvdpau.la \
+ ${GST_LIB_DIR}/libgstvdpau.so \
+ lib/libgstvdp-0.10.la \
+ lib/libgstvdp-0.10.so \
+ lib/libgstvdp-0.10.so.0
+gst_vdpau_DIST= bad
+
# vorbis
gst_vorbis_USE_GSTREAMER+= ogg
gst_vorbis_LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
@@ -492,6 +556,13 @@ gst_vorbis_PLIST_FILES= ${GST_LIB_DIR}/libgstvorbis.la \
${GST_LIB_DIR}/libgstvorbis.so
gst_vorbis_DIST= base
+# vp8
+gst_vp8_LIB_DEPENDS+= vpx.0:${PORTSDIR}/multimedia/libvpx
+gst_vp8_PLIST_FILES= ${GST_LIB_DIR}/libgstvp8.la \
+ ${GST_LIB_DIR}/libgstvp8.a \
+ ${GST_LIB_DIR}/libgstvp8.so
+gst_vp8_DIST= bad
+
# x264
gst_x264_LIB_DEPENDS+= x264.98:${PORTSDIR}/multimedia/x264
gst_x264_PLIST_FILES= ${GST_LIB_DIR}/libgstx264.la \
diff --git a/multimedia/gstreamer-plugins/distinfo b/multimedia/gstreamer-plugins/distinfo
index 2836805cb11c..b86d125d555c 100644
--- a/multimedia/gstreamer-plugins/distinfo
+++ b/multimedia/gstreamer-plugins/distinfo
@@ -1,9 +1,9 @@
MD5 (gst-plugins-base-0.10.30.tar.bz2) = 3ad90152b58563e1314af26c263f3c4c
SHA256 (gst-plugins-base-0.10.30.tar.bz2) = 63938641380be9935c804ae8d55acdcfd93920ed2deb72dcf70f027a78b085d7
SIZE (gst-plugins-base-0.10.30.tar.bz2) = 2455042
-MD5 (gst-plugins-bad-0.10.19.tar.bz2) = 368f72e2a1c7a6e8fe60394e4315259b
-SHA256 (gst-plugins-bad-0.10.19.tar.bz2) = 7b6c49f22caad3b573aee481381355b38ac9f2077f291d9f33a9a808a2568888
-SIZE (gst-plugins-bad-0.10.19.tar.bz2) = 3009513
+MD5 (gst-plugins-bad-0.10.20.tar.bz2) = 7c84766f6d24f41ba90c3f6141012ab8
+SHA256 (gst-plugins-bad-0.10.20.tar.bz2) = 1031dff866df976a957f34039addbab4c0753406299a275f4cf1780e1dbe2a90
+SIZE (gst-plugins-bad-0.10.20.tar.bz2) = 3209622
MD5 (gst-plugins-ugly-0.10.16.tar.bz2) = 989e1b0fab010f73f76912f70ec5f62a
SHA256 (gst-plugins-ugly-0.10.16.tar.bz2) = d7fc7636001e78736540c628ad889888cb85ea722f08d1c6813b16682dd9c09c
SIZE (gst-plugins-ugly-0.10.16.tar.bz2) = 1041297
diff --git a/x11/Makefile b/x11/Makefile
index bd01e46c0f12..a7e80dfbba78 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -125,6 +125,7 @@
SUBDIR += grabc
SUBDIR += gromit
SUBDIR += gskrab
+ SUBDIR += gstreamer-plugins-vdpau
SUBDIR += gsynaptics
SUBDIR += gtk-launch
SUBDIR += gtk-theme-switch
diff --git a/x11/gstreamer-plugins-vdpau/Makefile b/x11/gstreamer-plugins-vdpau/Makefile
new file mode 100644
index 000000000000..8454806312a3
--- /dev/null
+++ b/x11/gstreamer-plugins-vdpau/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: gstreamer-plugins-vdpau
+# Date created: 10 Sep 2010
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+CATEGORIES= x11
+
+COMMENT= Gstreamer nvidia vdpau plugin
+
+GST_PLUGIN= vdpau
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
+
+.include "${MASTERDIR}/Makefile"