aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/py-collective.templateengines/Makefile21
-rw-r--r--www/py-collective.templateengines/distinfo2
-rw-r--r--www/py-collective.templateengines/pkg-descr5
4 files changed, 29 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index aec73cc30003..6e088fdbb4da 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1482,6 +1482,7 @@
SUBDIR += py-cherrypy
SUBDIR += py-cherrypy-old
SUBDIR += py-clientform
+ SUBDIR += py-collective.templateengines
SUBDIR += py-cssmin
SUBDIR += py-cssselect
SUBDIR += py-cssutils
diff --git a/www/py-collective.templateengines/Makefile b/www/py-collective.templateengines/Makefile
new file mode 100644
index 000000000000..63b049e00a5d
--- /dev/null
+++ b/www/py-collective.templateengines/Makefile
@@ -0,0 +1,21 @@
+# Created by: Michelle Sullivan <michelle@sorbs.net>
+# $FreeBSD$
+
+PORTNAME= collective.templateengines
+PORTVERSION= 0.3.5
+CATEGORIES= www python zope
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DIST_SUBDIR= zope
+
+MAINTAINER= michelle@sorbs.net
+COMMENT= Template engine abstraction layer for Python
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Products.CMFCore>=2.1.0:${PORTSDIR}/devel/py-Products.CMFCore
+
+USES= python:2 zip
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/www/py-collective.templateengines/distinfo b/www/py-collective.templateengines/distinfo
new file mode 100644
index 000000000000..e9210b2281af
--- /dev/null
+++ b/www/py-collective.templateengines/distinfo
@@ -0,0 +1,2 @@
+SHA256 (zope/collective.templateengines-0.3.5.zip) = 126f85710bc56b7b04125308341d82077721205df8c9815010eea672b66d52d7
+SIZE (zope/collective.templateengines-0.3.5.zip) = 25926
diff --git a/www/py-collective.templateengines/pkg-descr b/www/py-collective.templateengines/pkg-descr
new file mode 100644
index 000000000000..b957ae871f47
--- /dev/null
+++ b/www/py-collective.templateengines/pkg-descr
@@ -0,0 +1,5 @@
+collective.templateengines is an template engine abstraction layer for Python.
+It defines generic Zope interfaces for communicating with various Python
+template engines to achieve higher code reuse value.
+
+WWW: https://pypi.python.org/pypi/collective.templateengines/