aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/c-icap-modules/Makefile3
-rw-r--r--www/c-icap-modules/distinfo4
-rw-r--r--www/c-icap-modules/files/patch-services_content__filtering_Makefile.in10
-rw-r--r--www/c-icap/Makefile14
-rw-r--r--www/c-icap/distinfo4
-rw-r--r--www/c-icap/files/patch-modules_memcached.c11
-rw-r--r--www/c-icap/pkg-plist3
7 files changed, 30 insertions, 19 deletions
diff --git a/www/c-icap-modules/Makefile b/www/c-icap-modules/Makefile
index 9db78bfd16e8..03fd0136ab29 100644
--- a/www/c-icap-modules/Makefile
+++ b/www/c-icap-modules/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= c-icap
-PORTVERSION= 0.4.2
-PORTREVISION= 1
+PORTVERSION= 0.4.3
CATEGORIES= www security
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}${PKGNAMESUFFIX}/0.4.x/
PKGNAMESUFFIX= -modules
diff --git a/www/c-icap-modules/distinfo b/www/c-icap-modules/distinfo
index a9173e39fe5f..65e0d4428c35 100644
--- a/www/c-icap-modules/distinfo
+++ b/www/c-icap-modules/distinfo
@@ -1,2 +1,2 @@
-SHA256 (c_icap_modules-0.4.2.tar.gz) = f7da6064550c842c13ffab36dd53f1427029a2e362bcf3a0375d99be469f4e29
-SIZE (c_icap_modules-0.4.2.tar.gz) = 428877
+SHA256 (c_icap_modules-0.4.3.tar.gz) = 89c0851d4fc6f6bdf7510bc1c2b23ae054db2548f68162356cfa3ca6ab1f6cde
+SIZE (c_icap_modules-0.4.3.tar.gz) = 428936
diff --git a/www/c-icap-modules/files/patch-services_content__filtering_Makefile.in b/www/c-icap-modules/files/patch-services_content__filtering_Makefile.in
deleted file mode 100644
index ee3898aeb746..000000000000
--- a/www/c-icap-modules/files/patch-services_content__filtering_Makefile.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- services/content_filtering/Makefile.in.orig 2016-01-03 23:26:06 UTC26:06 UTC
-+++ services/content_filtering/Makefile.in
-@@ -691,7 +691,6 @@
-
- install-data-local:
- $(INSTALL) srv_content_filtering.conf.default $(DESTDIR)$(CONFIGDIR)/srv_content_filtering.conf.default
-- if test ! -f $(DESTDIR)$(CONFIGDIR)/srv_content_filtering.conf.default; then $(INSTALL) srv_content_filtering.conf.default $(DESTDIR)$(CONFIGDIR)/srv_content_filtering.conf; fi
- $(mkinstalldirs) $(DESTDIR)$(cicapdatadir)/templates/srv_content_filtering/en
- $(INSTALL) $(TMPLS) $(DESTDIR)$(cicapdatadir)/templates/srv_content_filtering/en/
-
diff --git a/www/c-icap/Makefile b/www/c-icap/Makefile
index 0d842f7dc650..55977ee60afe 100644
--- a/www/c-icap/Makefile
+++ b/www/c-icap/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= c-icap
-PORTVERSION= 0.4.2
+PORTVERSION= 0.4.3
PORTEPOCH= 2
CATEGORIES= www
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/0.4.x/
@@ -20,10 +20,11 @@ CPE_VENDOR= c-icap_project
USE_LDCONFIG= yes
USE_RC_SUBR= c-icap
-OPTIONS_DEFINE= BDB IPV6 LDAP PERL POSIXSEM LARGE_FILES
+OPTIONS_DEFINE= BDB IPV6 LDAP PERL POSIXSEM LARGE_FILES MEMCACHE
OPTIONS_DEFAULT= IPV6
LARGE_FILES_DESC= Enable large files support
POSIXSEM_DESC= Use POSIX Semaphores instead of SYSV IPC
+MEMCACHE_DESC= Enable memcached
CICAP_USER= c_icap
CICAP_UID= 959
@@ -54,6 +55,15 @@ CONFIGURE_ARGS+= --enable-large-files
CONFIGURE_ARGS+= --disable-large-files
.endif
+.if ${PORT_OPTIONS:MMEMCACHE}
+CONFIGURE_ARGS+= --with-memcached
+BUILD_DEPENDS= memcached:databases/memcached
+PLIST_SUB+= MEMCACHE=""
+.else
+CONFIGURE_ARGS+= --without-memcached
+PLIST_SUB+= MEMCACHE="@comment "
+.endif
+
.if ${PORT_OPTIONS:MLDAP}
USE_OPENLDAP= YES
.endif
diff --git a/www/c-icap/distinfo b/www/c-icap/distinfo
index b5c4061e118b..4523ff6fc2e9 100644
--- a/www/c-icap/distinfo
+++ b/www/c-icap/distinfo
@@ -1,2 +1,2 @@
-SHA256 (c_icap-0.4.2.tar.gz) = b138c7d7d9828d54c3307bcfe7b4917911266593832ffc26a60df9a0dfd2511e
-SIZE (c_icap-0.4.2.tar.gz) = 642379
+SHA256 (c_icap-0.4.3.tar.gz) = c46c7ab784e623bbf4bc4261702d6708127edf71dd2312b97440ab66ee75cfbf
+SIZE (c_icap-0.4.3.tar.gz) = 643244
diff --git a/www/c-icap/files/patch-modules_memcached.c b/www/c-icap/files/patch-modules_memcached.c
new file mode 100644
index 000000000000..56f0d7ed50d6
--- /dev/null
+++ b/www/c-icap/files/patch-modules_memcached.c
@@ -0,0 +1,11 @@
+--- modules/memcached.c.orig 2016-04-30 12:42:52 UTC
++++ modules/memcached.c
+@@ -47,7 +47,7 @@
+ #include <libmemcached/memcached_pool.h>
+ #endif
+
+-#include <crypt.h>
++/* #include <crypt.h> */
+
+ int USE_MD5_SUM_KEYS = 1;
+
diff --git a/www/c-icap/pkg-plist b/www/c-icap/pkg-plist
index 1757be1dced2..bb4cd74639cc 100644
--- a/www/c-icap/pkg-plist
+++ b/www/c-icap/pkg-plist
@@ -43,6 +43,7 @@ include/c_icap/util.h
%%BDB%%lib/c_icap/bdb_tables.so
lib/c_icap/dnsbl_tables.so
%%LDAP%%lib/c_icap/ldap_module.so
+%%MEMCACHE%%lib/c_icap/memcached_cache.so
%%PERL%%lib/c_icap/perl_handler.so
lib/c_icap/shared_cache.so
lib/c_icap/srv_echo.so
@@ -50,7 +51,7 @@ lib/c_icap/srv_ex206.so
lib/c_icap/sys_logger.so
lib/libicapapi.so
lib/libicapapi.so.4
-lib/libicapapi.so.4.0.2
+lib/libicapapi.so.4.0.3
man/man8/c-icap-client.8.gz
man/man8/c-icap-config.8.gz
man/man8/c-icap-libicapapi-config.8.gz