aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/p5-Image-Scale/Makefile7
-rw-r--r--graphics/p5-Image-Scale/files/patch-Makefile.PL10
2 files changed, 12 insertions, 5 deletions
diff --git a/graphics/p5-Image-Scale/Makefile b/graphics/p5-Image-Scale/Makefile
index 411104d6a2ec..dc8d68e31f5c 100644
--- a/graphics/p5-Image-Scale/Makefile
+++ b/graphics/p5-Image-Scale/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Image-Scale
PORTVERSION= 0.08
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -13,11 +13,8 @@ COMMENT= Perl module for fast, high-quality fixed-point image resizing
LICENSE= GPLv2
-BROKEN= Uses undocumented giflib API
-
LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libpng.so:${PORTSDIR}/graphics/png \
- libgif.so:${PORTSDIR}/graphics/giflib
+ libpng.so:${PORTSDIR}/graphics/png
TEST_DEPENDS= p5-Test-NoWarnings>=0:${PORTSDIR}/devel/p5-Test-NoWarnings
USES= perl5
diff --git a/graphics/p5-Image-Scale/files/patch-Makefile.PL b/graphics/p5-Image-Scale/files/patch-Makefile.PL
new file mode 100644
index 000000000000..1e1ed2fd39a9
--- /dev/null
+++ b/graphics/p5-Image-Scale/files/patch-Makefile.PL
@@ -0,0 +1,10 @@
+--- Makefile.PL 2015-02-23 09:23:19.000000000 -0800
++++ Makefile.PL 2015-02-23 09:24:02.000000000 -0800
+@@ -144,6 +144,7 @@
+
+ # Look for libgif
+ for my $incdir ( $gif_inc, @check ) {
++ last;
+ if ( $incdir && -e catfile($incdir, 'gif_lib.h') ) {
+ $GIF = 1;
+ $gif_inc = $incdir;